Skip to main content
Adobe Photoshop Family

1 Message

 • 

140 Points

Wed, Jun 27, 2012 3:02 PM

Solved

Photoshop: CS6 polygonal lasso tool auto-completes unexpectedly

Having issues with polygonal lasso tool.

When in mid selection, the dotted line disappears - though I am able to continue making a selection, the selection seems to jump and completes itself. Also, when plotting multiple points around rounded edges, it completes the selection, as if I were to double click. The plot points are far enough away, so this should not happen.

Furthermore, when I try the "Add to Selection" feature of the tool, I make a selection to add to the areas that were affected with the above issues, it seems I am adding to the selection, but when finished, nothing happens. This feature is not working altogether.

Other than those issue, I love the new CS6 creative suite. Nice improvement and a valuable arsenal of tools for my daily tasks :)

Responses

6 Messages

 • 

112 Points

7 years ago

I am on CC. The problem is worse than ever!

6 Messages

 • 

110 Points

7 years ago

I use a wacom intuos ptk 840

2 Messages

 • 

70 Points

7 years ago

that seems to fix my problem. I only tried it once with the lasso, but it worked flawlessly.
Thank you!!

6 Messages

 • 

110 Points

7 years ago

WORKS ! ( I only tried lasso-tool as well )

Thank you Jeffrey !!!

6 Messages

 • 

112 Points

7 years ago

Hi Jeffrey, got anything for none-wacom users yet?

Adobe Administrator

 • 

15.8K Messages

 • 

295K Points

Did you try the plug in?

Sr. Product Manager, Adobe Digital Imaging

6 Messages

 • 

112 Points

Yes but it had no effect. I do not use a Wacom but I am on a iMac running OSX. It really is a weird bug... I'm the only one I personally know who has experienced it. The team members around me all have the same or similar machines but none of them have ever had the same problem. I also have a twin machine at home where I also experience the same bug. The issue has persisted for me in the last 3 versions of Photoshop (CS 5.5, 6 and now CC) although it was far less frequent in 5.5. Basically the polygon lasso tool allows me anywhere from 5-20 clicks before it freezes and then auto completes (and trust me, it isn't because of my click speed). There are also times when I need to click 3 or 4 times before it even begins a selection, or the selection line is visible on the screen.

I appreciate your help, I really do love Adobe products, it's just this one little thing can be so frustrating at times as I am sure you can imagine.

Thanks, Sean

6 Messages

 • 

112 Points

Hold on - When I installed the plug-in yesterday I checked to see if it was working and it said it was but the problem persisted. I am embarrassed to admit I did not reboot at that time. I did however reboot this morning and, in the hopes of not jinxing it, it seems to have solved the problem. I can't express how I stoked I am by this! Thank you so much for your help Jeffrey! Much appreciated!

1 Message

 • 

60 Points

7 years ago

I have the same problem , lasso tool just stops after about 8 clicks, then auto-completes when I try to continue. So the Intuous Pro I just bought is now useless. So frustrated...

The above fix does not work because I get the following message:

"Could not complete your request because Photoshop does not recognise this type of file."

15.1K Messages

 • 

195.8K Points

The plugin isn't a file that you open, it's a plugin - that you install in the plugins folder.

1 Message

 • 

60 Points

6 years ago

I got CS4 with same problem. Is there a plugin for that

1 Message

 • 

60 Points

6 years ago

Very annoying problem, no solution for windows yet?

2 Messages

 • 

70 Points

4 years ago

I am on windows 8.1 and I have the problem with this tool. I didn't found any plug-in or fix for windows. The only way I found to avoid this is :

When I use the polygon tool and the dotted line disappears (after placing a plot point), I click and move the pen on the tablet without release the pressure like a "click & drag". When I do that, the "dotted line" reappears and I am able to continue the selection.

I hope this will help.

2 Messages

 • 

70 Points

hi,did you solve the problem?

6 Messages

 • 

110 Points

Yes!

2 Messages

 • 

70 Points

Hi, for my part no, i am still searching a solution for this. But i am still working with CC 2017, maybe the 2018 version fixed it. I keep using the trick above mentioned :/

2 Messages

 • 

70 Points

how did you solve it? thank you

6 Messages

 • 

110 Points

Still working with cs6 on mac osx 10.11.6. I installed the plugin.