bianca_picarelli's profile

3 Messages

 • 

90 Points

Wed, Dec 11, 2019 12:53 AM

Photoshop: Could not complete your request because of a program error

Hi, 
I am trying to edit a psd file that I had created about 5 months ago and every time I go to open it, it reads "Could not complete your request because of a program error."  Im not sure what to do, please help ;(.

Responses

Adobe Administrator

 • 

15.9K Messages

 • 

295.3K Points

1 y ago

Is your Photoshop up to date with the 21.0.2 update that came out last night?

Sr. Product Manager, Adobe Digital Imaging

Adobe Administrator

 • 

3.5K Messages

 • 

53K Points

1 y ago

Howdy Bianca,

If the update solves your problem, please let us know.  And if it doesn't, let us know as well so we can help you out.

Thanks,
David

3 Messages

 • 

90 Points

1 y ago

I am installing an update right now with my adobe creative cloud, thank you!  I will get back to you if this does not solve the issue. 

3 Messages

 • 

90 Points

1 y ago

ok so I just updated my photoshop on my mac to 18.0.1 which is the only available version when I go to acrobat reader to update my PS.  Sadly even after the update it is still giving me the program error.

Employee

 • 

247 Messages

 • 

3.8K Points

1 y ago

Hi Bianca,
Version 18.0.1 should not be an option and sounds like a downgrade.  Do you have the Creative Cloud Desktop application installed?  If not, you can download the application from here: https://helpx.adobe.com/download-install/kb/creative-cloud-desktop-app-download.html

Once you have the Creative Cloud Desktop applicaiton installed, select the "Photography" tab in the left pane.  Then click on the "Photoshop" box.  Afterward you should see a "..." button on the top right corner of the window where you can install the latest or previous versions of Photoshop.  Here's our article with more details of updating your Photoshop.

https://helpx.adobe.com/download-install/using/install-previous-version.html

Sincerely,
Andrew