Skip to main content
Adobe Photoshop Family

5 Messages

 • 

242 Points

Wed, Oct 29, 2014 4:30 PM

Solved

Photoshop: Could not complete your request because of a program error.

i keep getting this message when i try to do anything in photoshop a second time what i mean is when first opened photoshop works when i close the first image the go to do anything else i get the message: Could not complete your request because of a program error.i have uninstalled and reinstalled photoshop cc but no difference i have taken a couple of screen shots which i hope will give you more information

i hope you can solve this problem as i am at my wits end

Responses

Adobe Administrator

 • 

15.5K Messages

 • 

291.6K Points

6 years ago

Does the problem go away if you change the Finder view to Icons, List or Coverflow?

http://feedback.photoshop.com/photosh...

Sr. Product Manager, Adobe Digital Imaging

17 Messages

 • 

200 Points

No, does not go away.

Adobe Administrator

 • 

15.5K Messages

 • 

291.6K Points

Earlier in the thread you said the issue went away for you with a new Admin user account. Are you still using that new Admin user account and having the problem again?

Sr. Product Manager, Adobe Digital Imaging

14 Messages

 • 

242 Points

On a completely new setup with same problem. (new macbook, new PS install, new user profile)

1 Message

 • 

60 Points

6 years ago

I'm having the same problem as well. I go to open a 3rd or fourth file and it says the sam error. I save and restart PH and same thing happens.
Thanks

1 Message

 • 

60 Points

6 years ago

to resolve this problem to Edit / Preferences / Type and change the Type Engine from East Asian to Middle Eastern and restart Photoshop. it worked for me

2 Messages

 • 

70 Points

6 years ago

Hi all, I'm another one with this same problem. I tried various suggestions in this thread, but to no avail.

Here is my strange circumstance though. If I am in Photoshop CC and try to hit command + O as I commonly do to open an additional file, I get the error. However, if I go to a Finder window and double click the file, it will open. I've tried it several times, back and forth.

I can open from Finder, but not Photoshop. So at this point its just an annoyance, but regardless, I would like it to work either way as intended.

I don't know if my little addition helps narrow the problem or not.

15.1K Messages

 • 

195.8K Points

Are you on MacOS 10.10? The open/save dialogs have a few problems on 10.10, the worst of which was fixed in 10.10.1, but there are still some odd errors happening that Apple is still trying to fix.

2 Messages

 • 

70 Points

I am using 10.10.1. Hopefully they will get it fixed soon, it'd be nice for it to work properly.

14 Messages

 • 

242 Points

6 years ago

I've not posted to this issue in over 20 days...hoping a new macbook and fresh user profile would resolve this issue for me.

I'm on a new install of CC2014, New user profile and yet I'm still having the same issue. I can open files on 1st launch. Then after two or three files have opened I get the old: "Could not complete your request because of a program error."

14 Messages

 • 

242 Points

Also seeing the same error message when I try to load new swatches.

14 Messages

 • 

242 Points

Removed the swatches palette and reopened photoshop. Was able to open a handful of PSD files 20 or so...but eventually the same error message reappeared.

14 Messages

 • 

242 Points

6 years ago



Screenshot showing an error that has shown up in Photoshop using the keyboard shortcut to open files (cmmd + o)

This is on a brand new macbook pro, fresh install of Photoshop CC14, and new user profile.

15.1K Messages

 • 

195.8K Points

That is a completely different issue, caused by an OS bug in MacOS 10.10.

14 Messages

 • 

242 Points

Ha! - So, I've done two things that seems to have fixed the issue for me.

1. Finder is now set to list (was on columns)
2. Removed USB overdrive (3rd party plugin)

So far so good.

Adobe Administrator

 • 

15.5K Messages

 • 

291.6K Points

Thanks Brian, if you go back to Column now that you've removed "USB Overdrive" do you still get the error?

Sr. Product Manager, Adobe Digital Imaging

14 Messages

 • 

242 Points

Funny enough - I've added USB Overdrive back while still in list view for the finder and no problems so far.

Adobe Administrator

 • 

15.5K Messages

 • 

291.6K Points

The best test would be whether column view works without "USB Overdrive" installed. That way we could tell whether USB Overdrive is the root of the problem or if it's the OS by itself.

Sr. Product Manager, Adobe Digital Imaging

Adobe Administrator

 • 

15.5K Messages

 • 

291.6K Points

6 years ago

For the other folks on this thread, how many of you are using "USB Overdrive"?

Sr. Product Manager, Adobe Digital Imaging

11 Messages

 • 

160 Points

not me.

Adobe Administrator

 • 

15.5K Messages

 • 

291.6K Points

But it sounded like your issue was caused by user permissions. When you created the new user account it worked correctly, no?

Sr. Product Manager, Adobe Digital Imaging

11 Messages

 • 

160 Points

I could not get it to work in my profile... Another user profile is of not much use... I do not have info how to resolve permissions on my own profile... I tried all the advice and no luck...so I now use older version of PS... A small nuisance and not ideal, but workable

3 Messages

 • 

80 Points

6 years ago

Is there a solution yet? I'm also getting really frustrated. I've upgraded to Yosemite 10.10.2 and am using Creative Cloud Adobe

15.1K Messages

 • 

195.8K Points

Please read the existing responses -- every case is different, and we need more information to figure out what exactly is going wrong in your case.

3 Messages

 • 

80 Points

Well, I've read the responses but understand half of the things said. So how do I get my problem solved. What kind of information do you need?

Adobe Administrator

 • 

15.5K Messages

 • 

291.6K Points

Try creating a new Admin user account and run Photoshop from the new user account to see if the problem goes away: http://blogs.adobe.com/crawlspace/201...

Sr. Product Manager, Adobe Digital Imaging

3 Messages

 • 

80 Points

Well, the problem goes away but now I cannot access any of my files on the other user? So what now? How do I transfer all my files to the new user?

11 Messages

 • 

160 Points

Ditto...

Adobe Administrator

 • 

15.5K Messages

 • 

291.6K Points

Sr. Product Manager, Adobe Digital Imaging

Adobe Administrator

 • 

15.5K Messages

 • 

291.6K Points

Prior to trying to correct the user, can you try this log generation for Mac OS X.

Switch back to the bad/affected user account, and then confirm you can reproduce the problem.

Then, to collect sysdiagnose, hit shift-control-option-command-period. The screen will flash and a few minutes later a finder window should open with an archive

Sr. Product Manager, Adobe Digital Imaging

11 Messages

 • 

160 Points

got that...what do we do with this sysdiagnose file? Thanks

2 Messages

 • 

70 Points

6 years ago

Is there a solution to this issue? I'm new to Mac and Photoshop and I've tried most of the sugguestions above that I understand and know how to do.

15.1K Messages

 • 

195.8K Points

Read the previous replies - it is not a single issue. We need more information to know what sort of issue you are encountering.

2 Messages

 • 

70 Points

I get the message when I try to either open another file after editing a jpg or when I trice to Place Embedded. I haven't done any updates or added any apps to my Mac and Photoshop was working fine until the last week or so.

15.1K Messages

 • 

195.8K Points

That sounds like you might be hitting one of the known MacOS 10.10 bugs -- which we have documented for Apple, and Apple is working on solutions for.

11 Messages

 • 

170 Points

6 years ago

Same problem here. It usual follows after i switch application and come back, which i when the brush tool won't work either...

15.1K Messages

 • 

195.8K Points

Which version of Photoshop are you using?
Which OS version are you using?
What does the PSErrorLog.txt file say?

11 Messages

 • 

170 Points

Latest version of photoshop CC, updated as soon as update was available hoping it would fix problem.

Mac os X yosemite on two macs, One iMac late 2012 and one macbook pro mid 2012

I have the same problems on BOTH computers.

PS error log here: http://adobe.ly/1MyA0Xl

15.1K Messages

 • 

195.8K Points

You are using Photoshop CC (14.2) not the latest version Photoshop CC 2014 (15.2).

And the log says you have a problem with your color profiles or color settings directory - if it happens at launch, then it would be the color settings directory; if it happens when switching apps, then the colorsync profiles or cache are more likely.

1 Message

 • 

60 Points

6 years ago

same problem here. new imac and new yosemite up to date with CC fresh install. worked fine for a week. now errors trying to open.

15.1K Messages

 • 

195.8K Points

MacOS 10.10 has well known problems in the OS open and save dialogs that can cause program errors. Some people have avoided the problems by changing the view in the OS dialogs, others have not been so lucky.
Apple is aware of these issues in MacOS 10.10 and working on solutions.

1 Message

 • 

60 Points

6 years ago

The solution is as simple as frustrating in the problem. All you have to do is to reset Photoshop CS6’s Preferences File - I have CS6, if you have other version reset that one. And also, following exactly the same steps, reset Camera Raw settings. To learn how to reset Photpshop preference file watch this great video with Julianne Kost: http://tv.adobe.com/watch/the-complet...

Don't forget to do exactly the same steps with Camera Raw.
Let me know if it worked for you.

15.1K Messages

 • 

195.8K Points

Program Errors have many different causes, and resetting the prefs may fix a few, but not all of them.

7 Messages

 • 

70 Points

6 years ago

Hello. I'm getting the same error message "your request could not be completed because of a program error". And unlike most guys here I'm running PS on Windows 7 Ultimate laptop.

15.1K Messages

 • 

195.8K Points

That is a generic "we don't know what went wrong" message. You'll have to provide a lot more information to figure out what is causing it on your system.

7 Messages

 • 

70 Points

OK what info do you need?

I'm using PS CS6 Extended, and I'm receiving this error for: color dropper tool, the sliders in replace color, draw figure (line, polygon etc). Opening and saving the documents is working fine for me, and its been only a few days since I'm receiving the error.

15.1K Messages

 • 

195.8K Points

The PSErrorLog.txt contents would help.
Have you tried resetting Photoshop's preferences?

7 Messages

 • 

70 Points

Yes I did reset the preferences, but its still same. Can you please tell me where can I find PSErroeLog.txt on my PC?

15.1K Messages

 • 

195.8K Points

That file is in your Photoshop preferences folder.

7 Messages

 • 

70 Points

2015:04:26 23:51:56 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:52:00 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:52:23 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:52:26 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:53:14 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:53:37 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:53:49 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:54:09 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:54:19 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:54:31 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 00:11:27 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 00:11:33 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 00:12:43 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 00:14:50 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 02:47:43 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 02:48:59 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 02:57:41 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:05 00:22:00 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:05 00:22:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:11:27 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:11:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:11:49 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:11:55 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:25:25 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:25:33 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:25:36 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:29:31 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 03:28:39 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 03:28:46 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 03:34:04 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 03:34:09 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:01:14 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:01:30 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:01:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:01:41 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:01:48 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:01:53 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:02:14 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:02:21 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:04:02 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:04:09 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:04:11 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:04:14 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:25:47 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:25:51 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:25:53 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:25:58 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:30:56 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:31:02 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:34:03 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:39:13 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:39:24 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:12:37 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:13:09 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:13:20 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:13:25 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:15:06 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:28:45 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:29:01 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:33:18 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:33:32 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:34:16 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:45:20 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:45:22 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:45:26 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:48:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:49:39 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:18:42 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:18:45 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:18:48 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:18:51 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:18:53 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:01 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:04 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:07 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:11 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:15 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:18 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:28 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:32 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:45 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:47 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:50 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:58 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:20:01 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:20:04 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:23:48 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:23:54 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:23:56 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:06 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:10 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:16 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:18 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:29 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:32 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:25:28 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:25:32 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:25:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:26:28 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:26:32 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:26:34 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:37 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:41 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:43 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:49 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:51 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:56 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:58 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:30:03 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:30:05 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:30:36 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:30:41 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:30:43 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:32:03 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:32:06 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:32:08 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:58:53 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 23:03:37 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 23:09:08 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 23:47:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:09 00:46:03 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:09 03:13:00 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:09 03:13:05 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:09 03:47:17 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:09 04:04:59 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed

15.1K Messages

 • 

195.8K Points

Something in your document is trying to pass a bad color mode to a layer function that expects a valid mode for layers. My guess would be shape layer tools, but resetting prefs should clear that.

7 Messages

 • 

70 Points

But I already tried that. I clicked on the "default" button wherever it appeared in preferences and it notified me that the changes will take place on next PS launch. So I closed PS and restarted it but still the same.

Is there any other way to reset preferences?

15.1K Messages

 • 

195.8K Points

That doesn't sound like you reset preferences at all. There is no such button to reset preferences in the shipping version of Photoshop.

Either hold down control-alt-shift while launching Photoshop and say "yes" to deleting the prefs, or just delete the files in the Photoshop preferences folder.

7 Messages

 • 

70 Points

No there's no "reset" button, but is a "default" button in a few categories within preferences. But I didn't know it doesn't reset it, never have faced any issue before so no experience with technicalities. Thanks for info, I'll try it.

7 Messages

 • 

70 Points

OK I tried the method you told, and the preferences are reset. Saying that, the issue is solved. Thanks for the assistance.

3 Messages

 • 

30 Points

I'm having the same problem. Have tried deleting the preference files from the Library, disabling third party plug-ins and deselecting 'Enable generator'. Nothing works. This is the error log I get:

2015:03:13 16:47:36 : /Volumes/workarea/PS_15_Mac_Daily_Retail/20141204.r.310/photoshop/main/photoshop/sources/USheetList.cpp : 246 : REQUIRE failed

15.1K Messages

 • 

195.8K Points

That error should be cleared with resetting preferences -- it means that something is holding onto some layer data with a color mode that is not valid for layers.

3 Messages

 • 

30 Points

Thanks for your reply Chris. I thought that in order to reset preferences you had to delete the preference files. Is this not correct? If not, how does one reset?

15.1K Messages

 • 

195.8K Points

Deleting the preferences files works, or holding down control-alt-shift (command-option-shift on Mac) at launch.

It is also possible that some extension panel or third party plugin could be causing the bad reference somehow.

3 Messages

 • 

30 Points

It's still not working... anything else I can try?

2 Messages

 • 

70 Points

5 years ago

PS error prompt: "Could not complete your request because of a program error." (OK button)
Desktop Mac Pro running OS X Version 10.7.5
PhotoShop vCS4 v11.0
Lightroom v4

VERY likely Culprit ---> Fonts and PhotoShop

Possible root cause in my case:

LightRoom hang began this maybe??
My instance of this issue only began happening maybe 1 month ago. I think I am correct that it only began happening after my install of Adobe LightRoom v4 hung my machine during an Import of jpegs. This curiously ALSO hung the Finder. While able to Force Quit Lightroom v4 at that time I was curiously UNABLE to ReLaunch Finder. Full freeze. Hard Power off. Hard power up. I'm pretty certain that power up was when I first began to notice this error with PhotoShop then starting up for the first time following that LRv4 freeze.

CONDITIONS of occurrence:
Only happens when PS4 is started up.
AND in that instance ONLY happens IF a document is opened.
AND in that instance ONLY happens IF the document has had the Type Tool clicked (or text actually added to the document) and then saved.

IF I open PhotoShop CS4 with no document, error does not present itself.
If I create a new, Untitled document, leave and return to PS4, the error does not present itself.
IF I quit PS4 with that new (now saved as) document left open, relaunch PS4 with that document auto-opening, the error does not present itself.
IF I click the Type tool, the error instantly presents itself.
IF I quit PS4 without saving that document, relaunch PS4 with that document auto-opening, the error does not present itself.
IF I quit PS4 after adding a letter and saving the document, relaunch PS4 with that document auto-opening, the error instantly presents itself.

My instance of this issue happens (only) when I first fire up PhotoShop CS4 and open a document that has some sort of text in it.

The error produces a variable number of repeated prompt(s) each saying the same error. However the variable is 7 (OR) 8 recurrences. I dismiss each with (OK).

Once I have:
- Fired up PhotoShop CS4 (WITH A DOCUMENT)
- Left the application (clicked on an open browser window for example)

At that time, PhotoShop produces the first instance of this error.
I switch to PhotoShop again, dismiss the 7 instances of the error (sometimes 8 instances of the error) and it does not occur again for the rest of the day.

If I quit PhotoShop, and then launch PhotosShop, THEN the above repeats itself.

I ALSO have PhotoShop CS5 installed (have had both versions installed for years now without conflicts or issues....). PhotoShop CS5 DOES NOT exhibit any of these issues.

No resolution on my part yet. I have long since forgot how to chase down Font issues in OS X (I've not added any or modified any in months and months... years?).

Does this spark any ideas to chase down? Anything I can provide to assist resolution?

15.1K Messages

 • 

195.8K Points

First, install the updates for Photoshop CS4. You should be on 11.0.2.

Start here for troubleshooting fonts and OS font caches: https://helpx.adobe.com/photoshop/kb/...

2 Messages

 • 

70 Points

Thanks for your suggestions Chris.
I'll update this after I've completed your suggestions.

1 Message

 • 

60 Points

5 years ago

I just downloaded OSX 10.11 (El Capitan) last week. I am using Photoshop Elements 11. When I try to open a .pdf file I get the message "Could not complete your request because of program error". It seems that many of the comments above were for different versions of either OSX or Photoshop.

Thanks in advance for your help.

Adobe Administrator

 • 

15.5K Messages

 • 

291.6K Points

Sounds like a permissions issue. Try creating a new Admin user account and run Photoshop from the new user account to see if the problem goes away: http://blogs.adobe.com/crawlspace/201...

Sr. Product Manager, Adobe Digital Imaging