Skip to main content
Adobe Photoshop Family

1 Message

 • 

80 Points

Fri, Dec 7, 2018 6:08 PM

Not a problem

Photoshop: Content aware tool not working

I'm trying to extend an image and when using the crop tool with the content aware box checked, it does nothing. I just used this tool yesterday with no problems. I'm assuming an update bug broke it. Any ideas??

Responses

48 Messages

 • 

1.4K Points

2 years ago

Not sure if this is the same issue, but I've caught it misbehaving like that until I changed the Background layer to a regular layer. Only happens sometimes; maybe that's worth a try?

Champion

 • 

3.3K Messages

 • 

58K Points

2 years ago

The Content Aware checkbox is not activated in your screenshot...

Johan W. Elzenga,

http://www.johanfoto.com

31 Messages

 • 

828 Points

2 years ago

I have tried to replicate your issue with no success...but I DID notice that the Content Aware box is NOT checked in your screen capture here...?

48 Messages

 • 

1.4K Points

2 years ago

It just happened to me again. What happens is you check the box, and as soon as you manipulate the crop frame, it unchecks itself. If you don't notice that happening, you get the above results. If you check it again just before you commit, it unchecks itself. Sometimes the check box is greyed out.

It's intermittent and I don't know what causes it. Once it starts I can't stop it by changing tools and changing back to the crop tool, only turning the background layer into layer 0 makes it work again.


48 Messages

 • 

1.4K Points

I think I may have figured it out. Seems to happen when there’s multiple layers and a Background layer. Turning the Background into a regular layer makes it work.

Adobe Administrator

 • 

747 Messages

 • 

16.5K Points

a year ago

Hi Jody,

Do you recall when you started seeing this? What was the last version you recall using of Photoshop where Content-Aware Scale worked? I'm trying to determine the version where it first broke.

Thank you,
Hannah

10 Messages

 • 

210 Points

Hannah - same problem with me now. Started happening this month. Before, when I used crop tool the content aware button was available whether a smart object or not. Now it's not there. I have two computers - one with Mac OS Catalina (no problems with that) and one with Mojave (where the problems lie). I don't want to update the Mojave due to its issues with other software that won't run on it. So - is it OS that's the problem, or something else? Thanks.

Adobe Administrator

 • 

747 Messages

 • 

16.5K Points

Thanks for letting us know Paul. I'm looking into it and I'll update when I know more. Offhand I wouldn't think your OS would be related, but thanks for including that information. 

Hannah

5 Messages

 • 

130 Points

10 months ago

I've been using both Edit>Fill>Content Aware and the Edit>Content Aware Fill approaches with no problem.  Not until just now, that is.  And they both worked fine a few days ago.  When the suggestions offered here didn't work, I decided to bang my head against it with something else.  My selection had been made by Ctrl-clicking an old mask and inverting it.  (I'm reworking an image I'd done probably about five years ago.)  I replaced that selection with one made with the Lasso tool, and Edit>Content Aware Fill worked just like it's supposed to.  Trouble is, I have no idea why.  You'd hope it wouldn't matter how the selection was made.

2 Messages

 • 

70 Points

9 days ago

Make sure your layer isn’t locked. 

2 Messages

 • 

70 Points

9 days ago

Make sure your layer isn’t locked