Skip to main content
Adobe Photoshop Family

8 Messages

 • 

152 Points

Tue, Jun 9, 2015 8:34 AM

PHOTOSHOP CC2014 Interface is laggy and unresponsive on the very latest hardware (OS X)

I have a BRAND new Mac Pro with 64GB RAM, D700 graphics, and a brand new install of Photoshop CC2014. I ran disk utility and repaired permissions & repaired disk. I am running 2 4K LG 4096x2160 displays. I have a scratch drive set to a USB3 drive (I do not yet have a thunderbolt drive for scratch, I will soon).

The Photoshop interface is slow and laggy. The biggest indicator is when I click on layers, there is a full second between my click and when the layer is selected. This happens on 12,000px 16-bit comps, and also on 300px 8 bit comps. File size is not the issue. It also happens regardless of what other apps (if any) are running along side Photoshop. There are almost no system processes running, it is mostly a bare bones system since it is so new. Not even Office is installed yet.

I have restarted, repaired disks, unmounted external drives, set the scratch to the boot volume (SSD), and played with the performance prefs. Nothing has fixed the issue. I am running the latest version of Photoshop.

PS is barely useable. I can get work done, but the lag is distracting and slows me down quite a bit.

An added note:

I just shut down, unhooked one display, and restarted. The issue persists.

I usually run a workspace that has almost every palette open on the second display. (It is a FANTASTIC way to work!!!) When all the palettes are open, PS slows to a crawl. If I return to the "Essentials" workspace, it is zippy and responsive.

http://i.imgur.com/e1z18y8.png

I ran Photoshop CC, CS6, and CS5 in this multi-palette workspace mode for years and years without issue. It is my preferred workspace and I cannot give it up. I need to find a solution to this issue! I just invested about $7000 in this new system, and it's performance is pretty bad!

Responses

229 Messages

 • 

6K Points

5 years ago

Hi Steve,

It would be really helpful if you could work with me to figure out which panel is slowing things down for PS. If you haven't done so yet, try closing the Libraries panel and see if that improves performance. If it doesn't, I have a few other things you can try.

Thanks,
Adam

8 Messages

 • 

152 Points

5 years ago

Adam,

I will be very happy to work with you in a resolution for this issue. I will be at work all day and will not have direct access to the system until this evening. Starting tomorrow morning I will be out of town for a week. I had to get a HUGE comp delivered today and was up until 4am getting it taken care of.

I will try your Libraries panel idea and post here when that step is completed with the result.

I run a CC2014 setup at work in an older Win7x64 machine with 96gb RAM. I have a 4K screen there as well. I'll see if I can reproduce the issue.

Thanks

15.1K Messages

 • 

195.8K Points

5 years ago

There are well known slowdowns in MacOS 10.10 that Apple is still working to solve.
The worst of these is triggered by Rulers showing in the document window, and the histogram palette (anything that draws a lot of lines). But there are a pretty good number of performance and display corruption OS bugs still waiting for fixes from Apple.

Third party plugins can also cause slowdowns - try disabling them.

And some scripting can cause slowdowns (Generator, or Event Scripts) - try disabling those as well.

70 Messages

 • 

760 Points

5 years ago

Hey Chris,

I contacted Apple's engineering team through AppleCare and they refuse to acknolwedge its anything wrong with Apple software. They once again told me to contact Adobe and when I contact you guys you tell me to talk to Apple. Its a back and forth thats been going on for 8 months

15.1K Messages

 • 

195.8K Points

Apple's general support won't admit anything, and they don't seem to have access to RADAR to search for all the known issues. You'd have to escalate the issue to someone senior before they would check for known issues.

There is a RADAR bug on this, and it shows a clear OS change in MacOS 10.10 that causes drawing slowdowns when drawing lines (like for rulers or the histogram palette).

70 Messages

 • 

760 Points

5 years ago

and the panning drawing lag issue ive been talking about since last october is now happeing on cc 2015 on windows 7 64-bit now, not just mac osx anymore. this has to be a bug in photoshop

15.1K Messages

 • 

195.8K Points

If you see an issue on Windows, then that would be a different issue.
Also, please stick to an appropriate topic instead of posting to several different topics that are not directly related to your Windows issue.

8 Messages

 • 

152 Points

5 years ago

For what it's worth...

This issue is not occuring on my Windows 7 x64 box running CC2014 (latest updates). Rulers are on, and Libraries panel is open.

I'm home from my trip, so I can check on these things on my home system this evening.

---------------S

70 Messages

 • 

760 Points

5 years ago

yeah cc 2014 runs fine, upgrade to 2015 and you'll see the problem

8 Messages

 • 

152 Points

5 years ago

For what it's worth, I just opened a 300x120px 8 bit comp and it lags heavily with the Libraries panel both open and closed. This is on the Mac Pro where the issue originated.

There is a cc2015?

8 Messages

 • 

152 Points

5 years ago

I just upgraded to cc2015. Issue still exists.