Skip to main content
Adobe Photoshop Family

9 Messages

 • 

238 Points

Mon, May 21, 2018 11:35 AM

Photoshop CC: Latest update filter gallery is not working properly

I recently updated ps cc to version: 19.1.4. Since this update, my filter gallery is not working properly. Has anyone else come across this problem? It doesn't matter which filter I apply. All drivers are up to date. The screenshot shows the problem. I've googled this but haven't found anything useful. Hopefully someone here can point me in the right direction.

Responses

952 Messages

 • 

15.3K Points

2 years ago

A lot people have problem with last version. Try downgrade for now.

Champion

 • 

1.6K Messages

 • 

27.9K Points

2 years ago

what do you mean it's not working correctly? The two filters you've applied to the image look exactly as i would expect them to...

9 Messages

 • 

238 Points

Any filter I click just turns the image either b&w or black with another single colour such as black with red/green or blue, also it won't give me any options to adjust the effect.

Champion

 • 

1.6K Messages

 • 

27.9K Points

you're saying you can't move any of the slider options which are visible in your screen shot?

9 Messages

 • 

238 Points

I can move the sliders but they have no effect. I've tried everything I can think of, default colours are set, I've signed out of the cc app & signed in again hoping it would reset anything but I still have the problem. My next step is going to be to revert back to the previous version & keep my fingers crossed.

122 Messages

 • 

2.1K Points

I'm having the same issue, along with others all of a sudden. Did you get yours fixed? How? Good Luck! 

Adobe Administrator

 • 

14.8K Messages

 • 

284.8K Points

Some of the Filter Gallery filters get their colors from the Foreground and Background colors. Try setting resetting the Foreground and Background colors to Black and White respectively.

Sr. Product Manager, Adobe Digital Imaging

Adobe Administrator

 • 

14.8K Messages

 • 

284.8K Points

2 years ago

Some of the Filter Gallery filters get their colors from the Foreground and Background colors. Try setting resetting the Foreground and Background colors to Black and White respectively.

Sr. Product Manager, Adobe Digital Imaging

1 Message

 • 

60 Points

2 years ago

did anyone get a solution to this because I am experiencing the same problem. Everything appears to be working i.e. the filter gallery appears and I can move the sliders but it has no effect whatsoever.

7 Messages

 • 

160 Points

2 years ago

I have Mac and Windows computers and am getting different behavior between the two.  On Mac, the filters from the Filter Gallery that produce colored results work properly.  On Windows, however, all the filters that are supposed to produce colored results only produce results that use the foreground and background colors.  I have to go back to CC 2017 to get the filter gallery to work properly with colored images.  I've attached an image of what happens when I try to use the Artistic > Dry Brush filter.  (I wonder if we should start a new thread about this since the original post is 11 months old???)

Adobe Administrator

 • 

14.8K Messages

 • 

284.8K Points

The photocopy setting you have is turning the color image into black and white. Disable that if you want dry brush to work on color.

Sr. Product Manager, Adobe Digital Imaging