Skip to main content
Adobe Photoshop Family

1 Message

 • 

70 Points

Wed, Feb 27, 2019 7:28 PM

Photoshop CC 2019: When I paint over an area with the brush tool to mask an area the image is not being masked completely

I'm trying to mask a CMYK image using the brush tool. When I paint over an area with the brush tool to mask an area the image is not being masked completely. It looks like I have the mask black set to like 85% or that the opacity of the brush is set to 85%. The mask black is set to 100% which should mask the image completely.



This is what it looks like:



I can draw a marquee box and do a fill of black and get the same result:



I have tried using the marquee tool with the "Add Vector Mask" button and and it works correctly. But when I use the brush tool on part of the masked area, still set to 100%, I get this:



Now I can the mask to work with the brush tool if I change the mask colors from 100% Black to 100% on all CMYK colors. Which is counterintuitive.

I've tried turning Legacy Compositing with no change.

Other things of note:

Photoshop ver 20.0.2
OS X ver. 10.13.4

Thanks for any help in advance.

Responses

Adobe Administrator

 • 

14.8K Messages

 • 

285.3K Points

2 years ago

Do you have a blend mode on the layer? The brush you're using? (It helps when making screen shots to show the layers panel, tool bar and option bar settings to help troubleshoot)

Unexpected results using a tool

Sr. Product Manager, Adobe Digital Imaging

Champion

 • 

1.6K Messages

 • 

28.1K Points

2 years ago

I see the issue. You're masking in cmyk, but a mask doesn't use cmyk values. Use a zero B value in HSB or drag the circle in the gradient all the way down to the bottom.