Skip to main content
Adobe Photoshop Family

6 Messages

 • 

228 Points

Sat, Oct 27, 2018 3:16 PM

Photoshop CC 2019: Taking too long to start

Hi, I'm having a problem since updating to cc 2019, when I try to start photoshop it just freezes on the loading screen saying "Adding Extension....Halide Bottlenecks" and stops responding, but if I wait about 10-15mins it goes past that and photoshop starts.

I have already tried disabling this extension, reset my preferences, but nothing seems to work
Please help

Responses

Official Solution

Adobe Administrator

 • 

14.6K Messages

 • 

283K Points

2 years ago

See: https://helpx.adobe.com/photoshop/kb/freeze-on-launch.html

Probably an abnormally large preset file.

Sr. Product Manager, Adobe Digital Imaging

6 Messages

 • 

228 Points

I have already tried removing all my presets and still no luck, besides that, I don't have any preset file that's too large, biggest ones are brushes with 370mb and styles 200mb, which I don't think is abnormally large, or is it?

2 Messages

 • 

70 Points

I am having the same problem. Reset the preset file and everything was fine for a couple of weeks and now, the problem is back. Also, PS is not freezing but rather taking forever to load.

2K Messages

 • 

35K Points

Do you have a lot of presets loaded again?   You might try removing them all and adding them back slowly to see how your customary presets might be affecting load times. I'd include the default presets to see if they aren't part of the problem, too. They have to add to the load in addition to your own. Patterns are often very, very large, for example. I haven't checked on how large the shipping pattern sets are, but I know mine can skyrocket the overhead for loading presets. I have many that are large, not small repeating tiles.

I have heard that some antivirus software might also be a problem—in fact, I had a problem with mine (after 20 years of never having a problem), though it was interfering with something else. If you have it running always, have you tried temporarily disabling it before launch to see if that's it?

If you're sure none of that is it, Adobe might need to know what OS you're running in order to ask about other possible reasons for the slow down.

38 Messages

 • 

502 Points

2 years ago

This reply was created from a merged topic originally titled Photoshop: Halide Bottlenecks - how do I turn them off?.

I have a problem with loading PS CC2018 - I literally go and make a cup of tea while I'm waiting.  Not great when I'm on deadlines!  When I watch the loading pane, it seems to freeze for about 5 minutes on Adding Extension....Halide Bottlenecks.  I have searched for this name, but nothing on my system matches.  I have tried disabling all extentions, but this still shows up in the loading pane.  Help!!!  please.  Going slowly nuts here.....

631 Messages

 • 

9.6K Points

Shouldn't Rieque Lopes theard be merged to emma bryan that is 2 pages long & few months older?

Adobe Administrator

 • 

14.6K Messages

 • 

283K Points

Negative. It was full of comments not relevant to the current version and present understanding of the issue.

Sr. Product Manager, Adobe Digital Imaging

6 Messages

 • 

228 Points

I've read this thread and tried almost everything that was suggested in it but nothing changed

Adobe Administrator

 • 

14.6K Messages

 • 

283K Points

I've asked an agent to connect with you directly to troubleshoot.

Sr. Product Manager, Adobe Digital Imaging

13 Messages

 • 

300 Points

Thanks so much Jeff.  I am watching Adobe Max catchups and loving what is coming in CC 

13 Messages

 • 

300 Points

2 years ago

I just wanted to update the conversation on my thread as I see a few other people are having the same issue.   I updated to Mohave upon its release.  Current status is a PS load time of 1m 24s, of which 35 seconds on Adding Extension Halide Bottle necks, and 20 seconds on Reading Pane.  Once the Splash Screen has disappeared, there are two or three more spinning balloons sessions of approx 10-20 seconds each, which I assume is something loading in the background.  So I can get to work approx 2 minutes after I have clicked to open PS. 

6 Messages

 • 

228 Points

2 years ago

Thanks for the help everyone.
I've uninstalled using the Creative Cloud Cleaner Tool, as suggested here: https://forums.adobe.com/message/10712236#10712236 , and started getting load times of 40s to 1min without adding my presets (most of the time still on the Adding Extension....Halide Bottlenecks). So to test I've added my presets one by one and it looks like one of the causes was my brushes file, that has 370mb but took my load time up to 6min.

I will now rebuild my presets from scratch and see how they affect the load times, I even got a record load time of 20secs in ony of my tests without the presets, so they are certainly the reason


13 Messages

 • 

300 Points

Hi Rieque, that is exactly what a remote access session showed up on my system - it was my 400MB of brushes.  I have added to the thread.  I'm off to rebuild my presets too. xxx

13 Messages

 • 

300 Points

2 years ago

I had a tremendously successful remote access session with Priyank yesterday who achieved a load time of just 15 seconds (YES!) simply by removing my presets - colour profiles, patterns and brushes (my brushes alone were 400MB which is apparently quite big

13 Messages

 • 

300 Points

2 years ago

I had a tremendously successful remote access session with Priyank yesterday who achieved a load time of just 15 seconds (YES!) simply by removing my presets - colour profiles, patterns and brushes (my brushes alone were 400MB which is apparently quite big!)  Current load time is approx 55s to 1m 20, not unbearable and better than the 5 minutes hanging on Halide Bottlenecks that I had been experiencing.  I had updated to PS CC 20.0.0 beforehand which may contribute, and Priyank told me they are working on making the presets more efficient.  I would like to say a HUGE personal thanks to Jeff and the team (and any contributors) for following through to find a fix - it really does make a difference when you sit alone in a studio all day cursing your equipment. Very excited by new apps in in the pipeline. 

831 Messages

 • 

13K Points

2 years ago

I hope that the return to the speed of the previous version will be quickly found ... code compiled in debug mode?


13 Messages

 • 

300 Points

2 years ago

My happy dance was short lived - although ps loading time is much improved, I am still suffering the spinning balloon for even the simplest action - approx 5 seconds each click - seems worse since my Mohave upgrade.  I am trying to strip away anything that might be impacting performance.  May start a new thread if I can't improve it alone....

13 Messages

 • 

442 Points

2 years ago

Indeed, boot time for v19 is 3s while +10s for v20. These are both clean installs btw so no extra presets.
Opening a 650MB layered psd document, 7s in v19 vs 30s in v20. That is with both versions quit before loading documents.
Besides slow boot time and opening files v20 feels more sluggish in just about everything.

Adobe Administrator

 • 

14.6K Messages

 • 

283K Points

2 years ago

Please update to Photoshop CC 20.0.1. It should fix the issue where you see a progress cursor after clicking on the canvas.

Sr. Product Manager, Adobe Digital Imaging

1 Message

 • 

60 Points

My problems started when I updated to Photoshop CC 20.01.1. It takes my PS 8-10 minutes to open. I have tried several things I have read in these threads. I do have a lot of presets and brushes. I will try to delete alot of the presets that I know I don't use, but I do use a lot of my brushes. It has been extremely frustrating especially since PS worked beautifully until my recent update. Mine lags on "reading preferences"

Adobe Administrator

 • 

14.6K Messages

 • 

283K Points

If you're still stuck, contact support directly and they can help you troubleshoot: https://helpx.adobe.com/contact.html

Sr. Product Manager, Adobe Digital Imaging

13 Messages

 • 

442 Points

2 years ago

Hi Jeffrey,

I had another issue with crashing on Render/Lighting Effects which this version cured, many thanks for that.
The progress cursor issue while brushing was fixed in v19 by allowing Photoshop to control the computer. I don't know what changed in the latest v20 update but I'm sure that it's also fixed properly so thanks again.

The slow behavior in v20 on the other hand is still there I'm afraid. Loading the same 650MB layered PSD document as mentioned above your post, still 7s in v19.1.7 but now 35s in v20.0.1

Reading Photoshop Format comes up in v20 and takes a while to finish which does not even show up in v19.

Update: Loading a RAW file from Lr into Ps (via right click Edit In) takes 7s in v19 vs 13s in v20.

Update: hmm seems Lightroom is confused here because I have added v19 as the additional external editing app but in both Edit In instances it loads up v19.

Adobe Administrator

 • 

14.6K Messages

 • 

283K Points

Thanks for confirming the other issues are fixed. Let me see if I can repro the slower file opening.

Sr. Product Manager, Adobe Digital Imaging

13 Messages

 • 

442 Points

I might have spoken too soon Jeffrey. v20 just crashed again after with Lighting Effects. Same steps in v19, no crash.
Also my brush was still in darken mode, 50% opacity and v20 felt laggy while brushing. When changing opacity back to 100% and putting the layer blend mode on Normal the lag was gone.
No such issue though in v19 which is still much more responsive then v20.

As for loading RAW's from Lr. I uninstalled v19 so Lr was forced to load v20 but it felt slower.  
So even though I do want to run the latest update (and I always make sure I do) I will still go back to v19, which seems to be updated as well?

I might even stick with v19 for a few weeks/months.

6 Messages

 • 

228 Points

2 years ago

I've updated to Photoshop CC 20.0.1 and the first loading was worse than before, even with my now much lighter preset files, and I was still having trouble opening psd files, taking several minutes to open vs a few seconds on CC 2018, so I've turned on "Legacy Compositing" on the preferences and it got even worse with the loading time, with no change opening psd files

Also, it looks like on CC 2019 photoshop is using way more memory than it was supposed to, when it is loading or opening files other apps are almost unusable

13 Messages

 • 

442 Points

2 years ago

Figured I would try the new 20.0.3 since a few versions have been released in between but still the same issue occurs with "Halide Bottlenecks" loading at startup or at least that message is showing up when Photoshop halts at startup. It's a bottleneck alright ;)
All the tips and tricks (deleting prefs, legacy compositing, etc...) don't have any effect on this issue.
So again back to 19.1.7 since this new version still doesn't work properly.

13 Messages

 • 

442 Points

2 years ago

2018 v19.1.8: https://streamable.com/yj9ts
2019 v20.0.4: https://streamable.com/i67rs

Hopefully one day 2019 will get up to speed! Until then it's back to 2018 for me ;)

6 Messages

 • 

228 Points

Exactly, I'm stuck with 2018 as well

831 Messages

 • 

13K Points

2 years ago

I have decreased the number of my group of forms and it charges faster .... I only keep about 60 shapes. It is true that I do not use all the brushes during each session!