Skip to main content
Adobe Photoshop Family

15 Messages

 • 

372 Points

Thu, Dec 3, 2015 2:23 PM

Solved

Photoshop CC 2015.1: Sub-tool reverts back to primary tool in slot every time a new document is open

Photoshop CC 2015.1 Release, Line tool (U) reverts back to Square tool everytime a new document is open. This used to remain on the previous selection (Line Tool). Very annoying with the latest release. Adobe please address.

Responses

36 Messages

 • 

652 Points

5 years ago

No, because i don't find it in this post nor any other.

220 Messages

 • 

4.5K Points

5 years ago

Ok, I'll try and find it for you. In the mean time you can try this; whatever tool you want it to default to, put it first (at the top) of the Toolbar subgrouping. For example, I like Healing Brush to be the default choice so it's at top.



Also, as glitchy as PS has become I avoid this altogether by not sharing shortcuts for tools. As you can see for example the "H" key is dedicated to one tool and not shared between them.

Here's a link that might help you out.

https://forums.adobe.com/thread/2051410

36 Messages

 • 

652 Points

5 years ago

Updated Photoshop to Today's (March 16th 2016) update... The issue remains...

15.1K Messages

 • 

195.8K Points

Photoshop hasn't had an update since January, are you confusing the Camera Raw update with a Photoshop update?

36 Messages

 • 

652 Points

No.

11 Messages

 • 

238 Points

This is such an annoying issue. I can't believe they haven't fixed it yet. 

15 Messages

 • 

372 Points

To follow-up, I confirm that the issue continues to occur on PS CC 20160113.r.355 x64

8 Messages

 • 

124 Points

5 years ago

Yea still broken, but only when you close Photoshop and reopen. The new document part is fixed.

15.1K Messages

 • 

195.8K Points

Again, Photoshop hasn't had any updates since January (16.1.2 update).

8 Messages

 • 

124 Points

Is this a known issue, that's going to be fixed?

18 Messages

 • 

258 Points

5 years ago

I also still have the problem using PS 2015.1.2 on a Mac running OSX 10.9.5. Deselecting "Show Start Workspace..." in Preferences>General did not help for me.

1 Message

 • 

60 Points

5 years ago

My "Show Start Workspace" was already unchecked and the problem still persists

4 Messages

 • 

92 Points

5 years ago

New Install of Photoshop 15.1.2 on Mac OS X 10.11.4 and the issue still persists. Any updates on a possible solution? Turning off Start Workspace did nothing to remedy. 

Adobe Administrator

 • 

15.4K Messages

 • 

291.4K Points

Did you restart Photoshop after disabling the Start Screen?

Sr. Product Manager, Adobe Digital Imaging

4 Messages

 • 

92 Points

Yes and tried a full Mac restart when that didn't work.

11 Messages

 • 

242 Points

4 years ago

My reaction when they've FINALLY FIXED IT (For now) @ 1:13 (think of "paddy" being the bug, the fortress being Adobe and "Thorgal" the patch fix )

"OOOOOOOOOOOOOH YES!!!"

https://www.youtube.com/watch?v=U1kFj_nHt0Q

8 Messages

 • 

124 Points

4 years ago

Still not fixed for me. See video.

Open photoshop, then press G. Switches to gradient tool.

https://youtu.be/ivbWwP-T65I

Adobe Administrator

 • 

15.4K Messages

 • 

291.4K Points

Your video is private. 

Sr. Product Manager, Adobe Digital Imaging

8 Messages

 • 

124 Points

fixed, sorry

11 Messages

 • 

242 Points

Not fixed. It's a shame....

11 Messages

 • 

238 Points

4 years ago

Not fixed for me either. So idiotic that we have to deal with this stupid bug for so long. 

2K Messages

 • 

35K Points

Seems to be working here 2015.5 release. I can't make it NOT work. Perhaps it's just some versions of an OS, or you need to reset your Prefs?

8 Messages

 • 

124 Points

4 years ago

Same issue on Windows 10

11 Messages

 • 

238 Points

4 years ago

Verified still broken here

Adobe Administrator

 • 

15.4K Messages

 • 

291.4K Points

4 years ago

Sorry. We thought the KBSC issue was fixed by the change to retaining the state of the toolbar between launches with the start screen (original issue on this and other threads). We have a bug logged for this variation with KBSC and sub-tools - and in progress for this thread: https://feedback.photoshop.com/photoshop_family/topics/photoshop-cc-2015-1-1-tool-shortcuts-resettin...

Sr. Product Manager, Adobe Digital Imaging

8 Messages

 • 

124 Points

4 years ago

Fixed finally, yay a year later.