Skip to main content
Adobe Photoshop Family

1 Message

 • 

240 Points

Fri, Dec 11, 2015 3:21 PM

Photoshop CC 2015.1: CC libraries failure blocks entire program

Latest Photoshop CC, 2015-12-11, Mac. I am rushing to complete a project. Made a swatch. Now got "Waiting for Libraries" modal dialog AND CANNOT DO ANYTHING ELSE. Not Save, not Quit, not Cancel, nothing. I don't even want or use the wretched Creative Cloud libraries. Totally unacceptable - please fix urgently!

Responses

Employee

 • 

142 Messages

 • 

2.5K Points

5 years ago

Hi,

Sorry for the stoppage. If you haven't tried yet, can you reboot your system. If Ps is still blocked, try ESC key to dismiss that progress dialog.

regards,
steve

4 Messages

 • 

112 Points

Experiencing this particular issue for the first time. ESC key does not dismiss the progress bar. I see that this was first posted 3 months ago. Had to force quote and I've now lost work because of this. Not cool. If someone is paying a monthly subscription fee they ought to get appropriate updates.

4 Messages

 • 

112 Points

force *quit. So far the Libraries feature has brought about an equal amount of benefits and problems.

1 Message

 • 

60 Points

or at least good responses...

9 Messages

 • 

314 Points

PLEASE FIX YOUR SOFTWARE. THIS IS HORRIBLE.

4 Messages

 • 

112 Points

I just had this issue again ... 6 months later. Working on a document/design, tried to save a color as a swatch and got this annoying little popup that never went away (same as Devin's post below).
Also, locked up Photoshop. Also also, locked up some of my OS X functionality—could't properly switch between applications. So, force-quit it is. Luckily lost only a few minutes of work this time. I have unchecked Add to libraries although this seems a little different.

Boooo. :(

Adobe Administrator

 • 

15.5K Messages

 • 

291.9K Points

It may help if we could see your Photoshop System Info. Launch Photoshop, and select Help > System Info... and copy/paste the text in a reply.

Sr. Product Manager, Adobe Digital Imaging

4 Messages

 • 

112 Points

Happy to do so. Can you provide an email address or upload form? I'd rather not post it all here. Thanks.

1 Message

 • 

60 Points

Mine is doing the same lock up thing while saving color swatches. I don't want to reboot and lose my work!

6 Messages

 • 

116 Points

5 years ago

I'm having this issue as well. It happens when trying to copy in artwork from Illustrator as a Smart Object. When I use the Esc key it stops the dialog AND the copy of the object. So I'm at an impasse. Critical for me to have vector smart objects in my docs.

Employee

 • 

142 Messages

 • 

2.5K Points

Hi Lisa,

When you're at the paste dialog, uncheck the option to Add to library, then click OK. Does that work?

6 Messages

 • 

116 Points

Yes! THANK YOU!!!!

6 Messages

 • 

116 Points

This also seems to be a problem when using "Add to Swatches" - hanging up on the Waiting for Libraries dialog. Seems like a global Libraries issue that will continue to pop up for multiple processes - any idea where to start with fixing this?

Employee

 • 

142 Messages

 • 

2.5K Points

Hi Lisa,

I'm looking at this issue in more depth. The progress dialog is expected to only display on Quit, AFAIK. I suspect that a background process which CC libraries uses for shared cache isn't working properly.

thx,
steve

6 Messages

 • 

116 Points

Thanks Steve. I think this part of a bigger issue. I spent hours today with support and he came to the conclusion that it's a Mac issue, specifically with my user account. I have to take it from here. Appreciate you looking into it.

1 Message

 • 

60 Points

It's not just a Mac issue, I'm having the same problems on a Lenovo.

10 Messages

 • 

224 Points

I'm having the same problem on a Windows 7 64 bit PC. I made the mistake of creating a library and now one of my smart objects is useless because it takes so long to load the library.

2 Messages

 • 

110 Points

I am also having this same issue on a Lenovo. When pasting the smart object into Photoshop, I unchecked the "Add to library" option and this worked for me. What a relief! I am glad I found this forum and am able to stop the issue but I really wish it would not have that box checked by default. So many CC users are going to be tripped up by that.

On the other hand, if I did in fact want to add it to the library....why is it getting held up anyway? The progress bar gets to about 90% and stops. .

1 Message

 • 

60 Points

Absolutely same problem Lisa has - I have. I cannot work!!! Please provide option to switch off Libraries.

1 Message

 • 

60 Points

Same problem on a Macbook Pro.

2 Messages

 • 

72 Points

Same.

2 Messages

 • 

72 Points

See Alicia Quickel's response below; "did you try unchecking the 'Add to libraries' in the paste options dialogue box?" 

This actually fixed the issue for me, and was able to paste in the smart object from illustrator without it getting stuck in dead space.

2 Messages

 • 

70 Points

It did also work for me but is more of a workaround, unless you don't use libraries.

3 Messages

 • 

82 Points

Same problem. Lost a huge revision to a file. 
Reboot and it happens again. 
Fix this damn it.

1 Message

 • 

60 Points

unchecking "add to libraries" worked for me.  thanks Patrick

1 Message

 • 

60 Points

5 years ago

I am also having this exact problem on a Windows 10 64bit PC. It's incredibly frustrating as I am also on a deadline and can't get any work done.

Employee

 • 

142 Messages

 • 

2.5K Points

Hi Jerry-Does ESC dismiss the dialog so you can continue? Or do you need to use the Library assets for your work?

2 Messages

 • 

110 Points

Jerry, did you try unchecking the "Add to libraries" in the paste options dialogue box? That has helped a few of us =)

1 Message

 • 

60 Points

thanks a lot !!!!! so simple... damn

2 Messages

 • 

70 Points

thank you very much Alicia for your support

2 Messages

 • 

90 Points

5 years ago

Very annoying. I need vector images as well. Anyone find a workaround at least temporarily?

Employee

 • 

142 Messages

 • 

2.5K Points

Hi Nicole-You should still be able to copy/paste vector data from AI into Ps. Just make sure to uncheck the 'Add to Library' box in the paste options dialog.

2 Messages

 • 

90 Points

Thank you!

1 Message

 • 

60 Points

Thank you... It worked :D ...God bless you

1 Message

 • 

60 Points

Thank you!

1 Message

 • 

60 Points

Thank you... It worked :D ...God bless you

2 Messages

 • 

70 Points

Thank you... Thank you..... Thank you... it worked....

2 Messages

 • 

90 Points

5 years ago

Thank god for this forum spent so much time looking for a solution.
So ridiculous Add to Library is a default that this is a default.

1 Message

 • 

62 Points

5 years ago

Thanks, SG! Yet another CC "bug" in my opinion. Should be UNchecked by default.

1 Message

 • 

60 Points

5 years ago

This is definitely a bug. At some point they updated Photoshop CC and other apps. It was then that adding a color to your swatches gave you the option to add it to the new online libraries. Unfortunately adobe is sitting on their ass over this unacceptable error because this is a common activity that results in the complete stalling of the program. I finally realize you could just move the cursor over the cancel button and click out of it even though it doesn't look like the regular cursor. Horrible implementation of the new libraries feature.

1 Message

 • 

102 Points

5 years ago

 just we need to unclick the right button on Add to my current library. Thats it done.

1 Message

 • 

62 Points

Perfect, thanks.

3 Messages

 • 

124 Points

5 years ago

HUGE thanks! Oh Adobe...

1 Message

 • 

80 Points

5 years ago

I am also having a similar issue, but not with placing a Smart Object. When I add a swatch to the libraries it brings up the Progress Bar, won't process, won't go away, and I can't use anything else in Photoshop, which forces me to Force Quit the program and lose my work. This is such a pain... Anyone know a solution?

1 Message

 • 

62 Points

5 years ago

UNCHECK "Add to my current library". If you are on a group network (Secure with Firewall), or on a Ad Agency CC Account and not your own personal CC then it is trying to find the companies cloud Library vs. your own Library. That's what it is searching for but does not have access to (Adobe's bobo'd devs didn't think of this user scenario), most likely an admin setting in your IT group.

Just uncheck Libraries unless you really want to get into the headache of using them.  

CC 2015 is a donkey compared to 2014. Lame. Been using PS since v 3.0 and this is the worst iteration since. 

1 Message

 • 

62 Points

Thanks. Helped after I lost about an hour's worth of work. Lame indeed.

1 Message

 • 

82 Points

1 year after and CC2017 still has the same issue, software is still horribly bugged.. why is this PoS software so expensive?

1 Message

 • 

80 Points

5 years ago

adobe is such a < profanity removed by admin > to sit on such a CRITICAL ISSUE. i HATE this company!

2 Messages

 • 

70 Points

5 years ago

Fix for me was to sign in to Creative Cloud, restarted Photoshop, and then your libraries will be available to add the Smart Object to. 

1 Message

 • 

60 Points

5 years ago

Lost a couple of hours to this one. Brainstorm here Adobe, how about not having the breaking bug set as the default :-) Thanks to others.

9 Messages

 • 

314 Points

5 years ago

Please add a PERMANENT and SINGULAR PLACE TO DISABLE YOUR HORRIBLE HORRIBLE cloud libraries. Your desperate attempt to force everyone into using your poorly executed attempt at a "cloud solution" is a disgrace. And here we all are, paying monthly fees for software that has no stability or competent staff to troubleshoot or fix it. Utterly disgusted with you Adobe. Can't wait until somebody Ubers you right out of business.