Skip to main content
Adobe Photoshop Family

3 Messages

 • 

204 Points

Wed, Jun 17, 2015 10:32 AM

Solved

Photoshop CC 2015: Slow panning and zooming with rulers showing

Photoshop 2015 is slow when zooming out / in or panning. This didn't happen on the same (Windows 7) computer with the 2014 version.

Responses

Official Solution

Adobe Administrator

 • 

15.5K Messages

 • 

291.6K Points

5 years ago

This issue should be corrected in the Photoshop CC 2015.0.1 update which was released today. Details here: http://blogs.adobe.com/crawlspace/201...

Sr. Product Manager, Adobe Digital Imaging

Employee

 • 

229 Messages

 • 

6K Points

5 years ago

Try disabling Rulers. That should get performance back to normal for you.

9 Messages

 • 

606 Points

Glad you guys are already aware of this problem, and it's workaround!

3 Messages

 • 

80 Points

Disabling rulers definitely helped, but I hope there's a fix. We need those rulers to work!

5 Messages

 • 

190 Points

latest version of photoshop, still have this issue

5 Messages

 • 

102 Points

5 years ago

Had the same problem as Bart, but Adams solution worked, but does that mean we just have to do without them ?

15.1K Messages

 • 

195.8K Points

5 years ago

Make sure your video card driver has been updated from the GPU maker's website.
If that doesn't work, then try disabling GPU support in Photoshop, relaunch Photoshop, and see if the performance is any better. If so, then we'll need to get details about the GPU in your system.

3 Messages

 • 

204 Points

5 years ago

With rulers off problem is solved, but with rulers on still slow. It doesn't matter if GPU is on or off.

9 Messages

 • 

218 Points

5 years ago

just found this this thread...

is this a bug or is it correct to work like this? I don't think showing or hiding the rulers shouldn't affect the panning at all?

I'm running the current drivers for my gtx980. nothing to update there and it still works fine unter cc2014

9 Messages

 • 

606 Points

It shouldn't. I'm sure it's a bug that went unnoticed, or was noticed too late to fix.

9 Messages

 • 

218 Points

5 years ago

even when i disable the gpu support, it's still slow when the rulers are on. seems uneffected by this.

though disabling the rulers isn't an option. you can't use the crop tool properly if the rulers are hidden, please fix this.

5 Messages

 • 

102 Points

5 years ago

Without ruler the zooming and panning works much better, but it had no influence whatso ever if im using gpu or not... but other than zooming and panning, performance seems very bad, drawing just seems laggy, camera raw module is unusable slow... using CS6 again.... what a relief soo much faster in everything.. It apparently uninstalled cc2014 when it installed cc2015.. I think i'll be using cs6 again

3 Messages

 • 

204 Points

5 years ago

ah now I have 2 corrupt Photoshop versions 2014 and 2015, both not working, thaks to Windows reset after tip of installing new graphic driver. How do I get at least one version of Photoshop back?

5 Messages

 • 

102 Points

Hi Have you made it work again, I also updated my gfx driv for nvidia GF850M and now the 2015 stopped working all together regardless of which gfx card intel or the GF is used to start photoshop. :(

5 Messages

 • 

102 Points

ohh.. found this http://feedback.photoshop.com/photosh...
- Corné van Driel solution helped me there

5 Messages

 • 

104 Points

5 years ago

Same here. Win 8.1 64, GTX 770. Latest drivers. 2014 - very smooth everything. 2015 - hand tool is very slow. (Yes, I know about rulers and ect.) Adobe, please, do not break that works with any new major release.

1 Message

 • 

80 Points

5 years ago

same here Imac 27" 3.4 GHz Intel Core i7 8GB 1600 MHz DDR3 NVIDIA GeForce GTX 680MX 2048 MB
Also with quick selection tool same issues..... HELP!

Come on, must be a joke no?

31 Messages

 • 

342 Points

Hello! same problem, add me in Skype:devmost

thank you.

2 Messages

 • 

72 Points

5 years ago

Disabled rulers made it slightly faster.
Disabled GPU made it slightly faster again.
Restarted PS
Enabled GPU to basic mode
Restarted
Vast Improvement
Changed to ADVANCED GPU
much smoother now, basically how I expect it to be.

Enable Rulers... Goes back to terrible.
Disable Rulers... Goes back to smooth.

Definitely should not have performance impacted so heavily by rulers. I unisntalled the 2014 version so I can't test but I never noticed any issues like this in the 2014 CC.

Win 7 Pro
GTX 770
Intel i7-5820K
32GB RAM

Hope this helps with getting it fixed.

2 Messages

 • 

72 Points

+ Initial state was Advanced GPU mode with Rulers on

1 Message

 • 

60 Points

5 years ago

Same problem here. I even grabbed a new machine for our designer, improved a little (she was sitting on an older machine and needed the upgrade anyways), but can see she still works without rulers...

New rig:
Win8.1
i7 5500U / 2.4 GHz
512 GB SSD
8GB RAM
NVIDIA GeForce 840M 2GB

Hope a fix will be released soon or at least an announcement.

My onboard intel-hd isn't doing well either...

1 Message

 • 

10 Points

5 years ago

Same problem here, disabling rulers works but...

i7/16GB RAM/Quadro 4000/Win8.1Pro

3 Messages

 • 

132 Points

5 years ago

Same problem!

i7 / 24GB / R9 270X / Win 8.1 Pro