michael_jenkins_7050051's profile

11 Messages

 • 

170 Points

Fri, Jan 30, 2015 11:00 PM

Photoshop CC 2014: Running with 200% scale for the UI degrades performance

The aesthetics of this feature are great, however the blow it gives my performance makes it unusable. I am using a Dell P2715Q 27" 4K display, 16GB Corsair RAM, 120GB Crucial SSD as boot and scratch disc, and XFX R7 250X GPU; all in Windows 7. I was running PS CS5, but decided to do a trial run with PS CC 2014 due to the ridiculously small UI in CS5 at 4K resolution... The performance slow down from CS5 to CC 2014 is ridiculous with the 200% UI enabled, and disappointing even without it. My actions that run lightning fast on CS5 take a significant amount of time in CC 2014. All in all, I will be reinstalling my CS5, and reducing my resolution to standard high definition again... unfortunate that my brand new screen has to be held back to half of it's capabilities due to poor development on Adobe's part.

Note: This conversation was created from a reply on: Photoshop: Introducing scale the UI 200% for high-density displays for Windows.

Responses

Official Solution

Adobe Administrator

 • 

15.9K Messages

 • 

296.4K Points

6 y ago

This should be fixed in the Photoshop CC (2015) update.

15.1K Messages

 • 

195.8K Points

7 y ago

OK, for everyone else CC runs faster or the same as CS5. So you need to check your system to see what might be slowing down CC.

And yes, drawing on a high res display is a bit slower than drawing on a low res display - which can be hidden by a good GPU, but not all GPU drivers are yet optimized for high res displays.

2 Messages

 • 

70 Points

7 y ago

As a result of problems, I had a CS rep give me a couple months free subscrip to CC or whatever, in a tel conversation, but my account is still billed in the month after. Adobe has problems deeper than consideration for its hi-rez customers.

The dinosaurs never saw it coming.

15.1K Messages

 • 

195.8K Points

7 y ago

That needs a new topic, as it has nothing to do with this topic.

11 Messages

 • 

170 Points

7 y ago

The only thing that makes it slower is initiating the 200% UI feature. If I disengage it, it is comparable to CS5 speeds, though still notably slower- if I activate this feature, it slows down unbearably. The resolution is the same while running both programs, the only variable is this feature. I am running the same preferences as I was in CS5. Also of note, the speed on CS5 doesn't change regardless of the resolution. My system is in good shape, I don't know what would be wrong there. Just sharing my experience, if there are additional details I can provide to be of assistance I gladly will.

11 Messages

 • 

170 Points

7 y ago

I have tinkered around with this feature a bit more, as I would truly love to move out of my CS5 software and utilize my 4K display to it's fullest. I have spent the last 2 days playing with every setting imaginable on my system and in my PS CC 2014 software. I have the performance of CC almost identical to my CS5 in every way while using 4K and disabling the 200% UI feature. Actions run comparably, and all features check out. Enabling the 200% UI feature, for some reason, doubles my wait times on every action I run. I definitely appreciate the 200% feature, and respect that it is a Experimental Feature (I can't wait for the Bridge team to at least make it this far), however doubling my workflow for the sake of utilizing my screen to it's full potential is illogical. Back to CS5 and standard high definition editing I will go.

But rest assured, when the scaling issue is sorted out with PS CC and Bridge CC, I will be the first in line to subscribe!

Employee

 • 

230 Messages

 • 

6K Points

7 y ago

Michael,

Is there an action you can share that's running slower in 200% vs 100%? I just ran some quick automated performance tests and didn't see much of a difference between the two settings. @ 200% we are pushing way more data around (compared to 100%) but it still shouldn't have a significant impact on your workflow.

Thanks,
Adam

11 Messages

 • 

170 Points

7 y ago

Hi Adam. Unfortunately, the actions I am using are not of my own invention. They are Florabella Colorplay actions that I purchased, and the terms of purchase specifically prohibit sharing. I will grant that these actions are instigating a lot of changes at once on very high resolution images, on a very high resolution screen. It would make sense that they would be slower overall when compared to their performance on a lower resolution display, however I still fail to see how activating the 200% UI feature can cause such a dramatic slow down. This feature is only enlarging the UI; the canvas size and all elements of the image being changed should hypothetically remain the same, correct?

Employee

 • 

230 Messages

 • 

6K Points

7 y ago

Michael,

I'm investigating this now and have the Florabella Colorplay actions to test. I'm seeing the difference between 100% and 200% in performance when running the Color Perfect action (haven't tried the others yet). What I've found in my tests is that if I hide both the Actions palette and the Layers palette, that 200% runs just bit slower than 100% (1/2 sec difference in a ~8 sec operation). Can you try running the action with those panels hidden to see if performance is better on your system?

Thanks,
Adam

1 Message

 • 

60 Points

6 y ago

Hi. Unfortunately I am facing the same problems: using 200% UI scale feature PS performance significantly drops down using actions.
Very looking forward for a solution.

Thanks

11 Messages

 • 

170 Points

6 y ago

Beautiful, I will be watching for its release.

Employee

 • 

230 Messages

 • 

6K Points

6 y ago

The update is available now. Have at it :)

11 Messages

 • 

170 Points

6 y ago

Sweet, I'll update and implement! You guys rock!

1 Message

 • 

60 Points

6 y ago

Hi Good morning. Even with the update applied we are still seeing a slow down in performance when using big files (psb - 4gb and up). Efficiency will spike up and down. We are using secondary drives (1TB) for our scratch disks. Dell XPS 8700 - 16GB Ram. We've tried uninstalling/reinstalling - with adobe cleaner tool as well. Primarily on zoom ins/outs. Multiple crashes - the event viewer does show an application crash.
Any suggestions? Thank you in advance.
Something to note - i fixed one of the crashes by changing the log-in. So we have multiple memberships, however one of them constantly said try, instead of install. Under that log-in photoshop would crash every 20 minutes. When logged in with a different account, the crashes stopped... we also uninstalled/reinstalled