Skip to main content
Adobe Photoshop Family

39 Messages

 • 

946 Points

Thu, Jun 13, 2019 3:26 PM

Photoshop: Background saving no longer as fluid and non-interruptive as it was previously

For about a month, near the end of the saving process, Photoshop is giving me the spinning beach ball for 5-10 seconds, locking me out of working or even moving windows when it gets close to 90% done. This is horribly disruptive and not the way it worked previously. My coworkers have the same issue.

Responses

114 Messages

 • 

2K Points

a year ago

Hello there. That is one of my issues too and while what I'm going to share is NOT really a good answer I am doing that for now because I am not a happy camper. I was saving everything to a remote drive, not the cloud, but a stand alone drive. It was fine for a while, then like you and your coworkers I could have taken a lunch break before the saving process was done. 


This is what was suggested to me: Save what is being worked on to the local drive. 


What? Well, I think I'm a clown at a circus because I am working on dozens of things at one time and I'm not that good of a juggler. That seems to work and as I said it isn't a "FIX" but I have to move forward. 


Let's talk about [copy] [paste]! I'm going to keep looking and writing until PS is fixed, It is broken and I want Adobe to know!! 


Good Luck! 

Champion

 • 

1.6K Messages

 • 

27.8K Points

a year ago

You need to provide a whole lot more info if you folks to help...

- which version of Ps?
- which OS?
- how large are the files you're saving?
- where are you saving them to? local? network?

etc etc.

39 Messages

 • 

946 Points

a year ago

PS 20.0.4
MacPro 3.7 GHz Quad-Core Intel Xeon E5
128 GB
MacOS 10.14.5
Saved across a gigibit ethernet network via AFP or SMB to new MacMini on a SSD connected via Thunderbolt

Files approx 80M/200M


Champion

 • 

1.6K Messages

 • 

27.8K Points

saving over the network is probably what's causing the issue. There's a thread over here which might have useful info:

https://feedback.photoshop.com/photoshop_family/topics/photoshop-cc-cannot-save-anywhere-but-a-local-drive

31 Messages

 • 

512 Points

a year ago

Wow, what a thread you linked. I know all about that issue. We’ve also been suffering the same thing for as long as everybody else. I hope yesterday’s work around of turning off the thumbnail and writing preview set to “never” works.

Seeing how this issue only popped up around a month ago, I doubt it’s related to that. I plan on testing it by launching an older version of Photoshop and seeing if I get the same result.

31 Messages

 • 

512 Points

a year ago

OK, so this issue, which was never formally acknowledged, has ACTUALLY been fixed by 20.0.6. While this is encouraging, the lack of acknowledgement and and the MONTHS of frustration and interrupted workflow are yet another Adobe slap in the face.

That said, 

Thanks Adobe. I acknowledge and appreciate your shadow efforts to right wrongs.