Skip to main content
Adobe Photoshop Family

4 Messages

 • 

300 Points

Wed, Feb 26, 2020 1:37 PM

Photoshop 21.1.0: "New Layer" and "New Group" buttons in the Layers panel stay down after clicking on it and become unusable

Hello,

since the last update, almost every time I click on the New Layer and/or New Group buttons in the Layers panel, the buttons become stuck and unusable. I have to restart Photoshop to reset their state.
Not game breaking but definitely annoying.


Regards

Responses

Official Solution

Champion

 • 

881 Messages

 • 

19K Points

5 months ago

531 Messages

 • 

12.2K Points

7 months ago

I can confirm. This has happened to me on two occasions after the 21.1.0 update.

I had been working on a document which I had already added quite a few layers then all of a sudden when trying to create a new layer, the Create New Layer button on the bottom of the Layers Panel  becomes unresponsive. I have to save my document and restart Photoshop.

I can't reproduce as it's a random thing for me but it has happened.

I have the latest Windows OS. All drivers are up to date.

3.5K Messages

 • 

52.9K Points

7 months ago

Howdy Julien and Rosa,

You're both on English Win10?  How frequently does this happen?  Other apps running at the same time?  Any 3rd party plugins?  What about your network -- how stable is it?  Could you have been down/uploading a file in the background, particularly a large cloud doc?

I'd like to dig into this and figure out the trigger.  Any additional info is appreciated.

Thanks,
David

4 Messages

 • 

300 Points

Hi David, thanks for looking into it.

To answer your questions :
- I'm on a French language Win 10 Pro x64 v.1909
- It happens fairly often but I failed to find a way to recreate it consistently.
- The other apps I'm running are usually Outlook, Chrome (up-to-date), Microsoft Teams
- No 3rd party plug-ins
- I don't have any issue with my internet connection, but my work files are on a local network, which can sometimes lag a little when opening or saving files.

I noticed that if there's a delay when clicking on these buttons they stay down until the lag ends. Maybe that's where it can bug out?

Hope it helps.

531 Messages

 • 

12.2K Points

Hi David,

Yes, I'm on English Windows 10.

This has happened to me twice since 21.1. update. 
I had Google Chrome open as well as my mail app, Outlook.
I wasn't using any plugins at the time.
I wasn't downloading any files.
External hard drive attached which is fine and no issues with.
No issues with my internet connection.

I had only created 2 pieces of artwork since the update.

I can remember exactly what happened with my last piece. 

The Create New Layer button became unresponsive towards the end of a photo-manipulation artwork which had a total of 43 layers. I needed to add a last layer for some brushwork. The document size was only 17.9M/433.2M 

I had to save my work and restart Photoshop and the button became responsive.

The previous time this happened would have been a similar scenario. 

3.5K Messages

 • 

52.9K Points

Thank you for these details.  I don't yet have the cause, but this info will help.

Thanks,
David

4 Messages

 • 

208 Points

7 months ago

Mine too. But also the trashcan & add mask button. I haven't used either yet on this project but they are blacked out. Yes Win10. Has happened on/off since last update. Only other program I have open is chrome (always have & never had issues before!) Network fine, just me, no downloads/uploads.  

7 Messages

 • 

182 Points

7 months ago

This has also been happening to me. English windows 10. Using Lazy Nezumi and Coolorus 2.5, but the issue still happens without them. 

531 Messages

 • 

12.2K Points

7 months ago

Hi David,

Yes, I'm on English Windows 10.

This has happened to me twice since 21.1. update. 
I had Google Chrome open as well as my mail app.
I wasn't using any plugins at the time.
I wasn't downloading any files.
External hard drive attached which is fine and no issues with.

I had only created 2 pieces of artwork since the update.

I can remember exactly what happened with my last piece. 

The Create New Layer button became unresponsive towards the end of a photo-manipulation artwork which had a total of 43 layers. I needed to add a last layer for some brushwork. The document size was only 17.9M/433.2M 

I had to save my work and restart Photoshop and the button became responsive.

The previous time this happened would have been a similar scenario.



3.5K Messages

 • 

52.9K Points

7 months ago

Wow, so both platforms.  Not good.  Flay, did you have Chrome open as well? 

Otherwise, perhaps this is a speed or workflow issue -- did you click the mouse several different times rapidly or move your mouse around and click or similar actions that might "stress" the UI?

Thanks,
David

531 Messages

 • 

12.2K Points

David, no, did not click the mouse several times. When I realised that my new layer wasn't added, I thought it must have been something I'd done. So I went to click add a new layer and saw the Create New Layer button greyed out. As mentioned prior, I already had something like 46 layers in my document. So it's not as if Create New Layer button hadn't worked before in the same document.

I stress, that this only happened since 21.1 update. I don't believe it's a workflow issue as I've been doing this type of work for 5 years and in all my experience with Photoshop, I've never encountered this issue before. 

I have a decent machine that was built for PS. I've encountered another couple of bugs which I've reported beside this one since the 21.1 update. 

531 Messages

 • 

12.2K Points

David -  I'm working on a piece right at this moment. I have not used any Plugins, no issues with my PC etc. and I cannot add a Group or New Layer via the bottom of the Layers Panel as those options are 'greyed out' as you can see below. I have 4 groups and 23 layers. I now have to save my work and restart Photoshop. 

P/S I've decided to work in PS 20.0.8 with no issues. 


3.5K Messages

 • 

52.9K Points

Hi Rosa,

Ugh!  That's not right.  8-(  I'm sorry.

So, my question about the mouse clicks was to rule out a different cause.  Okay, ruled out.  But clearly you're running into a new problem.

What kind of work were you doing?  Compositing?  Editing?  What KIND of editing?  I'm trying to narrow down the trigger -- it isn't something I do in either my professional or personal workflows.

Thanks,
David

531 Messages

 • 

12.2K Points

Hi David,

I was doing compositing work. This was my third piece of compositing work since updating to 21.01 and the issues happened every time.

One piece of compositing work can take me up to 5 hours to do. I start out with cutting out my subjects with a pen tool. Then I add layers, placing my subjects on different layers, I add more layers, using the brush tool for artwork, adding textures, colour etc. I group them to keep things in order.  I use curves adjustment layers in between my added layers. This issue with the 'greyed out' buttons usually happens past midway of my workflow. I know I'm winding down my work because that's when I'm ready to finalise my piece with adding new layers for highlights and shadows. I don't use actions, plugins, filters or even adjustment layers for adding highlights and shadows, I prefer to paint them on using blend modes on new layers.

That's my usual workflow in compositing when I encounter the issue with the 'greyed out' buttons. 

I still have PS 20.0.8 installed and so I used it to finish my last compositing piece, without any dramas and since then I've just finished more compositing work in PS 20.0.8 without encountering any issues.

I hope this helps narrow down the problem.

Thanks for taking the time to look at this.

4 Messages

 • 

300 Points

Hi David,
I've finally caught the bug in the act. It happens when a scrollbar is present in the layers window, and you click and drag a layer over the buttons:



Edit : you can sometimes fix an already bugged button by doing the same move.

1 Message

 • 

80 Points

7 months ago

It is the same for me. Just doing basic stuff, creating layers and trying to group them. I havn't had the new layer stuck, but the new group button. I have to restart Photoshop to get it working again.
(Win 10 Norwegian, latest Photoshop, English)

Ole 

7 Messages

 • 

152 Points

6 months ago

Happens to me as well, also with the mask button.
Extremely annoying and time wasting
I am using Mac with Catalina

3.5K Messages

 • 

52.9K Points

6 months ago

Thank you for your details.  Please keep them coming; we still haven't isolated quite the problem, but I've logged the bug and we're discussing it.  A reliably reproducible case would be awesome.

Thanks,
David

531 Messages

 • 

12.2K Points

I would love to give you a reliable reproduce David, but it happens sporadically for me so I can't reproduce.

7 Messages

 • 

338 Points

Seems there were some changes to the layer palette in this version. There's also this problem: https://feedback.photoshop.com/photoshop_family/topics/photoshop-cc-2020-v21-1-0-recessed-layer-thumbnails

3 Messages

 • 

160 Points

6 months ago

ME TOO. I click on the Groups folder to start my new group and nothing happens. Tried in multiple files and same result - nothing. This is a HUGE need for a website designer... I have hundreds of layers in a given document that I need to put in to groups.

9 Messages

 • 

270 Points

6 months ago

I also have this problem.  I am using Mac Mojave.  Many of us are awaiting the fix for this.  It's a time suck and workflow disturbance.

12 Messages

 • 

316 Points

6 months ago

This reply was created from a merged topic originally titled Add layer and sometimes Add Mask buttons highlight and don't work.

After a few hours it does this, the buttons to create new layer in the layers panel are highlighted a lighter colour. It then won't let me click on them. It recently changed the add new mask button too. Restarting photoshop fixes this, is there anything i'm doing wrong?

3 Messages

 • 

140 Points

6 months ago

Happening to me too. Win10 English. No other programs running, no plug-ins installed, not connected to the internet, and all drivers up to date. Has been happening since the last update of PS 21.1

1 Message

 • 

84 Points

6 months ago

The new mask, new layer, and delete layer buttons at the bottom of the layers panel seem to stick down periodically for me as well.