Skip to main content
Adobe Photoshop Family

42 Messages

 • 

1.4K Points

Sun, Nov 10, 2019 12:01 PM

Photoshop 2020: Brush tool lag macOS. Will it ever be fixed?

This long standing problem seems to be perpetual now. I've tried the latest 2020 version on three different Macs, all have the usual brush tool lag issues. Yes, I've deleted prefs, tried a clean install on a new user account, tried legacy mode, turned rulers off and all the other suggested workarounds, but nothing has ever worked for me.

Can we please get an update on whether Adobe are still investigating this issue, and if we are any closer to getting a working version?

Responses

2 Messages

 • 

72 Points

a year ago

Same problem, Adobe please fix the problem. I use Affinity on my iMac Pro. It works, so it's definitely a Adobe Problem. 

42 Messages

 • 

1.4K Points

Yes, Affinity Photo works perfectly on the same machines with .ABR files. I'm also a heavy Zbrush user and don't experience any lag there either when sculpting or painting textures.

The only thing that does work for me is filling the layer that I'm painting on with option+backspace and then undoing the fill. That stops the lag and I can continue painting again. Just throwing it out there in case it helps to isolate the problem. Obviously it's not good for workflow or your sanity to have to keep doing this.

4 Messages

 • 

102 Points

a year ago

Had the same problem on a Windows10-platform. I could solve it by setting the "Flow" to 0 %. Now there is no more tool lag. Perhaps it works for you, too.

42 Messages

 • 

1.4K Points

Thanks but this doesn't work for me.

5 Messages

 • 

120 Points

Doesn't work for me either.

2 Messages

 • 

92 Points

I did two things and then fixed.

1. Go to system preferences>security and then add Photoshop under Privacy tab
2. Relaunch Photoshop, turn Smoothing to 0% in the sub tool menu while using brushes

5 Messages

 • 

120 Points

Thanks. I'm in Illustrator and discovered if I "Hide Rulers" that solves the issue up to 95% and I can keep the smooth set up as high as I need.

47 Messages

 • 

1.4K Points

10 months ago

Same issue on all of my Macs and on all Macs I have tried so far (from 2010 Mac Pro to 2013 Mac Pro to the newest Macbook Pro: Brush performance declined from CC2018 to CC2019 to 2020. I had no problems in the first, it began to annoy me in CC 2019 and is unusable in 2020.Problem: Each brush stroke is fast, after you started to draw. The problem for me is the initial lag to start a brush stroke. Multiple quick brush strokes with low opacity for Dodge & Burn for instance are impossible this way. Often brushes pause, and suddenly I get a to strong effect, because a number of steps have not been visibly applied and then are applied at once suddenly. Very annoying!

1 Message

 • 

60 Points

10 months ago

Had the same brush lag with Photoshop 2020 with my Wacom. Set the brush Smoothing to ZERO and all works fine now.

5 Messages

 • 

120 Points

That doesn't work for me. I'm using Illustrator 2020 and MacOS Catalina. My Wacom driver is up-to-date as well. Very frustrating.

1 Message

 • 

80 Points

9 months ago

I found a simple fix, just select one of the generic smooth brushes and then reselect the other brush, and the problem is gone.

5 Messages

 • 

120 Points

8 months ago

I just updated my MacOS Mojave to the newest version MacOS Catalina and that killed my CS6 box apps. So I finally broke down and purchased the monthly subscription for the suite. I mostly use Illustrator and the brush is lagging... one thing after another.... I tried all of the above options but can't seem to resolve this. Please advise. Is there something else I can try?

2 Messages

 • 

92 Points

I did two things and then it got fixed.

1. Go to system preferences>security and then add Photoshop under Privacy tab
2. Relaunch Photoshop, turn Smoothing to 0% in the sub tool menu while using brushes

4 Messages

 • 

122 Points

8 months ago

I have same problem... I was using sierra and updated to catalina recently and at first it was alright but brush lag is getting serious... I thought it's just my tablet but I tried different tool and I realised it is actually photoshop which causes the problem... everytime I draw a line. it creates one dark dot and then moves where I moved..

1 Message

 • 

60 Points

8 months ago

Same issue here, impossible to work with short strokes, which is strangely what I need. 
None of the smoothing off and preferences advices mentioned work for me. Cant even revert to older Photoshop versions, so were currently paying for a license to a non-working software, lovely.

5 Messages

 • 

120 Points

I found a workaround for Illustrator: If you have your Rulers on, go to View > Rulers > Hide Rulers. I've always used my rulers for guides so I had mine on. Once I hid/turned them off,  it resolved the brush lag. If you're using Photoshop, this might also work. Seems this problem was in both programs of the Adobe software.

42 Messages

 • 

1.4K Points

7 months ago

Any feedback from Adobe about this issue please? My workflow is a disaster thanks to this mind numbingly annoying bug. I used to LOVE my job and Photoshop, but I just dread using it now and actively avoid Photoshop whenever I can. It used to be such a fast stable program on the Mac but it just runs like pure hell now. Getting anything done is like swimming through bricks. From the very best application out there, to one of the worst. It's so sad and frustrating.