Skip to main content
Adobe Photoshop Family

19 Messages

 • 

358 Points

Fri, Jan 27, 2012 9:13 PM

Clicking the vector mask of the shape layer produces a program error.

When I click a vector mask Photoshop displays an error "Could not complete your request because of the program error". I'm not sure if it was a reason, but it started doing it after a copied vector shape from Illustrator and pasted in Photoshop as "Shape layer". CS5 12.0 x64

And also I don't remember since when, was ignoring as it is not that important, but instead of displaying a colour of a vector layer Photoshop displays just a white rectangle. It is on the screenshot.

Update: yes it is because of copy/pasting, just had replicated the error. I even created a new file in illustrator and copied vector shape from there again and pasted in the new file in Photoshop.

Responses

15.1K Messages

 • 

195.8K Points

9 years ago

Are you sure you installed all the updates for Photoshop?
That sounds like something that was fixed in a dot release.

The cursor problem sounds like a video card driver bug.

19 Messages

 • 

358 Points

cursor problem?

15.1K Messages

 • 

195.8K Points

Sorry, I was typing too quickly.

19 Messages

 • 

358 Points

9 years ago

Hi, how can I know this? Where I can see what is the latest update is? I thought it is here? But sounds like I was wrong.

15.1K Messages

 • 

195.8K Points

You are running 12.0.0. You missed 4 updates.

19 Messages

 • 

358 Points

9 years ago

never mind, just found

19 Messages

 • 

358 Points

9 years ago

Thank you, an update fixed the issue.

19 Messages

 • 

358 Points

9 years ago

However! :) It didn't fix the vector layers' thumbnail preview, see the screenshot

19 Messages

 • 

358 Points

9 years ago

OK, it just happened again:



now it happens only with the layer that I pasted from the illustrator

OK I'm totally confused, now it is not doing anymore this weird thing, looks like that error was tight to the original psd file I created and then was re-saved with it.

In any case this problem with the path selecting somehow got fixed, and doesn't bother me anymore. But would be nice to have normal thumbnails of the vector layers :)

Thanks!

PS Oops it did it again :) different files, re-created from scratch shapes and layers. And it did it again. And I'm sorry for million replies and updates, it just this error interrupting my work, annoying. Annoying also because it wasn't doing it before, started from today and except recommended updates nothing has changed on my computer... well except windows updates, that I did today as well :)

15.1K Messages

 • 

195.8K Points

9 years ago

Alright, now you have me confused as to what you're seeing.
Maybe someone else can help you figure it out.