Skip to main content
Adobe Photoshop Family

4 Messages

 • 

120 Points

Wed, May 30, 2012 10:44 AM

Elements: Organizer thumbnails won't load -- just an hourglass icon

I have over 3000 photos in my organizer and I can not see the thumbnails. Each photo only shows the hourglass icon and no matter how long I keep the program up, it does not go away. I can definitely delete some photos, but I don't have the time to delete each one individually.

Note: If I click on the picture, it shows up on it's own page, but just won't show up in the organizer.

Responses

146 Messages

 • 

2.5K Points

9 years ago

Try Edit...Preferences and turning off all Media Analysis functions.

Ken

4 Messages

 • 

120 Points

9 years ago

Didn't work. Thanks, though.

146 Messages

 • 

2.5K Points

9 years ago

What file types are those images?

What are the sizes of the image files?

Ken

4 Messages

 • 

120 Points

9 years ago

They are just about all jpgs.
Most are regular family photos, so between 1-2MB.

It's funny, because once I click on the photo (which is just a spinning hourglass), the photo pops up into it's own window. But I really need to be able to look at them all in organizer.

146 Messages

 • 

2.5K Points

9 years ago

Hmmm...I'm out of ideas, then.

Hopefully one of the Adobe employees can help.

Ken

146 Messages

 • 

2.5K Points

9 years ago

Use the size slider at the top of the application to increase the size of the thumbnails.

Ken

4 Messages

 • 

120 Points

9 years ago

Thank you for your help Ken.

1 Message

 • 

60 Points

8 years ago

I'm having the exact same problem. I have about 7400 pictures; Photoshop touts the Organizer as being able to handle very large catalogues and recommends only having one catalog. So I can't figure out the problem. I really don't think that 7400 is an inordinate number of photos in one catalog. I didn't start having this problem until a couple of weeks ago.

Adobe Administrator

 • 

780 Messages

 • 

16.7K Points

Hi Erin,

Try renaming the thumbnail cache.

If you are on Windows, goto the location: %programdata%/Adobe/Elements Organizer/Catalogs and double click the folder whose name is same as your catalog.

On Mac the location you go to would be : ~/library\Application Support\Adobe\Elements Organizer\Catalogs

Look for a the file with name thumbs.cache. Rename to thumbs.old .

Restart the Organizer and let us know if that resolves for you.

72 Messages

 • 

1.2K Points