Skip to main content
Adobe Photoshop Family

6 Messages

 • 

140 Points

Fri, May 25, 2018 9:52 AM

Elements: Editor not starting, not enough RAM (Windows 10 update1803)

Windows update delivered version 1803 the other day and now Elements 14 editor will not start. No error message.


Event log information points towards libceff.dll being the issue. I have removed print and graphic drivers to no avail.
Any ideas greatly appreciated.
John

Log Name:      Application
Source:        Application Error
Date:          25/05/2018 10:36:58
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      DESKTOP-PC
Description:
Faulting application name: PhotoshopElementsEditor.exe, version: 14.0.0.0, time stamp: 0x55df8c21
Faulting module name: libcef.dll, version: 3.1750.1738.0, time stamp: 0x539860dd
Exception code: 0x80000003
Fault offset: 0x000000000018ac68
Faulting process ID: 0x448
Faulting application start time: 0x01d3f40bea593e89
Faulting application path: C:\Program Files\Adobe\Photoshop Elements 14\PhotoshopElementsEditor.exe
Faulting module path: C:\Program Files\Common Files\Adobe\Elements\ELive\14\libcef.dll
Report ID: fda0b349-4c9f-4ba2-9ded-ff6ccab666f8
Faulting package full name:
Faulting package-relative application ID:
Event Xml:
" title="Link http//schemasmicrosoftcom/win/2004/08/events/event">http://schemas.microsoft.com/win/2004/08/events/event">;
 
   
    1000
    2
    100
    0x80000000000000
   
    860
    Application
    DESKTOP-PC
   
 
 
    PhotoshopElementsEditor.exe
    14.0.0.0
    55df8c21
    libcef.dll
    3.1750.1738.0
    539860dd
    80000003
    000000000018ac68
    448
    01d3f40bea593e89
    C:\Program Files\Adobe\Photoshop Elements 14\PhotoshopElementsEditor.exe
    C:\Program Files\Common Files\Adobe\Elements\ELive\14\libcef.dll
    fda0b349-4c9f-4ba2-9ded-ff6ccab666f8
   
   
   
   
 

Responses

Official Solution

Champion

 • 

1.3K Messages

 • 

20.2K Points

2 years ago

6 Messages

 • 

140 Points

2 years ago

Right, an update. Unplugging my second monitor has allowed the editor to start. However most of the tools are now complaining about lack of RAM! I have 4GB installed with only 40% used. I'm sceptical as PSE ran fine before the upgrade.

Champion

 • 

1.3K Messages

 • 

20.2K Points

2 years ago

John,
You mention updating Windows recently to the 'build 1083' and your problem starting immediately.
Did you notice the number of similar complaints in this forum as well as in the Elements user to user forum? Not only for Elements (all recent versions) but also for Photoshop?

Yes, the common factor is that the RAM size is no longer recognized.
The only workaround now for Elements is to edit the Windows registry.
https://forums.adobe.com/thread/2423579
Many other posts in both forums.

6 Messages

 • 

140 Points

2 years ago

Michael. I just found this posting https://feedback.photoshop.com/photos...

It solved the ram problem.

6 Messages

 • 

140 Points

2 years ago

Yes, my link above led to your link and it did the trick for me. Thanks again.

2 Messages

 • 

82 Points

2 years ago

This reply was created from a merged topic originally titled Elements 14 not enough RAM on Windows 10. Used to work before rebuild of system..

I installed elements 14 on windows 8 then upgraded to windows 10, all was working fine. However after issues with me disk I had to rebuild pc. This time the system upgraded me to windows 10 before I installed elements 14. Now whenever I try to do anything apart from clip a picture I get told I do not have enough RAM to perform the task. I cannot save any picture I open. Please advise. I have uninstalled and reinstalled, and put on the latest updates.

2 Messages

 • 

82 Points

2 years ago

This reply was created from a merged topic originally titled Elements 15: Has suddenly started unable to "save as" because of insufficient RA....

My Photoshop Elements 15 has suddenly started saying that is unable to "save as" because of insufficient RAM. Also when I try to do something e.e.select an area it automaticallty shuts down without warning. I tried reloading the software but this hasn't fixed it. Help please.

6 Messages

 • 

140 Points

2 years ago

Re the RAM problem. Windows is now miss reporting what RAM is available to PS. Go into preferences and then performance. This produced an error that stated an invalid numeric value is entered. If this happens to you then follow this guide https://helpx.adobe.com/photoshop/kb/.... You'll need to edit the registry and once done the performance tab should display properly and PS will know the correct value of RAM installed