Skip to main content
Adobe Photoshop Family

2 Messages

 • 

362 Points

Sat, Oct 18, 2014 10:19 AM

Solved

Elements: Brush/eraser hangs in Yosemite MacOS 10.10

Photoshop Elements hangs now when I use brush/eraser tools following the installation of Mac Yosemite OS on my Mac. Others have reported this problems on other feeds. I hope that Adobe will give priority to fixing the apparent incompatibility of Printshop Elements with Yosemite OS.

Responses

67 Messages

 • 

922 Points

6 years ago

Jim, that's good news - I guess Apple just didn't include the trackpad issue in the list of bugs that the update fixed!! thanks for being a pioneer - I always wait a few days before I install any new updates!!

9 Messages

 • 

200 Points

6 years ago

As Jim mentioned 10.10.1 fixed the trackpad issue on my MacBook Pro. Given the list of fixes Apple does mention, looks like a good update.

10 Messages

 • 

152 Points

6 years ago

update 10.10.1 and it works with the installed plug in work around .
Anything is ok with PSE 11 (y)

13 Messages

 • 

290 Points

6 years ago

Confirmed - PSE12 works fine with 10.10.1.

3 Messages

 • 

90 Points

6 years ago

This reply was created from a merged topic originally titled OSX Yosemite conflicts with Photoshop Elements 12 Editor.

Photoshop Elements 12 Editor freezes up when the following are selected: enhance, draw, or select. I have Mac Air OS X Yosemite ver. 10.10.
Bob

Adobe Administrator

 • 

14.9K Messages

 • 

286.1K Points

Make sure you update your OS to 10.10.1

Sr. Product Manager, Adobe Digital Imaging

3 Messages

 • 

90 Points

Problem solved, Thank you

5 Messages

 • 

110 Points

6 years ago

This reply was created from a merged topic originally titled Elements 12 Freezing When Using Spot Healing/Dodge/Burn, etc..

PSE 12 freezes and requires me to force quit if I use features such as the spot healing tool, blur, dodging, burning, etc. I am able to use some features (crop, lighten, contrast, etc.). Anyone else experience this issue and find a resolution?

67 Messages

 • 

922 Points

6 years ago

this issue was solved by an Adobe plugin until the Yosemite update came out --- update your computer to Yosemite and you should have no further problems

5 Messages

 • 

110 Points

6 years ago

My Yosemite and Adobe are both updated. That did not fix the issue for me.

Adobe Administrator

 • 

14.9K Messages

 • 

286.1K Points

It may help if we could see your Photoshop System Info. Directions for sharing your system info from Photoshop:

http://feedback.photoshop.com/photosh...

Sr. Product Manager, Adobe Digital Imaging

67 Messages

 • 

922 Points

6 years ago

really? wow! that's the first I've heard of it. Did you try applying the Adobe plugin that's at the top of this page before you did the Yosemite update? You should have seen a change then. seeing as the Yosemite update did not fix your problem, you might want to back up everything on your computer and do a clean install of Yosemite - a lot of work but might solve the problem. good luck.

5 Messages

 • 

110 Points

6 years ago

Thanks, I will try that as my next step.

67 Messages

 • 

922 Points

6 years ago

I hope it works, Shannon. Let me know. Be sure you do a really thorough back up (do you use Time Machine? - that worked for me -- I did a double TM backup about an hour apart just to be sure).

4 Messages

 • 

100 Points

6 years ago

Looks like Adobe solved problem with Clone Erase. I updated Elements, and there is no longer a problem. There was an option to allow plug-ins. Works great. Thanks all!

2 Messages

6 years ago

This reply was created from a merged topic originally titled is elements 12 compatible with Mac OS 10 yosemite version 10.10?.

elements locks up and the editing tools don't work now that I have upgraded my operating system to yosemite
is there an free upgrade or do I have to buy another version of this elements program

67 Messages

 • 

922 Points

Debra, did you do the update to Yosemite? that should fix the issue. Previously Adobe had posted a plugin that was a temporary solution - I applied that and then when Yosemite was updated, I just left it in place -- no problems for Elements 11 or 12 after that. Go to the very top of this page - the Adobe fixes are in a big pink box. Good luck!

1 Message

 • 

60 Points

6 years ago

My smart brush, etc. does not work with Yosemite. I downloaded the zip file but I get the message "Photoshop Elements does not recognize this file."

15.1K Messages

 • 

195.8K Points

Which version of Elements?
Which ZIP file are you referring to? And did you unzip and install the contents correctly?

Adobe Administrator

 • 

14.9K Messages

 • 

286.1K Points

Hi Shirley, you do not need to install the plug-in if you update your OS X Yosemite to 10.10.2.

Sr. Product Manager, Adobe Digital Imaging

10 Messages

 • 

222 Points

If the plug in was installed prior to version 10.10.2 OS do we need to uninstall it?

5 Messages

 • 

110 Points

I'm not sure, but I did and it works.

Adobe Administrator

 • 

14.9K Messages

 • 

286.1K Points

You don't have to uninstall. It doesn't hurt either way.

Sr. Product Manager, Adobe Digital Imaging

2 Messages

 • 

80 Points

6 years ago

This reply was created from a merged topic originally titled Problems using Elements 12 with Wacom Ituos Pro + Mac Yosemite. Lasso tool and zo....

I am experiencing lasso tool time lag/early selection closure plus intermittent problems with zoom when using Wacom tablet. Seems to be common problem that has been around some time. Only work-arounds/fixes I can see relate to Photoshop CC (not Elements). Have applied latest updates to Elements, Wacom and Mac OS X 10.10.2 Running on mid 2010 iMac (Intel core i5 - 4GB memory).
I have no problems with lasso selection in Elements when I use standard mouse instead of Wacom pen. The Wacom Intuos seems fine with other software (e.g. Manga Studio, Sketchbook Pro). All issues seem to happen when Elements meets Wacom.

Wacom have responded with a shrug and directed me towards Adobe.
I have 2 questions
1- Is software conflict the most likely cause of my problems or is there anything I can try?
2- If this is still a compatibility problem, can anyone tell who is doing what to resolve it?
Thanks for listening