Skip to main content
Adobe Photoshop Family

2 Messages

 • 

80 Points

Tue, Jan 23, 2018 9:28 PM

Elements 10: Doesn't start anymore

My Photoshop Elements Vs. 10 doesn't start anymore. I re-installed the program but it stops immediately after opening the app by clicking. Then it says there is unrepairable problem and the system has to be closed down. 

Responses

Adobe Administrator

 • 

14.8K Messages

 • 

284.8K Points

3 years ago

What OS are you on? What happened between when it worked and it stopped working? Did you upgrade OSes?

Sr. Product Manager, Adobe Digital Imaging

2 Messages

 • 

80 Points

3 years ago

My Mac systems runs with MacOS High Sierra V.10.13.1 - I didn't use PSE for a while but I wanted to start it again and then it says unrepairable system or hardware error :-(

Adobe Administrator

 • 

14.8K Messages

 • 

284.8K Points

Elements 10 is pretty old and wasn't designed to work on High Sierra. https://helpx.adobe.com/photoshop-elements/system-requirements.html
  • Mac OS X v10.5.8 through v10.7

Sr. Product Manager, Adobe Digital Imaging

901 Messages

 • 

11.1K Points

3 years ago

Marcus:  

Not to repeat Jeff's answer, but to support it, being a Windows engineer I know that sometimes these messages may not concern PSE, but may be about a file in your OS, especially if the OS is newer than PSE.  If you recently changed your OS it could be that the files in your OS isn't compatible, as I had heard from a few Mac users who blamed High Sierra and got help for that from Mac users.  

While waiting for help from Jeff and myself, maybe you can consult with your OS technician to see if there is a compatibility issue with PSE-10.  Obviously reinstalling your PSE should have resolve the problem so it may not be PSE.   

Steve Lehman, MCSE