Skip to main content
Adobe Photoshop Family

54 Messages

 • 

1.5K Points

Fri, Mar 8, 2019 6:52 PM

Lightroom CC for web: Search for filename returns irrelevant results

I use Lightroom Classic. I sync my photos from Classic to Lightroom Web(https://lightroom.adobe.com). I do not use Lightroom CC except on my phone. I currently have over 82,000 photos synced to
LR Web from my Lightroom Classic catalog. In Lightroom Web, searching for an image by filename returns wildly irrelevant results.

When I type in a filename, such as L1224A9390.NEF, I get 176 results. Only one of the photos has that  file name. Fortunately, the file I'm looking for is first in the list. But why would it return 175 other images that aren't relevant?

If I search without the extension, using just L1224A9390, I get 175 results. Again, only one is relevant.

And, when I try searching just for a portion of the filename -- A9390 -- I get five results, all of which do have that text in the filename. It's strange that a more specific search -- L1224A9390 or L1224A9390.NEF -- returns less accurate results.

This seems to be a bug in Lightroom Web. If not, what am I doing wrong? How can I search for a filename and have Lightroom Web return only the one image with that filename?

Responses

54 Messages

 • 

1.5K Points

2 years ago

Here's something even weirder. I decided to see how many results I'd get by typing in one character at a time of the filename L1224A9390, and the number of results makes no sense.

  1. f I type just the letter L, I get over 13,000 results. That's to be expected.
  2. L1 returns about 3600 results. So far, working as I expect it to: a more specific search returns fewer results. 
  3. L12 is similar in that it returns fewer images.
  4. The same with L122 which returns 162 images.
  5. Here's where it get's strange: I search for L1224 and get more results: 175.
  6. L1224A also returns 175.
  7. L1224A9 returns 150.
  8. L1224A93 returns more results again: 175.
  9. L1224A939 and L1224A9390 also return 175.
I wonder what it is searching for.

Employee

 • 

142 Messages

 • 

2.2K Points

2 years ago

Hi Alan,

I've passed this along to the Search team and it is being investigated. It has to do with how things get tokenized, but we are digging deeper to see where it is going wrong and try to get a fix. I'll report back if I have more info. Thanks for reporting this.

Best regards,
Richard Coencas
Sr. QE Lead II, Lightroom Ecosystem

54 Messages

 • 

1.5K Points

5 months ago

Richard,
Filtering by Filename is still broken in Lightroom Web and Lightroom Cloud app. I still get the same type of irrelevant results mentioned in my original post.

It has been over 1 year since I made the original post. Seems like it should be easy to search for a filename. Will I ever be able to filter accurately by Filename on the web or with the cloud app?

Employee

 • 

142 Messages

 • 

2.2K Points

4 months ago

Hi Alan,
I'm very sorry that I lost track of this request. I've passed it on to the search team once again. I'll make a point to follow up.
Thanks