Skip to main content
Adobe Photoshop Family

945 Messages

 • 

16K Points

Wed, Oct 31, 2018 4:54 PM

Solved

Lightroom mobile: Store locally does not work anymore (iOS)

hi,

The "store locally" function on iOS seems to be not working anymore.

The only way to get the counter increasing is by manually "load" a picture by opening it.

I have enough space on my devices, rebooted the apps, devices and tried on different networks. Any others having this issue?

Kr,

Responses

Adobe Administrator

 • 

8.2K Messages

 • 

118K Points

2 years ago

Is it pulling in 0 images or is it stalling somewhere along the way?
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

945 Messages

 • 

16K Points

Pulling in 0 unless I manually open and load an image, then the counter increments. So if I want to download all the images of an album, I have tu load them all.

Adobe Administrator

 • 

8.2K Messages

 • 

118K Points

2 years ago

I am not able to reproduce. I tried about a half dozen albums from 30 - 300 images each and it pulls them all down without having to manually manipulate.  Have you restarted your device?
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

945 Messages

 • 

16K Points

I have, both app and both devices.

945 Messages

 • 

16K Points

Here’s a video of the issue. First a Speedtest just FYI (around 15 MB/s)

https://share.icloud.com/photos/0hJxE...

Adobe Administrator

 • 

8.2K Messages

 • 

118K Points

Thanks for the video.  I see you've been to Hraunfoss!

I tried duplicating your actions on my iPad and am not able to see what you are seeing. I am going to ask an engineer to step in here.
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

945 Messages

 • 

16K Points

I have

945 Messages

 • 

16K Points

* I have, it was awesome!

Employee

 • 

77 Messages

 • 

1.2K Points

Do you have "Only Download Smart Preview" - enable when you open up Lr Mobile settings -> Cloud Storage&Sync? Does this occur to all of your albums? - Lr Mobile QE

945 Messages

 • 

16K Points

No, but it shouldn’t matter as the vast majority of my synced catalog is coming from Classic. It also fails with original files upload from iPad.

11 Messages

 • 

234 Points

2 years ago

I'm having the same issue actually after upgrading to 2 new devices and iOS 12. In my case, it runs for about half of an album (1081/2036) and then stalls. It actually appears to stall in the same place on both devices which also seems suspect. 

I tried to unmark "store locally", clear all caches, uninstalled LR, reinstalled and problem persists. 

11 Messages

 • 

234 Points

Also, I do have "download smart previews" selected.

11 Messages

 • 

234 Points

I've made a little progress, one of my other albums wasn't syncing correctly either, so I started there. I'm using Lightroom Classic on my Mac so I unchecked the "sync with cloud" option, then cleared my local cache on iOS and then re-enabled it on the Mac. When choosing "store locally" on iOS it worked... this fixed it for that album. Maybe this will work for you. Seemed to sync very fast so I doubt that Adobe is clearing your data from the cloud immediately but I can't be sure of course.

For the other album with 2000+ photos, this option didn't work for me, so what I've ended up doing is selecting all of the synced photos and then found a field that I hadn't stored any metadata in (yet). For me it was "Caption", I just typed in a "." and saved the change. This is forcing a re-sync of all my files so it's taking FOREVER but it looks like it might have gotten it unstuck. 1700 files to go... I'll post back if it works or not.

945 Messages

 • 

16K Points

Thanks for the advice :)

As I have many many folders to sync (yes, folders! bluntly duplicated to collections as folders don't sync), I will not try too much to mess with it. It seems to be clear it's a server/app issue so I'll just wait until the problem solves. Let's hope for un update soon as an engineer is looking at it :)

11 Messages

 • 

234 Points

Yea, so it didn't even fully work for me. It did fix a lot of the images, now I get to 2030/2036 but then it stalls forever again. Also seems like it has a queue, so I can't download other albums once it stalls out for one of them. 

Seems to be clearly a server/app sync issue, but since this is the album I'm trying to work on right now, it's really annoying! Hopefully they can fix it soon. 

11 Messages

 • 

234 Points

Seems there might have been something messed up about the collection itself, I created another collection with the same name but with a "2" added and then I started moving the photos from one collection to the other. All the syncing completed just fine in the new collection.

So if you're in a pinch, this might work for you as well. Also the process was extremely quick since it doesn't re-upload the files if they were already in the Adobe sync cloud.

945 Messages

 • 

16K Points

2 years ago

Up! Any fix on the roadmap?

945 Messages

 • 

16K Points

2 years ago

Could you please put my subscription on hold until this is solved ?

945 Messages

 • 

16K Points

2 years ago

Just for the record: I was on the plane lately and could not use the app I am paying for.

Adobe Administrator

 • 

8.2K Messages

 • 

118K Points

2 years ago

I have pinged the team on this. My iPhone is experiencing the same issue today. 
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

11 Messages

 • 

234 Points

Not so nice that we have to wait until YOU personally have a problem for you to ping the team on our behalf when we've been waiting patiently for feedback over here for TWO MONTHS.

945 Messages

 • 

16K Points

2 years ago

Don’t take it bad, but does the issue needs to affect an Official Rep before it is taken seriously?

I had no reply from Ignacio nor on this forum since ages. Is thes really how Adobe treats it’s customrs? Is QC a known issue and will we ever get a Mea Culpa or will this continue forever? (Should I add: as long as the cash flows).

I don’t want want to be rude or whatsoever, but is this really a respectful way to treat customers?

Adobe Administrator

 • 

8.2K Messages

 • 

118K Points

2 years ago

Antoine and Troy,

I understand and sympathize with you. We take every report seriously but it is really tough to fix something until we can successfully reproduce it. I've tried reproducing this many times but  unfortunately, it took until now for it to manifest for me.

We are working on it. Thank you for reporting and your patience.
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

3 Messages

 • 

80 Points

2 years ago

Good day! I am experiencing the same issue. I am not sure when it started, but likely it may be somehow connected to ios12 update.
I tried several times to reset the app as well as the whole cloud, but nothing worked.
I hope you'll find a solution soon.

Thanks.

Adobe Administrator

 • 

8.2K Messages

 • 

118K Points

2 years ago

Update:

As a part of my testing on this bug, I resolved the issue on my two stuck devices (iPhone 7 & iPad Air II). Give this a try and let me know how it fares for you.

  1. Create (or use if you have one already) an additional Adobe ID.
  2. Make certain that your device is completely synced (do not attempt if not synced)
  3. Sign out of the device and wait a few minutes for the iOS background processes to complete.
  4. Sign in under the alternate ID.
  5. Sign out from the alternate ID.
  6. Sign in under your production ID.
  7. Allow the app to fully sync again
  8. Select an Album and set it to Store Locally
On both of my accounts and devices where this was stalled, it successfully synced and stored locally after following these steps.  Let me know if this works for you.
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

945 Messages

 • 

16K Points

I just tried but it failed.
I even tried to remove the cached pictures on my iPad and the already stored pictures.
Nothing... and now I’ve lost what I had imported on my iPad! Because you know, that’s another workaround to have 1:1 on mobile... workaroundception isn’t maybe the most obtimal, in the end

945 Messages

 • 

16K Points

Tried one more time on iPad and on iPhone... same result

Adobe Administrator

 • 

8.2K Messages

 • 

118K Points

I've let the engineers know, Antoine.
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

945 Messages

 • 

16K Points

2 years ago

There was a new version of LR but the problem still exists

Adobe Administrator

 • 

8.2K Messages

 • 

118K Points

2 years ago

Antoine,

A question from the engineers troubleshooting this issue.

Does this only occur in albums where you have a Tiff file which is also synced to Classic?

If you make an album with only raw or jpeg files will it store locally?
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

945 Messages

 • 

16K Points

Hi Rikk,

No, it occurs in every album, unfortunately.
I barley ever use TIFF (in return from photoshop) or jpeg (some screenshots are in png). I shoot almost exclusively in dng (Pentax) or proprietary raw (DxO).

Adobe Administrator

 • 

8.2K Messages

 • 

118K Points

Thanks
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

11 Messages

 • 

234 Points

I don’t use tiffs either

11 Messages

 • 

234 Points

Also if you read my above comments you’ll see that isn’t specific to the contents, but rather the folder itself. I moved all my images to a new folder and resynced and everything worked on the new folder even though the images are the same.

3 Messages

 • 

80 Points

Same for me, I don't use TIFF, but almost only RAW (formerly Nikon, now Sony).
However I noticed that importing photos through Lightroom CC (on an iMac computer), as sson as the import is finished and the pictures are available in the cloud, results in the iPhone starts storing locally. But it took few hours for a few pictures, so I interrupted the process. 

Adobe Administrator

 • 

8.2K Messages

 • 

118K Points

2 years ago

The team was able to repro and get a bug going. We should have this fixed in an upcoming release. Thanks for your patience.
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

945 Messages

 • 

16K Points

Awesome! I look forward to using LR again!

945 Messages

 • 

16K Points

Still nothing? It’s been 3 months now

7 Messages

 • 

120 Points

Unfortunately not working for me, been following this thread with interest, multiple trouble tickets with Adobe, countless hours with technical support, new software update yesterday, delete / reload Lightroom>......and still nothing works>..... will not download originals or smart previews using store locally.

945 Messages

 • 

16K Points

2 years ago

Hey Adobe ? What's going on with this bug?