Skip to main content
Adobe Photoshop Family

48 Messages

 • 

870 Points

Wed, Dec 5, 2018 9:20 PM

Lightroom CC for mobile (iOS): Doesn’t work offline

Right now lightroom mobile is impossible to use without an internet connection. This makes the app totally unusable in many situations. When traveling, when having bad reception and I guess it will be really expensive in places with high data charges. In ”flightmode” lrm cant start at all. It only seems to start when the app have been recently used (with internet connection). Otherwise Its stuck at startup forever, ”loading photos” with a black screen. Doesnt matter if there is albums stored locally since it cant start up. When deactivating flight mode in iOS, lightroom starts as usual. Tried on different iOS devices with the same results.

Responses

968 Messages

 • 

16.2K Points

2 years ago

Strange, I don't have that  issue on iPad.
Is your library fully synced? Have you tested rebooting your devices?

I have an issue, however: the "store locally" fuction does not work on my device.

48 Messages

 • 

870 Points

2 years ago

Reboot didnt help. Cant tell if its fully synced in the situation when it doesnt start. Maybe not. To me, the whole purpose with ”mobile” falls if you cant even start Lightroom without fully sync over mobile data or wifi every time before opening it. Of course its cloud-based which is great, but if it’s impossible to use at all when traveling or at remote places, then its really bad..

968 Messages

 • 

16.2K Points

2 years ago

Agreed, it should work. I don't understand why it doesn't.
Are you using LR Classic or LR CC on desktop?

48 Messages

 • 

870 Points

2 years ago

At the moment Im only using Lightroom mobile, paid version
It’s strange. I cant replicate this every time, but the problem occurs very often when I hanen’t opened Lightroom for a while. Last time I was traveling I had to allow mobile data almost every time just to get it started.

968 Messages

 • 

16.2K Points

I've had a big bug that was solved 'at server side'. No more explanation; but this means there's a lot that can go wrong. I've also read on this forum about some corrupted files in the cloud. I would therfore strongly advise to have a local backup on a coputer :/
(imagine the day you decide to leave LR...)

Employee

 • 

137 Messages

 • 

1.9K Points

Hi Emil,

how much storage do you have on the device?
Can you recall if you've normally had little available space on the device before this issue occurred?

Thanks,
Ignacio

48 Messages

 • 

870 Points

Hi!
One of my devices has very little storage left and Ive seen som other stability and import problems with lightroom because of this. Anyways, could this cause it to be stuck at startup only some times and only in flightmode? When I turn on internet access it always seems to work again. Cant recall if Ive had little space left on the other divice when it occured there..

It seems like some kind of cach-data or signal is needed to get plast the ”loading photos” and open the app. When not used for a while maybe this needs to be downloaded? therefore it doent start in flightmode? I did a test before updating the app today.
1. First I made sure lrm started on both devices in flightmode
2. Closed app and turn off flightmode.
3. Updated lrm
4. Turned on flightmode
5. Tried to start the updated app=
Stuck on ”loading photos” on both devices!
6. Deactivated flightmode=Lightroom starts fine

Employee

 • 

137 Messages

 • 

1.9K Points

Have you tried the latest 4.1 version? Does it still occur there?

48 Messages

 • 

870 Points

The test I did in the comment above was with 4.1 version

Employee

 • 

137 Messages

 • 

1.9K Points

Ok.

if you do the test again, without the update, does it work then?