Skip to main content
Adobe Photoshop Family

5 Messages

 • 

120 Points

Mon, Jan 22, 2018 12:18 PM

Lens Corrections not working on imported Sony a6300 RAWs

I've recently replaced my Sony a5000 with a Sony a6300 and there seems to be a problem with the Lens Corrections feature.

Lightroom Mobile would correct the distortions on imported Sony a5000 RAWs (Sigma 30mm f1.4 DC DN mounted), but not the RAWs from the a6300 with the same lens attached.

I've enabled sync with the desktop app and applied the lens corrections afterwards. The desktop app did the trick. Moreover, after properly correcting the distortions with the desktop app, syncing the photo back to Lightroom Mobile enables the same Lens Corrections feature to work properly.

Responses

381 Messages

 • 

7.6K Points

3 years ago

Try setting the Lens Comp. settings to "Auto" in the camera. This will give Lr a hint to automatically apply the external lens profile if it can be located.

5 Messages

 • 

120 Points

3 years ago

Unfortunately it still doesn't work.

381 Messages

 • 

7.6K Points

If you post a link to a raw (.ARW) file I can take a look.

5 Messages

 • 

120 Points

5 Messages

 • 

120 Points

And these are my settings

381 Messages

 • 

7.6K Points

Thank you for the sample image. The EXIF lens name is different in the image than in the lens profile. This is likely because the original camera/lens combination used to generate the profile used the more generic "E 30mm F1.4" name and there was a lens firmware update at some later date that changed it to a specific lens model. 

For reference the bug# is CR-4197695. I fixed/submitted it for a future release.

In the meantime, you can set a new Lens Profile Default in the Lens Corrections panel for one image of that camera/lens combination after you manually select the profile. This will provide the matching logic with a hint to enable the profile match.

Regards,

- Chris