Skip to main content
Adobe Photoshop Family

121 Messages

 • 

2K Points

Mon, Apr 20, 2020 10:10 PM

Acknowledged

Lightroom for Apple TV won't complete launch

I've been frustrated with this one for some time. I cannot get Lightroom on my Apple TV 4 (the HD version) to open fully.

It starts to open, and I get a picture background with a twirling busy wheel, but it just never launches completely, and eventually just quits back to the home screen.

I've tried various tricks, such as deleting and reinstalling, and even resetting the Apple TV itself, all to no avail.

I did manage to get it to launch a couple of time last year, but it took ages to get there.

I leave everything to auto update, so it's usually fully up-to-date at any time.

Lightroom is working fine elsewhere (iMac Desktop, iPhone, iPad and Web version).

Any suggestions?

Thanks.

Responses

Adobe Administrator

 • 

8.6K Messages

 • 

122.7K Points

7 months ago

I just installed Lightroom TV on my 4K Apple TV and signed into my Adobe ID. It launched and synced down the cloud content with no issue. (I've been running it for years on the HD version with no issues)

What is the free space on your Apple TV?
Can you verify the iOS version currently on your Apple TV? 
How many assets do you have in the cloud?
Adobe Photography Products

Quality Engineering - Customer Advocacy

121 Messages

 • 

2K Points

Hi Rikk, thank you for replying.

My AppleTV is a A1625 64GB model (HD not the 4K), with tvOS 13.4, and Lightroom 2.01.

I'm not sure of the free space on it, there doesn't seem to be anywhere in the data that shows that, but I'd be surprised if it's as much as half full, it only gets light use.

I have 61,999 items showing in my Adobe Cloud, which is about 575GB, and a mix of various Raws, movies, and normal images.

I got this aTV last year, and haven't ever really got Lightroom to run on it very well. Over the last few months, and iOS and tvOS updates, it's just got worse so it doesn't launch at all now.

Cheers

Adobe Administrator

 • 

8.6K Messages

 • 

122.7K Points

Ok. I am running one of each here and not seeing the issue on either. 

One point. When Lightroom was first released on Apple TV, it was a separate download for the TViOS. That version is no longer active. The current version of Apple TV is part of the Phone - iOS version. 

You may need to uninstall the App, then search the App store for the new App (phone) - not the iPad.  Don't reinstall from Purchased Apps.  Make sure you cycle power on the Apple TV between the uninstall and the reinstall. 
Adobe Photography Products

Quality Engineering - Customer Advocacy

121 Messages

 • 

2K Points

OK Rikk, I'll try an uninstall and reinstall again. Although it is showing as V2.01 installed, which according to the site blurb is the newer version (the old one stopped at v1.2.3).

It does start to run, but sticks at the spinning wheel for ages, before it quits - it does even show some nice pictures while it's doing it.

Regards

Adobe Administrator

 • 

806 Messages

 • 

14.7K Points

Hi Andy 
Thanks for taking the time to report this issue.  I'd like to get a bit more info, and hope to troubleshoot this with you.

I updated to the latest tvOS on both my 4th Gen (HD) and also 4K Apple TV devices, and installed the app again.   On my own large account (84,000 images, 400+ albums) the app did momentarily seem to get stuck loading my account after signing in.  Within a minute though, it resumed loading.  It sounds like you tried waiting too and this didn't help.

I know you tried re-installing the app already.  I wonder if forcing your account to reload helps.  Can you go into Lightroom TV app settings, towards the top right of our app.  In Settings, select Reload Albums.  Does that help?

Just curious -- if you sign into your account in a web browser at lightroom.adobe.com, near the top of the left side panel where albums are listed, do you see any reports of images that have sync issues?  I'm just trying to get an idea of what's different between our two accounts.

Thanks,
Charlie

121 Messages

 • 

2K Points

Hi Charlie

Thanks for looking into this.

I leave the app running, but eventually it just quits back to the main menu.

In the past, I have already tried re-installing, and even completely resetting the Apple TV box and reinstalling all the apps. My reinstall today of Lightroom didn't work either.

I've also tried rebooting the modem/router (broadband is good here, I get around 50Mbps downstream, and 19Mbps upstream). I've also switched between Ethernet and WiFi (the router is three feet away from the AppleTV box).

I can't get as far as reloading the account, it quits before it gets that far - it doesn't get to the folders/albums screen, I only see the initial loading screen, with the pretty photo and a progress animation.

There are no sync errors showing, and all other devices (web, desktop, iPhone and iPad) are all working perfectly fine.

I do have a folder/album structure that mimics my older Lightroom Classic layout, and there are over 4600 albums in my collection - is that perhaps a factor? (although it loads pretty quick in all other devices).

Cheers
Andy

Adobe Administrator

 • 

806 Messages

 • 

14.7K Points

4600 albums could certainly be the critical factor here.  I'll log a bug noting the details you shared.  Thank you, Andy!

121 Messages

 • 

2K Points

Thanks Charlie.

These are of course a well laid out set of folders and albums (was previously Collection Sets and Collections of course) covering 20 years of digital photos. It could be difficult to 'rationalise' that.

Regards

Andy

121 Messages

 • 

2K Points

5 months ago

Hi Guys,

Just an update to this in that the recent update hasn't changed anything here, I still can't open Lightroom on my AppleTV.

Would it be an idea to remove and reinstall it?

Cheers

Adobe Administrator

 • 

8.6K Messages

 • 

122.7K Points

I am able to successfully launch although I did have to reauthorize via a browser and re-enter the 6 character code. Verify your installed version is 2.1. 

If it is, a reinstall would be advisable. If not then an update would be advisable. 
Adobe Photography Products

Quality Engineering - Customer Advocacy

121 Messages

 • 

2K Points

Yes, it was v2.1.

I've tried an uninstall (and reboot), and then reinstall, it launches, but is just stuck on the opening screen with the rotating dots and a background photo. I left it for 45 minutes, and it still hadn't completed launching.

Adobe Administrator

 • 

8.6K Messages

 • 

122.7K Points

  1. Verify TvOS is up to date with Apple
  2. Uninstall Lightroom TV 2.1
  3. Disconnect Apple TV from power
  4. Wait 5 minutes
  5. Reconnect Power
  6. Install Lightroom TV 2.1
The above is a clean install procedure designed to clear any residual information from the Apple TV with regard to Lightroom. 

FWIW, I checked on an Apple TV Gen 3 and an Apple TV 4K and both launch with no issues.  What gen is your Apple TV?
Adobe Photography Products

Quality Engineering - Customer Advocacy

121 Messages

 • 

2K Points

Thanks Rikk,

OK, done the 1-6 list, it launched as it has done so far, with the 'Lr' logo and three rotating spots, then after a couple of minutes it just quit back to the main menu.

I'm running it again, and it's run for longer, but still not getting past this screen as yet.

FWIW, I assume you really mean a Gen 4 HD (I also have a Gen 3, which was the last of the iOS, non-Apps capable models, and not capable of installing Lightroom at all). It's the Apple TV HD (Gen 4) I am using here, the model below the 4K.

Cheers.

Andy

Adobe Administrator

 • 

8.6K Messages

 • 

122.7K Points

You are correct. I am running a Gen 4 - HD and a Gen 4 4K on my end.  Both are functioning as expected. 

Is it safe to assume your tvOS is up to date?
Adobe Photography Products

Quality Engineering - Customer Advocacy

121 Messages

 • 

2K Points

Hi Rikk,

Yes, I usually leave everything to auto update on most of my devices, the TV is fully up to date.

Everything else is working fine, it's just Lightroom that won't run. I did find an app to test the free space, and it's about 70% unused space at the moment (out of 64GB).

I did try again a few days ago, still no luck.

Thanks,

Andy

Adobe Administrator

 • 

8.6K Messages

 • 

122.7K Points

Thanks for reporting back. I am conferencing in one of the QE for LrTV - standby.
Adobe Photography Products

Quality Engineering - Customer Advocacy

Adobe Administrator

 • 

806 Messages

 • 

14.7K Points

Hi Andy and Rikk
I suspect it's the large number of albums affecting the experiencing here, impacting device resources.  I have logged a bug for this, but Dev hasn't been able to identify a fix through investigation yet.

As a work-around, can you screenshare Lightroom from your phone/tablet/Mac to your Apple TV?  I know this isn't ideal, but I don't have a better work-around at this time.

121 Messages

 • 

2K Points

Thanks for your time on this guys.

I'm astonished that I'm the only one that's come up with a too large number of albums and folders. To be honest, with only a modest collection, I was expecting this to be a relatively small collection. But perhaps there's not too many users with vary large collections using an AppleTV to view them.

Yes, using screen mirror/sharing works OK from either an iPad or iPhone, but as you say, it's not ideal, but workable, which is why I never really panicked about this.

Although, being able to install Lightroom was the primary reason I bought the Apple TV HD in the first place (to replace my older iOS AppleTV 3).

Hopefully it can be fixed at some point.

Regards

Andy.