Skip to main content
Adobe Photoshop Family

5 Messages

 • 

142 Points

Sat, Oct 6, 2018 3:21 AM

Lightroom mobile (iOS): Problems using selective editing

Hi I hope someone can help me.. I am using Lightroom mobile for iPad.. my iPad is the iPad pro 12.9 2017 with 256gb of storage. My issue is this.. when I edit a raw image (Nef file from D800) in Lightroom mobile it lags like crazy... When I am making a selective adjustment it seems to take the brush a long time to catch up which makes it almost impossible to do any serious editing. Has anyone else experienced this issue.. I am seriously frustrated with this issue.. I really like the idea of using Lightroom on my iPad but not like this. My Adobe photography subscription is due for renewal on the 25th October 2018 and if Lightroom mobile is going to be like this then I will not be renewing my subscription.. in fact I have already installed Affinity Photo on my IPad pro with a view to using this instead of Lightroom and already I can see a huge performance difference in the 2 ... So it is critical that someone offers some advice before I csncec my Adobe subscription.. Thank you in advance..

Responses

148 Messages

 • 

2.4K Points

2 years ago

try to close all other Apps not needed for yr editing. And, yes, sometimes the brush reacts with several seconds of lag

5 Messages

 • 

142 Points

I only ever have Lightroom open and if you are happy with a several seconds lag then you are easy pleased Ion the other hand expect and accept nothing of the sought.. I want value for my money...
Shame on you Adobe...

5 Messages

 • 

142 Points

2 years ago

I always only have Lightroom mobile open.. never anything else open..
I have tried everything.. last evening I gave it one more try and at first all seemed well but when I attempted to do a second selective edit on the same photybut a different area it lagged like crazy..
I find it frustrating and rather disappointing that Adobe offer a product that obviously is so inferior it's is ridiculous..

74 Messages

 • 

1.1K Points

2 years ago

Do you see this after a force restart of Lr Mobile as well? - Guido/ Lr  Mobile QE

5 Messages

 • 

142 Points

2 years ago

Yes I do..
I have tried everything I know.. restarted.. reinstalled.. but always the same.. it does the first selective edit fine but then it lags do bad it becomes unusable..

3 Messages

 • 

200 Points

2 years ago

I have the same problem. I am using iPad pro 10.5" 512 Gb which is very fast but selective editing (brush especially) is a big pain (Nikon D800/Sony A7Rii). Only Lightroom CC is open (always latest version of app and iOS), originals are stored on the iPad. I have to wait couple seconds to see changes to the mask. Pick WB tool is laggy too. This is unbelievable. In other hand Affinity photo is buttery smooth with lots of layers. Why? Because of optimisation.

5 Messages

 • 

142 Points

2 years ago

Although I'm sorry you are having problems.. I am glad it's not just me!
I thought maybe the new update this week would fix it but unfortunately it didn't. I am now resigned to not renewing my subscription with Adobe and sticking with Affinity Photo because as you say Sergey it is buttery smooth and I own it!!
Absolutely shameful Adobe..

4 Messages

 • 

86 Points

a year ago

Sorry for resurrecting a months-dead thread but I think people might benefit from an answer. The only response I’ve seen from Adobe was in another thread from 4 months ago. I posted there as well hoping to find some answers.

In my case, my primary camera is a Nikon D800 with pixel dimensions of 7,360 × 4,912. It doesn’t seem to matter if I’m working with a .NEF ( Nikon’s RAW file ) or if I convert to .DNG - after a couple of swipes with the healing brush, Lr CC becomes laggy for the rest of the edit of that image. Too many swipes and editing that image becomes impossible.

I recently purchased a 2018 12.9” iPad Pro for the purpose of editing small quantities of images ( 200 ish ) from wherever I happened to be. This is impossible with Lr CC’s current problems.

2 Messages

 • 

70 Points

Hi, I had this too and found a solution. In LR you can select the album in the left pane and choose to download it locally. If you have the setting on to only download smart previews, it doesn't take a lot of space. Works perfect after this, unless you already tried a selective edit on the pic, you will need to re-import it then.