olivierlacan's profile

37 Messages

 • 

570 Points

Fri, Apr 19, 2019 8:37 AM

Lightroom: Filtering Always Flashes "Oh no! A black hole" for several long seconds

Context: Lightroom CC 2.2 on macOS 10.14.4

I understand that filtering through a large set would take time but this screen should not be displayed when there's an active filtering query that hasn't returned yet. This is a bug.



Lightroom CC needs a proper loading screen when it's churning through a filter query and hasn't completed yet. This Black Hole screen should only be displayed when no query is running anymore. I have a very large library but even filtering through a 50-shot album can take several seconds so it looks like some query is not being properly scoped when the filtering is being done. A SQLite query that filters 5 out of 50 shots should be extremely fast. 

Responses

Adobe Administrator

 • 

10.7K Messages

 • 

142K Points

2 y ago

Lightroom CC is currently 2.2.1 Do you still see the issue after installing the update?

37 Messages

 • 

570 Points

2 y ago

Rikk, that version is not available for me even if I manually check for updates. Sadly it's impossible to click on the build number to copy it (would be a useful feature) but here it is:



Adobe Administrator

 • 

10.7K Messages

 • 

142K Points

2 y ago

Actually, it is easier to go to Help>System Info... . That text is selectable. 

Your Creative Cloud App does not show the update? You can refresh the App by [Ctrl/Cmd]+[Alt/Opt]+[R]

37 Messages

 • 

570 Points

2 y ago

Command + Option + R just quits the app for me and no update shows up for Lightroom CC. 

37 Messages

 • 

570 Points

2 y ago

All right. I can confirm that after upgrading to 2.2.1 this bug no longer seems to occur.

37 Messages

 • 

570 Points

2 y ago

Never mind, the issue re-occurred (after loading new images and while they were still syncing up). So it may be harder to reproduce under 2.2.1, but the bug is still there.