Skip to main content
Adobe Photoshop Family

4 Messages

 • 

130 Points

Wed, Jul 8, 2020 8:16 PM

Solved

Lightroom Desktop: Resets recently edited photos randomly and won't shut down

I've had this happen more than a few times: Lightroom clears all my edits from a photo, when I change selection to a next photo. I've lost more than days' worth of work since I haven't every time notice this happening, and it's a real bummer to see all edits gone after editing dozens of photos in one session. Also, each time this happens, the Lightroom app won't shut down and has to be force quitted. 

There has to be a solution for this, right? 

I'm using version 3.3 on a 2018 MacBook Pro.

Responses

Official Solution

Adobe Administrator

 • 

8.5K Messages

 • 

121.6K Points

a month ago

Greetings,

 

Updates for the Adobe Photography Products were officially released on 10.20.2020 that include fixes for this issue. Please install the most recent update and confirm that your issue is now fixed. Please let us know if you encounter any issues.

 

Thank you for your patience.

 Adobe Photography Products

Quality Engineering - Customer Advocacy

1 Message

 • 

62 Points

5 months ago

Happening to me as well.

1 Message

 • 

82 Points

4 months ago

I also have this problem with the most recent version of Adobe Lightroom. It's reset two of my photos completely to the RAW file, with all of the changes lost. I never had this problem with the older versions of Lightroom CC, so I think this was a new problem that happened with the most recent update. I'm thinking of reverting to the old version so I don't lose my progress on important photos. 

I've also had a few other annoying issues with the most recent update. It crashes constantly, and frequently freezes while importing RAW files. Again, I never had this issue with the previous versions of Lightroom, so it's strange that the new update has basically broken the program for me. 

3 Messages

 • 

36 Points

Did you ever find a solution to the random edit reset issue when you change the image selection?  

Adobe Administrator

 • 

8.5K Messages

 • 

121.6K Points

4 months ago

We'd like to collect a diagnostic log from you the next time it happens. To generate, go to Preferences>Account and hold down the [Alt/Opt] key and choose [Diagnostic Log].  When you have one ready to go, respond to this thread. 

Thanks!
 Adobe Photography Products

Quality Engineering - Customer Advocacy

4 Messages

 • 

130 Points

Hi! Just got this happening again, and I created the diagnostic log before force quitting. Also, the network status on software was "unable to connect" but at the same time, the syncing logo was rolling. Also pasting edit settings wasn't possible during this time. And - as stated in the original post, the edits made in that session were gone. Please let me know where to send the log :)

Adobe Administrator

 • 

8.5K Messages

 • 

121.6K Points

I've emailed you with instructions for the log. Thanks!
 Adobe Photography Products

Quality Engineering - Customer Advocacy

Adobe Administrator

 • 

8.5K Messages

 • 

121.6K Points

Got it. Thanks. I've attached it to the bug for the engineers to review. 
 Adobe Photography Products

Quality Engineering - Customer Advocacy

3 Messages

 • 

74 Points

I am also experiencing this problem on Windows 10.0 with LR 3.3,as well as other  issues. Any help?

1 Message

 • 

62 Points

I'm also experiencing this almost daily. It may be some kind of Adobe Cloud connection issue.

4 Messages

 • 

130 Points

Any updates regarding this issue, or solving it? Problems are still present, and honestly there is no way I am able to continue using Lightroom if there won't be a solution soon - feels like now I'm paying +150 € per year for something that wouldn't be worth it even if it were free. Price gap to competitors has closed ages ago by thousands of euros if we take into consideration the hours of work I've done to cover up the gone edits.

4 Messages

 • 

130 Points

Hate to keep complaining but.. For the past few days, I've had the program crash when launching it, or it opens up the usual way but the library seems completely empty and program is offline, even though the network connection works on all other apps. I have to start and quit, or alternatively have the program crash a few times before it opens up with my photos in it and functions normally. 

3 Messages

 • 

36 Points

having the same exact issue repeatedly and losing a lot time re-editing.

8 Messages

 • 

184 Points

3 months ago

This also happens constantly for me.

  • BUILD: 20200804-0825-1542eef
  • VERSION: 3.4
  • getOS: MacOSX
  • getOSVersion: 10.15.

Also cannot export photos during this time. Seems to be correlated with closing the lid on the laptop with Lightroom still running.

3 Messages

 • 

36 Points

2 months ago

Doesn't look like the "engineers" ever fixed this bug? 

I'm on the latest update and have the same symptoms.