Skip to main content
Adobe Photoshop Family

9 Messages

 • 

202 Points

Wed, Oct 25, 2017 5:33 AM

Lightroom CC: Only shows spinning icon after battery ran out



I was synching my photos, when my Macbook ran out of battery.
It hibernated and started again with power attached.

Now Lightroom is stuck with the progress spinner and does not show my library anymore.

This really does not build confidence of being able to trust all my pictures with a new product in Version 1.0, when after the 3rd day of usage I'm unable to access any of my images!


Here are some logs from Console:

default	22:29:32.981702 -0700	Adobe Lightroom CC Helper	NmbVolumeAgent:ACF65E13-3F74-3135-BA36-EFC196185BD7	ERROR	NmbVolumeAgent:ACF65E13-3F74-3135-BA36-EFC196185BD7	ERROR	maybePurgeLeastRecentlyAccessed encountered an error: %s 	 Database "/Users/stefan/Pictures/Lightroom Library.lrlibrary/79239ecf2a2a4438a6373609fc334137/Managed Catalog.mcat": library routine called out of sequence
Statement: SELECT fullDocId AS selectIdCol, revId, sequence, content, annotation, hasConflicts,
docs.deleted AS deleted, docs.mostRecentRevSequence AS mostRecentRevSequence FROM revs INNER JOIN docs ON docs.winningRevSequence = revs.sequence WHERE docs.localDocId = ? (error code 21)default 22:29:32.983940 -0700 Adobe Lightroom CC Helper Bad sqlite return code: 21. Info: library routine called out of sequence 0: field _bindByPositionMethod - C 1: [unnamed] - 1753170016:1056+27 2: upvalue ? - 67365416:1079+82 3: [unnamed] - 67365416:1387+17 4: global pcall - C 5: [unnamed] - 1753170016:1339+39 6: [unnamed] - tail 7: upvalue ? - 67365416:1415+7 8: [unnamed] - 1151015846:106+6 9: global pcall - C 10: upvalue ? - 1875443985:839+14 11: [unnamed] - 1875443985:951+11 12: [unnamed] - tail 13: [unnamed] - C---------------------------------default 22:29:32.984258 -0700 Adobe Lightroom CC Helper NmbVolumeAgent:ACF65E13-3F74-3135-BA36-EFC196185BD7 ERROR NmbVolumeAgent:ACF65E13-3F74-3135-BA36-EFC196185BD7 ERROR maybePurgeLeastRecentlyAccessed encountered an error: %s Database "/Users/stefan/Pictures/Lightroom Library.lrlibrary/79239ecf2a2a4438a6373609fc334137/Managed Catalog.mcat": library routine called out of sequence Statement: SELECT fullDocId AS selectIdCol, revId, sequence, content, annotation, hasConflicts, docs.deleted AS deleted, docs.mostRecentRevSequence AS mostRecentRevSequence FROM revs INNER JOIN docs ON docs.winningRevSequence = revs.sequence WHERE docs.localDocId = ? (error code 21)default 22:29:32.986296 -0700 Adobe Lightroom CC Helper Bad sqlite return code: 21. Info: library routine called out of sequence 0: field _bindByPositionMethod - C 1: [unnamed] - 1753170016:1056+27 2: upvalue ? - 67365416:1079+82 3: [unnamed] - 67365416:1387+17 4: global pcall - C 5: [unnamed] - 1753170016:1339+39 6: [unnamed] - tail 7: upvalue ? - 67365416:1415+7 8: [unnamed] - 1151015846:106+6 9: global pcall - C 10: upvalue ? - 1875443985:839+14 11: [unnamed] - 1875443985:951+11 12: [unnamed] - tail 13: [unnamed] - C---------------------------------default 22:29:32.986622 -0700 Adobe Lightroom CC Helper NmbVolumeAgent:ACF65E13-3F74-3135-BA36-EFC196185BD7 ERROR NmbVolumeAgent:ACF65E13-3F74-3135-BA36-EFC196185BD7 ERROR maybePurgeLeastRecentlyAccessed encountered an error: %s Database "/Users/stefan/Pictures/Lightroom Library.lrlibrary/79239ecf2a2a4438a6373609fc334137/Managed Catalog.mcat": library routine called out of sequence Statement: SELECT fullDocId AS selectIdCol, revId, sequence, content, annotation, hasConflicts, docs.deleted AS deleted, docs.mostRecentRevSequence AS mostRecentRevSequence FROM revs INNER JOIN docs ON docs.winningRevSequence = revs.sequence WHERE docs.localDocId = ? (error code 21)default 22:29:54.033089 -0700 Adobe Lightroom CC Helper WFRxContinuousTask ERROR Continuous task "WFCatIdleDownloader" sent onError: "<<>>"default 22:29:59.368950 -0700 Adobe Lightroom CC Helper WFRxContinuousTask ERROR Continuous task "NmbVolumeAgent:Proactive" sent onError: "<<>>"


Also, what is the proper way of filing a technical bug report for Adobe products?

Responses

166 Messages

 • 

3.5K Points

3 years ago

Have you tried logging out and back in..... of both Lr CC and then the Creative Cloud app?

9 Messages

 • 

202 Points

Yes, I've tried that. The issue persists.

From the logs it sounds like the SQLite database is corrupt.

166 Messages

 • 

3.5K Points

Here’s another thread with maybe the same problem Stefan?

https://feedback.photoshop.com/photos...

Julie Kmoch may be able to help on there....

9 Messages

 • 

202 Points

I ended up deleting the entire library and migrating all data all over again.

2 Messages

 • 

82 Points

Hi - is there a resolution for this problem? I have the same issue. I'm running LR CC v 1.0.1 and also Lightroom classic 7.0.1 on a mac with high sierra. Web based app works fine, classic program works fine. 

9 Messages

 • 

202 Points

3 years ago

More info:

$ sqlite3 Managed\ Catalog.mcat "PRAGMA integrity_check"

*** in database main ***

Page 133920: btreeInitPage() returns error code 11

Page 137976: btreeInitPage() returns error code 11

Page 137961: btreeInitPage() returns error code 11

Page 137958: btreeInitPage() returns error code 11

Page 137947: btreeInitPage() returns error code 11

Page 137932: btreeInitPage() returns error code 11

Page 137930: btreeInitPage() returns error code 11

Page 137929: btreeInitPage() returns error code 11

Page 137928: btreeInitPage() returns error code 11