Skip to main content
Adobe Photoshop Family

2 Messages

 • 

82 Points

Sat, Dec 29, 2018 4:29 PM

Lightroom CC - Error while importing: Unable to create directory. You don't have permission to save the file...

Cannot import photos into Lightroom CC 2.1.1 on 2017 iMac with Mojave.  I keep getting an error: "Unable to create directory. You don't have permission to save the file "2018-05-20" in the folder "2018".

I have tried with the Preference "Store a copy of all originals at the specified locaton." set to on and off.  When on, I am choosing a location that has read/write privs for everyone.

I was able to import photos to Lightroom Classic without issue.

I am truly stumped with this one.

Responses

Adobe Administrator

 • 

8.2K Messages

 • 

117.4K Points

2 years ago

You likely still have a permission issue at the drive or folder level. You will need to use the Mac OS to change the permissions for your User Account for that (and perhaps other) locations. If changing doesn't work you may need to repair your permissions.  

This may be of help for Repair instructions: https://helpx.adobe.com/x-productkb/global/repair-disk-permissions-running-disk.html
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

3 Messages

 • 

90 Points

Hello, I have the same permissions issue. But the help about repairing the permissions does not fit for Mojave. Any other ways to be able importing my photos ins LR CC ?

1 Message

 • 

60 Points

8 months ago

I had this issue with LR CC. I had changed the name of the folder where LR keeps the original files on my Mac but did not update it in LR. After making the change in LR, the problem was solved.