Skip to main content
Adobe Photoshop Family

7 Messages

 • 

278 Points

Mon, Oct 23, 2017 11:01 PM

5

Lightroom CC doesn't work behind a corporate proxy??

Disclaimer: I don't expect to be a "Lightroom CC" convert, but I thought I'd have a look for kicks. So I installed it on my work Mac, which sits behind a corporate proxy. I have no problems running any of the Adobe applications behind the proxy - they all play nicely with the proxy servers.

But in Lightroom CC, I have a message in the top right corner telling me "Network Disconnected". Nothing happens. Failed at step 1. I can't see any settings relating to proxy behaviour and I can only guess that "network disconnected" means that Lightroom CC can't find its way out through the proxy.

Is this for real? Lightroom CC is 100% "cloud-native", but can't work with a corporate proxy? Tell me I'm doing something wrong...

Responses

806 Messages

 • 

14.7K Points

3 years ago

Hi Nick, I just tested against an authenticating proxy (proxy login required), and could not reproduce any trouble logging into Creative Cloud and subsequently using LRCC 1.0.  As you said, if any of the Adobe apps work in your proxy environment, LRCC should also work.

Can you share more info about the type of proxy configuration your company uses?  For example, Kerberos, PAC+Kerberos, NTLM, WPAD, etc.  

Do you happen to know if your proxy allows port 80 through?  

If you need to sign into your network proxy, can you confirm the Creative Cloud app displays its own proxy login screen (see attachment; if you didn't see this, can you try quitting and re-launching the Creative Cloud app)


Thanks,
Charlie

1 Message

 • 

64 Points

3 years ago

I have the same issue. Adobe Creative Cloud application works perfect, but Lightroom CC gives an error "Network Disconnected". It also shows a crossmark with the Cloud Icon.

We use port 8080 for the proxy server and block port 80 because otherwise people can bypass the proxy server.

7 Messages

 • 

278 Points

3 years ago

We use an NTLM based corporate proxy, but I have always had problems with Adobe products in talking directly to our corporate proxy. So I have a CNTLM setup, which presents a simple local open proxy to applications on my Mac while handling NTLM authentication back to the corporate proxy directly.

The thing to note is that every other Adobe CC product works absolutely fine with my setup. The screen you provided showed up just once when I had to first inform CC of my CNTLM setup, and that's it - all CC products worked seamlessly thereafter.

But not Lightroom CC. It just flat out doesn't work. It also doesn't challenge me for proxy information / passwords. It just says "Network Disconnected".

Oh, and the corporate proxy operates on 8080. CNTLM is able to translate port 80 on the application side to 8080 on the proxy side.

806 Messages

 • 

14.7K Points

3 years ago

Nick, thanks for the details.  I'll try this out myself, and pass our info along to the team.  Basic proxy support including authenticating proxy configs were tested for LRCC 1.0.  I've confirmed with the team that more advanced corporate proxy support is being investigated for a future update.  Your report and info will certainly help inform the team.  Thanks for taking the time to reach out to us!

806 Messages

 • 

14.7K Points

3 years ago

After some discussion with the team, I don’t have much news to share...

I previously neglected to share Creative Cloud’s stated requirements for proxy support: https://helpx.adobe.com/creative-cloud/kb/proxy-authentication-support-creative-cloud.html

This does say NTLM is not supported for Creative Cloud.  After raising your issue with the team, I still can’t say if or when support for NTLM will be enabled in Creative Cloud.  Please check back on the page above periodically for possible updates.  Sorry I don't have something more helpful for you at this time.

Thanks,
Charlie

 

 

3 Messages

 • 

96 Points

a year ago


Any update on this issue?

1 Message

 • 

62 Points

a year ago

CC Client works fine behind proxy, I've only encountered problems with Lightroom, telling me I'm not online... also behind Corporate Proxy, which is configured in CC Client.

1 Message

 • 

62 Points

a year ago

Same for me, after 15 mins it works tho.. but keeps showing as offline ???

1 Message

 • 

80 Points

10 months ago

I have also been battling this issue. What I have found is that when the proxy is manually entered in OS settings the Lightroom CC works fine. When the proxy is set to auto configure or to use a configuration file, the application shows as offline.

I have performed traces with Wireshark and I can see that when the proxy is set to auto, most connections do go through the proxy but the application tries to contact servers within Amazon's cloud directly on port 443. This of course fails because of the firewall. So it seems that the application does not support automatic proxy configuration.

1 Message

 • 

62 Points

a month ago

Just installed CC - and have my Windows system set to auto for proxy - which means LR CC can't connect.