Skip to main content
Adobe Photoshop Family

6 Messages

 • 

120 Points

Tue, Nov 13, 2018 12:58 AM

Lightroom CC 2.0: Performance Issues after upgrading

Hi all, I had been using LR CC 1.0 on a late 2013 Mac Pro with reasonable performance, it was fine. After upgrading to LR CC 2.0 performance is mostly unusable on my Mac Pro. I currently have 19,161 photos in my library and scrolling through any collection of photos is very slow. This is especially so in Grid mode. When scrolling through photos I am seeing very noticeable lag and stuttering and frequent "spinning beach balls." I feel that 2.0.2 improved things marginally but it is still a pretty terrible experience. I have tried with and without "Use Graphics Processor" enabled and don't see a noticeable difference. Also, my library is fully synchronized.

I am running the latest macOS (10.14.1) on my Mac Pro (Late 2013) with 64 GB of RAM.

An anecdotal bit of data, on my 2018 MacBook Pro (32 GB RAM) LR CC 2.0 performed very similarly on the same photo library. I've since updated that system to 2.0.2 and performance on that machine is noticeably better. Scrolling in grid view isn't super smooth but is a lot more usable than when I first tried 2.0 on the MacBook Pro.

Thanks!

Matthew

Responses

204 Messages

 • 

4.1K Points

2 years ago

Why not give this a try... export a subset as a new catalog maybe 1000 pics.... open that new catalog and see if it makes any difference.

6 Messages

 • 

120 Points

Thanks for the suggestion. This is Lightroom CC not Lightroom Classic CC. I don't think the new one has the notion of multiple catalogs? The best test I could come up with was create an album view of fewer photos (291 in this case) and I see the same performance issues.

6 Messages

 • 

120 Points

2 years ago

I am now curious if this is related to macOS 10.14.x as well. The system requirements state that...

"Graphics processor acceleration requirements: 
  • AMD: macOS 10.12 or macOS 10.13 with Metal support."
https://helpx.adobe.com/lightroom-cc/system-requirements.html

Is GPU acceleration really not supported on macOS 10.14.x?

Adobe Administrator

 • 

15K Messages

 • 

286.9K Points

I think that is an oversight. I've asked our documentation guy to confirm. Does your system by chance have a fusion drive in it?

Sr. Product Manager, Adobe Digital Imaging

6 Messages

 • 

120 Points

Nope. This is a 2013 Mac Pro with a 1 TB internal SSD. I do run an external Thunderbolt 2 enclosure where I have LR set to store a copy of all originals but the rest of LR is using the internal SSD.

6 Messages

 • 

120 Points

Jeffery,

Any other ideas? I am at a loss as LR CC is pretty much unusable for me. As a test, I reinstalled LR Classic CC and with an 18,000+ image catalog performance was so much better. Scrolling the photo grid was generally smooth and I didn't see any instances of freezing as with LR CC.

9 Messages

 • 

200 Points

Same poor performance here on iMac 2017 5K + 32gb ram + Radeon 580
grid scrollng very slow, beach balls, and generally slow LR performance.

What do you mean by reinstalling LR ? Deleting the app and redownloading?
i'm using the CC

6 Messages

 • 

120 Points

Marc,

Since I now have the plan that only includes the new LR CC I had deleted LR Classic CC a while back. I was able to install the trail version of the old LR Classic CC via the Creative Cloud application and test against my old catalog. I also tried downgrading the new LR CC to 1.5 and saw noticeably better performance on my system than with 2.0.2.