Skip to main content
Adobe Photoshop Family

11 Messages

 • 

204 Points

Sat, May 19, 2018 10:07 PM

report bug

Maybe two revisions or so ago Lr, (which truth be told is really buggy) stopped displaying large images when I (fast PC custom built for motion graphics and video editing) ask it to display an image in folder at 100%.  It just goes black.  For years before that it would display larger images at higher magnifications, then one day it just stopped doing it.  Now I have to take the image back into Ps or Breeze Browser or even the Microsoft picture viewer to look at it. and I can't use Lr's excellent develop module, which is better than Camera Raw if you do not need to mask. 

And the posted size limits on images are not as advertised, same with Ps (filters), they are more in the Jack Sparrow realm- guidelines. Some images you say won't work still work, others that should work don't. That's bad form.  How can we trust anything?   I make really big images with unusual ratios,  they range from 20,000 x 6,000 to more than 80,0000 x 5,000.  It used to be I could store and view them in Lr, but no more.

And let us set the default location the program goes to when I click import.  It is so irritating for the program to go to the card every time I want to import.  I do not import from cards, I put the images in a folder on a dedicated hard drive, cull the trash with Breeze Browser then import into Lr.

Importing your way is a huge PIA, you want to make copies in different formats and stash them in bizarre spots, and deleting takes an act of congress. No, No, No. 

I do not delete images from cards. I move them to a folder, I found deleting images on a card from the computer corrupted cards, so I just move them into a folder, clean it up, then import. 

Give us the option of setting the default import go to. 

And let us color code folders.   

Responses

226 Messages

 • 

3.9K Points

3 years ago

I also download images from the card to a folder and then import from the folder. I used to be able to "eject" the card while LR was open, but since 7.3, I have to close LR to safely eject the SD card.

Champion

 • 

5.9K Messages

 • 

103.9K Points

> since 7.3, I have to close LR to safely eject the SD card.

That's a confirmed bug that should be fixed soon Lightroom Classic 7.3: Unresponsive after Eject SD Card/USB Drive

Victoria Bampton a.k.a. The Lightroom Queen

www.lightroomqueen.com

Author of Adobe Lightroom Classic - The Missing FAQ and Adobe Lightroom - Edit Like a Pro books.

Champion

 • 

5.9K Messages

 • 

103.9K Points

3 years ago

> posted size limits on images are not as advertised

Photos can be no larger than 65,000 pixels along the longest edge, and no more than 512 megapixels (not megabytes)—whichever is smaller. A photo that is 60,000 x 60,000 is under the 65,000 pixel limit, but it still won’t import as it’s over the 512 megapixel limit.

Can you give the exact dimensions of one that won't import? Better still, can you upload one somewhere, so someone can try it on their computer?

> Importing your way is a huge PIA, you want to make copies in different formats and stash them in bizarre spots

You set the import settings in the import dialog. If you've already put the photos in your chosen folder, select ADD at the top of the import dialog so it adds them at that location.

> And let us color code folders.

Add your vote to this request https://feedback.photoshop.com/photoshop_family/topics/colour_coding_folders_and_collections_to_simplify_navigation_cataloguing

Victoria Bampton a.k.a. The Lightroom Queen

www.lightroomqueen.com

Author of Adobe Lightroom Classic - The Missing FAQ and Adobe Lightroom - Edit Like a Pro books.