Skip to main content
Adobe Photoshop Family

12 Messages

 • 

210 Points

Fri, Dec 22, 2017 3:20 PM

RAW files in camera not visible in LR - will not import

I am a long term user of PS & LR and subscribe to Adobe CC so I should have all software at the latest issue. There has recently been an upgrade to LR (Dec 2017) which added a couple of features and updated to the latest RAW support. Since then when I connect my Canon 5D Mk3 to my PC I am told there are no photos to import. In fact there are photos which I can import via Canon software. As an experiment I took some photos in both RAW and JPEG (which I never do in "real" situations) and LR imported the JPEGs directly from the camera and ignored the RAW files. I have tried all update routes but the problem persists. I can't find any way of going back to the earlier version to see if the problem goes away other than a Windows system restore which will cause me a huge problem. Does anyone have any suggestions?
As a final point, trying to import via PS gives exactly the same issue. The 5D has been supported by Camera Raw since it came to market so there should not be a support issue for the camera.

Responses

253 Messages

 • 

3.3K Points

3 years ago

Hello Frazer, 
I use LR and PS since a long time as you... And one of the camera I use is a Canon 5DMkIII 
I made the last upgrade and I don't get the problem you describe.
Both, PS and LR recognise CR2 files coming from my different camera as well as from the 5DMkIII

12 Messages

 • 

210 Points

I have done some more trials and have found that I can import from my camera using MS Photos then sync to LR. Once the photos have been imported there are no issues. I am beginning to feel that the last update corrupted something because I also notice that in the import dialog options the "include subfolders" option is checked (as always) but is "greyed out". This still doesn't explain why I can import JPEG however as the are in the same camera sub folder as the RAW file?????? I feel a reinstall coming on but I will wait awhile to see if anyone has any other solution.

253 Messages

 • 

3.3K Points

Ok, I see MS Photo is a windows app. May be it's this soft that cause you the trouble.

Do you use MS Photo for other purposes?

Perhaps isn't it correctly upgraded or perhaps Adobe doesn't' consider that app due to they have an import process included in LR ???

I am on apple computer. But this doesn't change anything.

Just try to import your pictures directly from your camera using the LR function.
- Connect your camera and set it's switch on
- Then open an LR catalog and clic on the "import" button situated in the library screen down on the left.
- You then come to the import screen. As you can see on the next dum-screen. As you can see, on the upper lefthand side the camera is recognised by LR

From that screen You can make your import settings like changing picture name, defining the file name where the pictures should be recorded.... etc...  

12 Messages

 • 

210 Points

Unfortunately that is exactly what I have done for years. The existence of MS Photos makes no difference as it is normally disabled. I tried that to make 120% sure that it isn't an issue with my camera.
As I have noted the screen you describe happily imports JPEGs but will not import RAW when the are both coming from the same directory - that's the problem! LR import does not "see" any RAW file in the camera.

253 Messages

 • 

3.3K Points

I do clearly understand.... Did you tried to import using only the LR functions?

12 Messages

 • 

210 Points

Yes - JPEGs OK but no RAW.

253 Messages

 • 

3.3K Points

Quite strange.


When you did that, did you saw the CR2 file in the showed by LR in the download screen?

Have you tried to load your CR2 files directly from your camera to a new folder?

12 Messages

 • 

210 Points

Even stranger - for absolutely no reason because I have changed nothing I just tried another test photo and the import worked exactly as it should. To answer your points previously LR reported that there were "no Photos" and to your second point that is what I have always done although some people say it is better to use a card reader (which I don't have!). I will try some more shots tomorrow and let you know if the problem returns. Thanks for your input,

253 Messages

 • 

3.3K Points

Ok perfect if it work! Just another test?

To read pictures on the card. To my opinion, there is no reason to put the cards into a reader. I did this for several year and than stopped since I saw the result of that manipulation made by a friend on his camera.

He is a strong guy and one time he had difficulties to enter the CompactFlash card into the camera. He push harder... result has been that some of this very thin pins (in the camera) were ployed putting the camera out of service. Repair was almost costly. He didn't saw that the card was wrongly placed.

So I decided to buy a big capacity CompactFlash card and never get it away....

12 Messages

 • 

210 Points

I have never used a card reader and don't want to start so fingers crossed the problem has "gone away". I can't say solved because I have not changed anything!!

253 Messages

 • 

3.3K Points

This may occur, good chance for that and beautiful pictures with the awesome camera

253 Messages

 • 

3.3K Points

3 years ago

when you write: "I tried that to make 120% sure that it isn't an issue with my camera." As a very first reflexion, I will say that your camera is OK. A test to do this would be to load the CR2 files in an other folder and try to read them with different applications the can recognise these CR2.
For instance you could try with the Canon like Digital Photo Professional. 
Other possibility but I am not completely sure is that the camera pilot is not up to date. Mine is not and pictures are stil readable. But I am in the Apple world