Skip to main content
Adobe Photoshop Family

2 Messages

 • 

220 Points

Tue, Mar 6, 2012 2:32 PM

Solved

Photoshop: Lightroom 4 requires Camera Raw 7.0

LR4 uses Camera Raw version 7.0. (it says so on the about plate). However there is no CR 7.0 available for PS. The PS: Help->Update says all up to date - there is no option to install CR7 that is required and warned about when "Edit in PS" is selected in LR4.

Responses

Official Solution

Adobe Administrator

 • 

14.6K Messages

 • 

283K Points

8 years ago

As Chris states earlier on, the dialog should have pointed users of Photoshop CS5 to Camera Raw 6.7 and pointed users of Photoshop CS6 to Camera Raw 7.0 once it became available (and has become available since the initial LR4 release):

Camera Raw 6.7 (currently available on Adobe Labs: http://labs.adobe.com/technologies/ca... ) provides compatibility between Lightroom 4 and Photoshop CS5. The final release of Camera Raw 6.7 through the Adobe update mechanism will be available in the very near future.

Camera Raw 7.0 (currently available on Adobe Labs as party of the Photoshop CS6 beta: http://labs.adobe.com/technologies/ph... ) provides seamless compatibility between Lightroom 4 and Photoshop CS6. The final release of Photoshop CS6 will be available later this spring.

Sr. Product Manager, Adobe Digital Imaging

2 Messages

 • 

220 Points

9 years ago

7 Messages

 • 

120 Points

Same message in LR 4.2 when using PS CS5

1 Message

 • 

62 Points

9 years ago

Same deal. No way to find this plug in either. Googling like mad.

15.1K Messages

 • 

195.8K Points

9 years ago

It should say Camera Raw 6.7. Sorry for the confusion.

1 Message

 • 

60 Points

9 years ago

You have to use Camera Raw 6.7 Release Candidate

52 Messages

 • 

736 Points

9 years ago

This just about sums up this release of LR. It's asking for stuff that doesn't even exist. I'm using 6.7 and I'm still getting this message.

FFS, the more I try to use LR 4 the more frustrated I get but I'm hoping with the myriad problems being cited here Adobe will get on with a fix.

1 Message

 • 

62 Points

9 years ago

im working in LR4 for this big company (Cant say) and LR 4 doesn't work well with Photoshop and i have a dead line please adobe make this work

107 Messages

 • 

1.5K Points

9 years ago

I fyou have deadlines to meet and serious work to get done, go back to 3.6.

2 Messages

 • 

72 Points

8 years ago

I have the same problem with LR4, except with the added affect that if I "open anyway!" CS5.1 crashes! I reget upgrading from LR3 to LR4.

1 Message

 • 

62 Points

8 years ago

When I go from LR4 to CS5 I get a notice "This version of Lightroom may require the photoshop camera raw plug-in version 7.0 for full capability." Subsequently, I learned 7.0 is not out yet and I should install 6.7. Done however, I still get the aforementioned message. I don't follow some of the comments on the forum and need someone to dumb it down for me.

This reply was created from a merged topic originally titled
LR4 requiring Camera Raw 7.0.

3 Messages

 • 

80 Points

8 years ago

Once I install CR 6.7 how do I make Lightroom 4 use that rather than process in Lightroom with the creation of a Tif file?

Adobe Administrator

 • 

14.6K Messages

 • 

283K Points

Right Click and select "Edit in Photoshop CS5"

Sr. Product Manager, Adobe Digital Imaging

3 Messages

 • 

80 Points

Still uses the lightroom conversion and creates a tif filerather than going straight to PS5

3 Messages

 • 

80 Points

Ok figured it out now, its because I set CS5 as a user edit program following the install of CS6 beta which has set itself as the default editing program which I can't seem to change. However if I have CS5 already open them clicking edit in CS6 takes it to the open CS5 - go figure, not as I would have expected.

18 Messages

 • 

258 Points

8 years ago

There seems to be an issue with LR4/PsCS5 workflow due to the fact that LR4 uses ACR 7, which is not available for CS5. What this means is that you've released a major product from your suite that introduces a significant glitch with workflow with the latest available version of another product in your suite, and you can't spin that as anything other than a glaring flaw. Opening in Lightroom is not a viable option, as that creates a potentially unwanted file immediately. Obviously, waiting for CS6 is not a viable option, especially since an upgrade will presumably cost about $200 and we don't even know when it will be available... Several users have been told to download ACR 6.7, but this does not correct all reported issues and directing your users to utilize a version of camera raw that's still in beta is not acceptable. No matter how you spin this, you've released a major component of your suite that is not compatible with the latest version of another major component of your suite. Anything less than an immediate release of ACR 7 for CS5 is a failure to address this issue--it's beyond unimaginable that users who are leveraging about $800 worth of your products are experiencing very basic workflow issues. Please let us know when this will be resolved.

This reply was created from a merged topic originally titled
Lightroom: LR4 workflow with Photoshop CS5 broken due to lack of ACR7 for CS5.

Champion

 • 

1.4K Messages

 • 

24.5K Points

8 years ago

Adam,

Lightroom is not and never has been part of any Adobe Suite. It has never carried a CS designation. I have never seen it written or heard it implied that PS and LR would always be in lock step and backward compatible. There is no need to spin this.

A significant portion of the Lightroom user base does not use Photoshop. Many use Elements or non-Adobe branded product. Of those who do use Photoshop, not all are using CS5 or later. This means a host of LR users are unaffected by this lack of seamless data interchange.

If you do use Photoshop and are unwilling to upgrade to CS6 you have avenues available via the Free DNG Converter, or Rendering in Lightroom to continue working. Yes, it will cost you some hard drive space.

18 Messages

 • 

258 Points

You're completely missing the point. Whether or not LR is part of the CS suite is completely irrelevant. Adobe included functionality that simply does not work as it is intended and the work-arounds offered are unacceptable. I don't know how to make that any clearer.

This was incredibly sloppy implementation, and incredibly sloppy support, and frankly, fanbois coming to Adobe's defense with straw man defenses isn't terribly helpful.

2.6K Messages

 • 

33.7K Points

You don't have to use LR4, yet, if you find the integration and workarounds unacceptable. I would expect things to work better with the final release of ACR 6.7 and LR4.1. Those that do not have a cross-product dependency are happy to see a new version of LR4 sooner rather than later.

18 Messages

 • 

258 Points

Thanks again, Steve, for the exact same advice you offered several weeks ago. Not only is the suggestion that I avoid the product still incredibly helpful, but probably also much appreciated by Adobe.

2.6K Messages

 • 

33.7K Points

It is what it is.

2 Messages

 • 

72 Points

8 years ago

I’ve installed Camera Raw 6.7 (as I have CS5 installed on my computer) to see if this fixes the problem; but sadly I can report that LR4 still has the same problem, throwing up a dialog each and every time: “This version of Lightroom.... Please update the Camera Raw...” Personally I think this is extremely poor of Adobe to require you to upgrade to CS6/CameraRaw7 if you want to use LR4 without the drama; or is it simply that Adobe isn’t even doing the most basic compatibility testing of their current software.



No "Don't show again" option; makes working in LR4 a pain!

2.6K Messages

 • 

33.7K Points

8 years ago

Try LR 4.1 RC, I think it doesn't warn, anymore, about ACR 6.7.