Skip to main content
Adobe Photoshop Family

22 Messages

 • 

494 Points

Thu, Jun 16, 2016 9:24 AM

Memory leak

During a period with heavy adjsutment brush work I have found that LR gets slower and slower for each image I edit. Through a conversation with Trshaner on your forum I have learned that there is a memory leak in LR that causes gradual performance decrease which is seen by LR eating up memory bit by bit until a restart of LR clears it. Trshaner reproduced the behaviour as you can read in the thread.

This is not ok Adobe, as I wrote yesterday on the forums regarding this : https://forums.adobe.com/message/8813...

it seems unfair that LR users again and again has to live with a half finished product that has not been tested properly by Adobe before launch. And ss I wrote, I pay my monthly CS fee and expect to get bug free apps, at least so bug free that the overall impression is that they are working. This is not the case as it is with LR right now.

Best regards
Steen Knarberg

Responses

87 Messages

 • 

1.6K Points

4 years ago

You don't have to restart LR.
Just minimize it, wait 5 to 10 seconds, maximize it and then it works for another 12 pictures or actions and then do it again...

22 Messages

 • 

494 Points

4 years ago

Hi Stefan. That's probably right, but ti is still very annoying when it supposed to work without this workaround. Adobe has to get on their feet and get this fixed... But thanks for your reply :-)

Employee

 • 

1.7K Messages

 • 

32.4K Points

4 years ago

Are you doing a lot of brushing on a single photo? We might consider clear the develop history once a while to see if it helps.

Principal Scientist, Adobe Lightroom

22 Messages

 • 

494 Points

4 years ago

After the latest update, I still see performance issues after editing for some time, especialy with the adjustment brush. LR gets slower and slower until using the adjustment brush gets impossible due to lag. In task manager LR use almost 6 Gb of memory and settles down to around 4 Gb when minimizing it. If this is a memory leak I don't know, but the behavior resembles what I saw last time this was an issue. I just can't understand that LR has to be this slow on a high end laptop like the Thinkpad P70 with 32 Gb of ram and a Quadro M3000M graphics card and only SSD's. I've read and followed every peace of advice on tuning LR for best performance, but is seems the effort only makes minor difference.