Skip to main content
Adobe Photoshop Family

2 Messages

 • 

700 Points

Tue, Sep 29, 2015 1:48 PM

Planned

86

Lightroom: Support for importing Live Photos (iOS 9, iPhone 6s)

Just got iphone 6s. One new feature is "Live Photos" which while taking a still picture also takes a 3 sec movie. When imported into Apple's Photos app each Live photo becomes 2 files, a movie file and a normal picture file that can be edited. In lightroom the imported Live photo file is only a movie file, which can"t be edited. Can this be changed in a future update so that importing also gives a normal still picture file and a movie file?

Responses

10 Messages

 • 

196 Points

4 years ago

My Lightroom does not support it at all. I just get jpeg file from Live Photo file. And there is no movie file at all. I have iPhone 7 Pro. I can't see them in my library on iPhone neither on Mac

Adobe Administrator

 • 

508 Messages

 • 

9.7K Points

Edward,
Could you please let us know the Lightroom version you use?

Thanks,
Sunil

10 Messages

 • 

196 Points

the last one
iOS : v 2.7.1 3D4B98
Mac : 2015.9

I've just checked one more time. Made the Live Photo. And they are simple jpegs.

5 Messages

 • 

102 Points

4 years ago

I'm so sad. I've just imported 2 months of photos of my newborn babe. Deleted pics of iphone and then realised to my dismay that they are ALL mov files in lightroom. Needless to say I've turned off LIVE on the iPhone now, but it's too late. Any ideas what I can do? 

15 Messages

 • 

292 Points

Do not despair  just yet!
When you delete an image, it goes to a folder  in Albums called Recently Deleted that have to be emptied manually unless you wait 30d and then they are autogamagically deleted I believe.  Check in that folder to see if your newborn photos are there.  

Do you have iCloud Photo Library on?   if so they might be in your iCloud account also. Or if you put them in an iCloud Shared Album, they could exist there maybe independent of your iPhone?

The movie file may have also imbedded a jpg in it when it transferred and Lightroom just cannot see it?  but it exists? and someone with much greater knowledge than I can assess and help you pull them out?

Finally, if you do not take any more pics for a short time ( or have not taken many), the images MAY be able to be recovered from the area in memory they were stored.  not sure about that with a phone, I know that can happen with DSLR's memory cards and certainly on a computer hard drive.

I hope at least one of these hits the mark or is at least close to it.

Good luck with it-sp

5 Messages

 • 

102 Points

Scott thanks so much for taking the time to reply so promptly. I used an importer called Image Capture and I'm afraid they immediately disappear, not even in trash. But good point, I'll google that and check. Will also look into the embedded jpeg thing, but I feel like that might have been mentioned above it was a thing? Anyway, all good ideas. Have already checked iCloud and I don't have it turned on but will now. Anyway, thanks again. 

15 Messages

 • 

292 Points

My pleasure-I was not aware image capture could get around the Recently Deleted movement of deleted files. I thought it just put them there which would account for them not being in the trash anywhere.  I do not mean to beat a dead horse...but did you find the Recently Deleted album?  Anyway, If you have a genius bar near you, they may be able to recover from the phone directly if that is even possible.  Last thought, did you send ANY of the files to friends or grandparents, etc.... You may not get all of them back that way, but not ALL would be lost.   Post Katrina, some folks down here were able to recover some of the lost 'hard copy' images because family and friends had them out of state...  sp

13 Messages

 • 

280 Points

Right click on the file in Lightroom, click "showing finder", or "show in explorer".  See if there's a JPG file on your hard drive beside the movie file.

It's probably that Lightroom assumes the JPG is a cover photo for the movie.  So Lightroom may not have touched it at all.

If you find them there, copy them out to another folder.  Just the JPGs, not the movies.

5 Messages

 • 

102 Points

Thanks very much for this John, I will do 

5 Messages

 • 

102 Points

Scott unfortunately the Recently Deleted album only has the ones I had deleted from my phone directly, so in other words rejects!! Thanks for the thought, though. 

5 Messages

 • 

102 Points

That worked a treat John. Thanks so much!!

13 Messages

 • 

280 Points

4 years ago

Hi. It still doesn't work with Lightroom Mobile, right? I have LR mobile set to automatically import from my iPhone, and I only get the .jpg images, not the .mov movies. I just imported all my photos from our iPhones using the cable and indeed the .mov files were imported, but it was slow and I also got a lot of duplicate .jpgs. LR Mobile should import the .movs and the .jpgs.

I think the API was just released. https://developer.apple.com/live-photos/ So, hopefully you can introduce live photo support in the native iOS app.

1 Message

 • 

82 Points

4 years ago

I facing this bug since over 8 months. 50% of my Live Photos are shown as green thumbnails and cannot be playbacked. For a commercial software in this price class a weak performance.

Dear Adobe Team: When will this BUG finally addressed?

20 Messages

 • 

544 Points

Hi Philipp,
Which version of Lightroom you are using?

6 Messages

 • 

194 Points

4 years ago

I still have the problem with most Live Photos where the mov are only showing up as a green screen and not playable. I am using version 6.10.1 of Lightroom for mac.

36 Messages

 • 

458 Points

3 years ago

This reply was created from a merged topic originally titled Lightroom Defect: Some iPhone 7 LivePhoto files imported as green blobs.

When I import iPhone LivePhoto MOV files, some of them import successfully, while others just show up as green blobs - thumbnails are just completely green squares, and playback is just the same green, although I can hear the audio.  I have repeated the import process multiple times in brand new catalogs, and the result is the same.  The files that were successfully imported are always successful in subsequent imports, and likewise the failed ones always get the same green blob.

I am using LR 6.10.1 on Mac Sierra 10.12.5 and my iPhone is running 10.3.2.

12 Messages

 • 

354 Points

3 years ago

Lightroom CC 2015.10.1 on a Mac seems to have improved but not completely solved this problem. Out of 120 LivePhotos imported only 6 show as unplayable (in LR) green.  In addition, all my previously imported LivePhotos which had this problem still show as green.

Come oin Adobe, please provide a complete fix!

1 Message

 • 

60 Points

3 years ago

Please engineers of Adobe, please add support for Apple live photo. For now, it's the only reason who prevent me to use Lightroom. (Maybe the new heic file format too). Thank you.

1 Message

 • 

60 Points

3 years ago

I am having the same issue.  I just updated lightroom, but the movie files are showing as green thumbnails.  Why does it state above that the issue is solved.

2 Messages

 • 

74 Points

3 years ago

I am still seeing mostly green blobs when I import live photos. I am running 6.12 on a Mac. While I believe you have made improvements, I am not seeing them.

6 Messages

 • 

194 Points

3 years ago

I upgraded to 6.12 on Mac and NO improvement with the green screens on Live Photos. Common Adobe, time to fix this problem. 

5 Messages

 • 

134 Points

3 years ago

I am shocked and dismayed that Adobe have still not fixed this major issue after 2 years!
I still cant import or my photos from my old iphone 6s.  Even if I use the undesirabe "treat RAW and JPG separete (which screws up all my other cameras), it still gest all the movies previews upside down. Honestly, this would take 30 minutes for a developer to fix - just treat movies and jpgs as different files and fix the upside down bug.

Adobe Administrator

 • 

508 Messages

 • 

9.7K Points

3 years ago

John,
Are you on Lightroom 6.12? It should work normally. There shouldn't be any issue with import of live photos..
However, some live photo videos won't play as Michael pointed out. We will fix the same in the next version of Lightoom. 

Thanks,
Sunil

5 Messages

 • 

134 Points

I am using Lightroom version: CC 2015.5 [ 1067055 ]
i have auto update enabled, so I can only assume this is the latest version.
importing from an iphone 6s is completely broken in this version still.  It does not work at all, and requires renaming of all files by hand which takes a very long time, and also the video part is still upside down.  I have wasted so many hours because of this 2 year old bug.

Adobe Administrator

 • 

508 Messages

 • 

9.7K Points

CC 2015.12 is the latest version.
Don't you get update notification in the Creative Cloud app?

Thanks,
Sunil

5 Messages

 • 

134 Points

I never use the creative cloud app. Is servers no purpose other than to slow down startup of my machine.  I disabled it from startup years ago.  It is a great shame that lightroom doesnt know how to update itself like every other windows app.  I have just updated manually to 2015.12, I see the upside down videos have been fixed at least.

1 Message

 • 

60 Points

3 years ago

I just updated to 6.12 (windows x64) and ran synchronize on my photo storage.  All of my live photo .jpg files (previously imported seperate from raw) are being reported as missing, but they do exist on disk. 

As a test I let synchronise remove them (it left the .mov files in the catalog but did remove the .jpgs), then ran it again, the second time it added them all back as new files to import.  Ran it a third time and it reported them as missing again.

I don't often use synchronise as I have import move files for me, as such this isn't a huge problem for me personally, but something is definitely wrong with how this is being handled.

1 Message

 • 

60 Points

3 years ago

Im using the latest version of lightroom on my mac (CC 2015.12 build1125239) and Im still getting the green screen.
When I click to view in finder they are there just fine as a .mov but this is really inconvenient as I use Lightroom to manage all of my pictures and videos. 

Not all of the live pictures are like this though, some work just fine which is a bit strange.
 
Any suggestions if a) this is something I need to fix or b) its still awaiting to be fixed after what looks like 2 years of issues :/
Thanks