Skip to main content
Adobe Photoshop Family

16 Messages


360 Points

Sun, Mar 11, 2012 2:29 PM

Lightroom: Problems with metadata in video files in LR4

All my video files present some sort of problem with metadata.

*.mp4 (without sidecar *.thm) and *.mpg
Metadata Status: Unknown
If I click on the button to resolve the conflict I get the message "There was an unknown error while writing metadata to this photo. Retry?"
Nothing happens clicking on either button ("Import Settings from Disk", "Retry Metadata Export")

*.mp4 (with sidecar *.thm), *.mov, *.avi
Metadata Status: Conflict detected
Clicking on the button to resolve the conflict I get the message "The metadata for this photo has been changed by both Lightroom and another application. Should Lightroom import settings from disk or overwrite disk settings with those from the catalog?"
Nothing happens clicking on either button ("Import Settings from Disk", "Overwrite Settings")

Anyone with this same problem?




5K Messages


91.7K Points

9 years ago

LR 4 doesn't know how to save metadata back to video files. The messages you are observing are LR's poor way of communicating that. Please see this feedback topic and add your opinion and vote:

2 Messages


80 Points

If Lightroom does not know how to write metadata back to video files, does it know how to write metadata back to xmp (text) or jpeg (image) files?

e.g. to those (in)famous "sidecar" files that serve actually little purpose besides sitting next to the aforementioned video files, being imported together with the aforementioned video files, getting renamed with the aforementioned video files, yet being neglected thereafter.
Whereas they could be used for, hmmm, well, let's say... hold any metadata related to the aforementioned video files? Just like, hmmm, for instance, .xmp or .thm sidecars and such?

What about that, Adobe? I'm pretty sure it doesn't take a rocket scientist to write some xmp or jpeg sidecar file...

4.5K Messages


76.3K Points

9 years ago

After taking an inordinately long time to save metadata (close to an hour probably, for 12000 photos), the following dialog box was presented:

I don't mind seeing this once, but I sure don't want to see it every time I have a video file mixed in.

Is this normal?


This reply was created from a merged topic originally titled
Lightroom 4: Save metadata errors..

12 Messages


320 Points

9 years ago

Having pictures and videos (*.MOV) files in a folder I often want to save all metadata of all pictures. So I generally would go for CTRL+A, CTRL+S which worked flawlessly in LR3.

In Lightroom 4 this generates the error "Could not write metadata. Unknown File formats" for all *.MOV files. Of course it can't write the metadata - it writes the metadata to the accompanying *.THM files.

Please let me choose to disable this error message as I don't care that Lightroom "could not save metadata due to file format" or bring back the behavior of LR3. If there are sidecar files (*.THM) you do not need to generate this error.

Also see my forum post at

This reply was created from a merged topic originally titled
LR4: Saving metadata with movies and images selected generates an annyoing error.

8 Messages


140 Points

8 years ago

I am getting the error "could not write metadata. unknown I/O error (163)" after saving GPS data as well as other information to about 500 photos (definitely no movies!!!). The list of files for which Lightroom (v4.0) claims that it could not write the metadata is 163 files long.

However, when I clicked OK (what else should you do?) I found only one file in the whole catalogue with "metadate needs to be written" and when I initiated a "write metadata to file" for that one it worked fine.

I was wondering whether Lightroom not only didnt write the metadata but also deleted it from the catalogue so I went to the map to see if the images tagged with GPS locations in a particular city would show. - They didn't! So I went to them directly in the Library module and found that they do have GPS tags. So I clicked on that tag to bring me directly to the location on the map and it did (well, not exactly, it brought me to the city centre, not to the GPS coordinates of that phot, but that's a different story), and suddenly also the other images showed up.

So now my impression (havnt checked all files) is that except for one file, the whole error message was wrong which is almost more annoying than getting a proper error message for a reason.

I thought this was a program for professionals!

Well, I'll stop complaining, hoping that someone from Adobe will clear this up.

8 Messages


140 Points

OK, after looking at the files in windows explorer, I understand better what happened: when lightroom could not write the metadata into the jpg-file, it created a sidecar (.swp file) for it. That's why those images where not tagged as "need to write metadata" any longer.

Nevertheless, I still don't understand why those files could not be written into. They are not write protected.

I tried to find a pattern and the only thing I can see at this point is that they were either previously edited in Adobe Photoshop or ACD Systems Digital Imaging (according to the file information), or they are not genuine digital photographs but digitized analogue images (of the kind that you sometimes get when you sent your film roll to the lab for paper prints).

Now the question is, why can't Lightroom write into those files or rather: how can I get it to do so?