david_thorpe_5104389's profile

7 Messages

 • 

150 Points

Mon, Jan 7, 2013 12:52 PM

Lightroom: Panasonic GH3 files do not show GPS data in LR EXIF

I note RW2 Files from the Panasonic GH3 and imported as DNG in LightRoom do not show GPS location in EXIF data even though it is present in the original file and the DNG file.

I'd like to report this as a bug.

(LR4.3/Win 7 64bit)

Responses

Official Solution

Employee

 • 

478 Messages

 • 

10.7K Points

8 y ago

Hi David,

I am able to reproduce this problem, and I've entered the issue into our bug database.

Thanks,
Ben

Official Solution

Adobe Administrator

 • 

15.9K Messages

 • 

296.4K Points

4 y ago

This was fixed in Lightroom 5 or later.

Champion

 • 

677 Messages

 • 

8.7K Points

8 y ago

How do you know there's GPS in originals? Where is the embedded GPS coming from? Does the camera feature a built-in GPS unit?

7 Messages

 • 

150 Points

8 y ago

Exiftool shows all the information in both the RW2 and the imported DNG File.

The GH3 imports data via wifi direct from your mobile phone via Lumix Link. It makes its own wireless link which is how you operate the remote control and remote viewfinder as well.

I have put example files and screenshots at:

http://www.dthorpe.net/gpsquery/gpste....

7 Messages

 • 

150 Points

8 y ago

I meant to add, here is the thread on LR Forums where I first voiced this query.

http://forums.adobe.com/message/49741...

Adobe Administrator

 • 

15.9K Messages

 • 

296.4K Points

8 y ago

Hi David, can you post an affected file? My guess is the metadata in the files might be outside the XMP standard. We could tell by looking at a file. (Post to dropbox or other download service)

Champion

 • 

5.9K Messages

 • 

102.6K Points

8 y ago

As discussed in this thread:

http://forums.adobe.com/message/49741...

I used Exiftool to examine the metadata very closely, and it appears that if there is an incompatibility between the camera and LR, it is at the byte-level format of the IFD0 GPSInfo entry. If you use Exiftool to simply copy and rewrite the GPS entry, the GPS metadata will then be imported by LR 4.3:

exiftool.exe -tagsfromfile gpstest2.RW2 -gps:all gpstest2.RW2

Note that Exiftool doesn't complain about the metadata; usually it gives at least a warning about non-conformant data formats. While not dispositive, Exiftool's track record in such cases is pretty strong.

7 Messages

 • 

150 Points

8 y ago

Thanks again John.

Jeffrey, if you look at my previous post you will see where I have placed some files in a zip for downloading.

Thanks for your attention.

Adobe Administrator

 • 

15.9K Messages

 • 

296.4K Points

Ahh. Sorry. Missed it. I will get it in front of someone.

7 Messages

 • 

150 Points

8 y ago

Thanks for the prompt attention, Ben.

Champion

 • 

221 Messages

 • 

4.1K Points

8 y ago

Ben, this is a widespread issue and was waiting for you guys to return from holidays. Happens to me with NEFs and Nikon GP-1, used to work ok!! TIffs derived from DNGs work ok???

Champion

 • 

5.9K Messages

 • 

102.6K Points

Does this command line allow the GPS metadata to be imported:

exiftool.exe -tagsfromfile test.nef -gps:all test.nef

If not, then perhaps it's a different issue.

Champion

 • 

221 Messages

 • 

4.1K Points

I'm not going down that road thanks John, I know the team will resolve this as it is a new bug.

Champion

 • 

5.9K Messages

 • 

102.6K Points

As long as you're reasonably confident it's the same bug.

7 Messages

 • 

150 Points

8 y ago

John, running exiftool.exe -tagsfromfile gpstest2.RW2 -gps:all gpstest2.RW2 on my file and then importing into Lightroom does result in the the GPS and Altitude metadata entries in Lightroom being displayed correctly.

I can't speak for the .nef files, of course.

1 Message

 • 

60 Points

8 y ago

The GPS coordinates embedded in JPG's aren't visible in LR 4.3, and the locations are not displayed in Maps.

The GPS data is taken from the Bilora GT-10 geologger (Jobo has an identical logger) is then assigned to each file using the Taggr software from U-blox. For JPG files the GPS data is embedded in the JPG's, and for the ORF (Olympus raw) files the GPS data is written to XMP sidecar files.

For the JPG's, Taggr puts the GPS coordinates in the Exif metadata, and the text data (city/county/country, highways numbers etc) in the ITPC metadata.

The text data from Taggr is shown as "Image title", and also availble as suggested keywords int the LR4.3 Library section. The GPS coordinates filed is empty.

With ORF files (Olympus raw files) all GPS coordinates are shown correctly, and also the location in Maps. However, the location data (city etc) is only shown as a keyword, and the "Image title" is shown as "OLYMPUS DIGITAL CAMERA"

In Zoner Photostudio the GPS coordinates are shown correctly for both JPG and ORF files, including showing the position in the Map part (Zoner uses Google Maps). Picture Window Pro does also show the correct GPS coordinates, akthough it doesn't have a map module.

Apparently, the GPS data is embedded in the JPG's, and other software can read and display it. Is ther a bug in Lightroom 4.3, and a convenient workaround?

12 Messages

 • 

280 Points

8 y ago

I have the same issue with my Sony DSC-HX9V compact camera, but with a twist. The GPS and Altitude appear blank in the EXIF metadata in the Library module view, but when I switch to the Map module, lo and behind it is littered with orange balloons at the right locations for all of the selected photos.