Skip to main content
Adobe Photoshop Family

134 Messages

 • 

2.1K Points

Fri, Mar 6, 2020 8:58 AM

Lightroom Mobile: Tif smartpreviews not updated in develop mode in mobile

Ok first the setup:
I start with LR Classic (in a shared album, smart-previews in the cloud) and send a RAW to Photoshop, after I'm done with my edit the saved tiff gets added my LR classic and automatically added to the shared album as a smart-preview too (thats nice).

In LR Mobile I can see my edit in develop mode and in the preview, so far so good.

Then later I continue working on that tiff (sending it to Photoshop via LR Classic again, so LR gets the update). And it does get the update, LR classic shows the changes I have done.

Back to mobile, here I get the old version in develop mode, the preview thumbnail gets updated to the new version, if I open the tiff smart-preview into activity, rating, or info view, I see the updated version as it should be.

But if I get into develop mode in LR mobile, it shows the current version (as it should be), but only for a second and then switches to the version that was first shared when I saved the first edit (that is now outdated and not what LR classic shows or whats actually in that file).

If I switch from develop to the activity, rating, or info views it remains the incorrect older version, If I get back and go into activity, rating, or info view directly without going through develop, its the current version as it should be again.

Biggest problem, on export I always get the old outdated version of this photo, even if I don't export out of the develop mode view.

Responses

828 Messages

 • 

12.9K Points

6 months ago

It is normal, it is badly messed up .... LR mobile is that for the development made in LR Classic or Mobile, it does not 'yet' know how to process files edited in editors external to LR. And probably it never will be.
Look at how is integrating PS and PS mobile and you will understand!

134 Messages

 • 

2.1K Points

No its not normal, if the thumbnail updates correctly so should the whole smartpreview.

134 Messages

 • 

2.1K Points

6 months ago

The Lightroom Web interface also shows the correct photo in develop mode.

So its definitely a bug in LR mobile Android not getting the info that the file was updated.

7.9K Messages

 • 

114.4K Points

6 months ago

Not necessarily. If you go to https://lightroom.adobe.com and look at the TIF after the second edit, has the second edit made it to the cloud?  This may be Lightroom Classic failing to send the re-edited version to the cloud rather than Android failing to pull it back down.

Adobe Photography Products
Quality Engineer: Customer Advocacy

134 Messages

 • 

2.1K Points

Already answered with the post above yours.

7.9K Messages

 • 

114.4K Points

Yes, when I refreshed the screen your other post appeared.  Does this happen every time or just occasionally?  Is your Android device connecting via Wifi or Celluar?

Adobe Photography Products
Quality Engineer: Customer Advocacy

134 Messages

 • 

2.1K Points

Well it's the second time I noticed it, most of the time I do my edits in one go (or don't do major changes I notice at once) , so it might happen every time.

Sync is set to wifi only, this bug is consistent on 3 other Android devices I use.

7.9K Messages

 • 

114.4K Points

Just so I have steps correct.

1. From Lightroom Classic: Sync Tiff to Cloud - Allow to download on Android
2. In Lightroom Classic - Edit in  Tiff from step 1 (Choose Edit Original)
3. In Photoshop - edit image - save
4. New Edit Appears in Classic - allow to sync
5. New Edit Appears in Cloud - allow time to sync to Android
6. Android syncs and shows all syncing activity complete but image does not update in Android?

Did I miss anything? Are you doing anything differently than I mentioned?

Adobe Photography Products
Quality Engineer: Customer Advocacy

134 Messages

 • 

2.1K Points

Sounds about right, maybe missing that the thumbnail gets updated on Android but the image switches back to the initial version on the develop screen on the mobile device.

Champion

 • 

2.1K Messages

 • 

36.3K Points

a month ago

A similar issue was reported recently in the Lightroom Classic forum.

https://community.adobe.com/t5/lightroom-classic/edits-on-photoshop-not-showing-on-lightroom-mobile/...

I've come up with a simple three step 'Edit in PS' that fails consistently on my Windows 10 system using LR Classic 9.3, PS 21.2.1, Camera Raw 12.2 and Lightroom Mobile for Android 5.3.1 on my Samsung Note Pro 12.2" tablet.

From inside Lightroom Classic:

1) Raw File> Edit in PS> Add a text box to record steps
2) PSD File> Edit in PS> Add a new line of text and Crop Image
3) PSD File> Edit in PS> Add a new line of text
(Use 'Save' after each step and not 'Save As')

All three steps display properly in LR Classic's Library and Develop modules and sync to the Web app. Steps 1 and 2 sync properly to LR Mobile for Android 5.3.1, but not step 3 and succeeding Edit in PS> Edit Original operations. It's frozen in time!

As Donna Wetter mentions when I switch from Grid View to Loupe or Develop view  I see a preview with all edits properly applied for about 1.0 sec. So a Smart Preview with the latest edits has been downloaded to the mobile device, but is being over-ridden by the earlier Smart Preview.
Rikk Flohr said: With Store Album Locally enabled, I can duplicate this.
FYI-on my LR Mobile 'Store Album Locally' is NOT selected.











2 Messages

 • 

74 Points

Yes! Same problem.

134 Messages

 • 

2.1K Points

a month ago

Similar or same, this thing has been acknowledged as a bug since almost half a year, something should happen during that time.

Champion

 • 

2.1K Messages

 • 

36.3K Points

Hi Donna, at the Lightroom forum link I posted on of the users does not see the issue on his iOS devices. What mobile device(s) are you using that exhibits the issue?

134 Messages

 • 

2.1K Points

All infos are in the first posts before Rikk Flohr said he can reproduce it, no reason to repeat myself.

Champion

 • 

2.1K Messages

 • 

36.3K Points

Donna, as a Champion and ACP I have the ability to work directly with Rikk Flohr and other Adobe staff. In fact I'll be meeting with them tomorrow via video conference. Just trying to gather additional information for the meeting to determine if it is device or Android version specific. I'm using Android version 5.1.1 (Lollipop), which was the last version update for my Samsung Note Pro 12.2" tablet. It's now up to version 11.

I'll also be discussing a LR Mobile for Android issue with color management that was reported over a year ago. It would be helpful if you could add your comments at the below report concerning what you're seeing on your android mobile devices. Thank you.

https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-collection-sync-to-lr-mobil...

2 Messages

 • 

74 Points

I use an iPhone and Samsung tablet. Same scenario, start process in Lightroom classic. Upload photos to Lightroom cc. Make edits in photoshop, save. Then make more edits. Eventually the new edits no longer export correctly from iPhone using Lightroom mobile. They do seem to work on Samsung tablet.

Champion

 • 

2.1K Messages

 • 

36.3K Points

Thank you GRP Imagery. What model Samsung tablet and Android version are you using?