Skip to main content
Adobe Photoshop Family
bradley_fernihough's profile

14 Messages

 • 

290 Points

Mon, May 23, 2011 2:01 AM

Solved

Lightroom: Losing 'Right click' mouse functionality

Peculiar.

I am losing the ability to use the right click functionality of my mouse within LR.

Of note
- Windows 7 64bit
- on the rest of my computer i have no such issues (anywhere).
- it seems to happen after i have had the program open for extended periods +30-40min.
- only seems to have started with 3.4 (for me at least)
- re-staring Lr solves the issue for another 40 min

Seems to have been reported before
http://forums.adobe.com/message/3321022
http://www.flickr.com/groups/adobe_li...

Responses

Employee

 • 

166 Messages

 • 

3K Points

10 years ago

Hmm. Which things are you right clicking on? I'm guessing they bring up pop up menus, right? My best guess is that something is going wrong to cause the creation of the pop-up menu to fail, which probably means that the process is running out of handles.

In Task Manager, there's an option to additional columns, including ones for various kinds of handles. I'd add those columns and watch those numbers.

There's a system wide limit (and it's relatively low, IIRC), so I'd watch other processes as well. That said, since other apps aren't showing the problem and restarting LR makes it recover does at least hint that it's the one leaking. I haven't seen a leak of that sort for a while, but it's certainly possible. Note that you may see brief climbs and sudden drops in those numbers. Those resources are exposed to Lua such that they have to be garbage collected, so the timing of when they get freed isn't necessarily deterministic or immediate.

I'll take a look and see if I can spot anything. In the meantime, take note of which right click options you're using. It's possible just one of them has a leak and if it's used a lot, it'd eventually starve out the others.

6 Messages

 • 

124 Points

right clicking on the big main image in the center of the LR interface.....

6 Messages

 • 

124 Points

is there any way you can piggie back on my system to see that paybe perhaps Its possible that I may be doing something wrong? would you mind? I am a late night gal, and am up till probably 1,2,3 a.m. Pacific Time. Let me know.

I sure would appreciate it.

This is just silliness!

14 Messages

 • 

290 Points

10 years ago

I have been working extensively in collections - specifically, i will right click and image to either 1. remove an image from the collection or 2. go to the folder it belongs to.

Employee

 • 

166 Messages

 • 

3K Points

Hmm. I tried a bit of this and didn't see any obvious leak of handles. I did get a crash on quit cleaning up some UI objects, but it only happened once out of several tries, so I'm not sure if that's related or just a fluke.

4.5K Messages

 • 

76.3K Points

9 years ago

Right-click stops working sometimes (when I right-click the mouse - nothing happens). I assume its a Lightroom bug, since it continues to work in all other apps. Restarting Lightroom clears it.

Kensington Expert Mouse Model #K64325

Lightroom version: 3.6 RC [788152]
Operating system: Windows 7 Ultimate Edition
Version: 6.1 [7601]
Application architecture: x64
System architecture: x64
Physical processor count: 4
Processor speed: 3.4 GHz
Built-in memory: 7934.1 MB
Real memory available to Lightroom: 7934.1 MB
Real memory used by Lightroom: 450.3 MB (5.6%)
Virtual memory used by Lightroom: 431.9 MB
Memory cache size: 116.0 MB
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1200, 2) 1920x1200

This reply was created from a merged topic originally titled
Lightroom: right-click stops working sometimes..

Adobe Administrator

 • 

15.9K Messages

 • 

295.3K Points

Rob, are you able to find a consistently reproducible set of steps? That would be most helpful.

Sr. Product Manager, Adobe Digital Imaging

4.5K Messages

 • 

76.3K Points

Not yet - tends to happen every couple of hours or so, without rhyme nor reason that I have been able to identify. I've been using publish services heavily - reloading them a lot, and changing stuff. In fact, the disappearing publish services may be connected to the missing right-click - dunno...

513 Messages

 • 

11.1K Points

9 years ago

Rob, you didn't have this problem a while ago, right? Did you change anything, e.g., switch to a 64-bit version or changed a driver, that you can connect to the phenomenon of losing the right-click?

The problem is quite old and it seems funny that you apparently wasn't bothered by it before but are suffering from it now.

4.5K Messages

 • 

76.3K Points

I've had this happen a couple times before in the past, but seems to be happening far more frequently now. Only difference I know of other than Lightroom version is that I've been developing a publish service.

Employee

 • 

166 Messages

 • 

3K Points

Interesting... while I've heard of this and spent a bit of time on a couple of occasions trying to figure out what might cause it, I haven't managed it so far. Your mention of publish services may match with two other cases (one above and one via another conversation) indicating that operations working with collections may be involved. It'd be interesting to know if there are particular commands you're invoking with greater frequency now than before or other specific differences in your usage pattern that might yield further clues.

Thanks!

1 Message

 • 

62 Points

(yes, when in develop mod and deleting a large amount of images) it will not bring up the menu you usually have access to when normally right clickie on the image. Win 7/64 bit/12 GB Ram/Develop module/CR2 files from a Canon 50D and Canon 7D. Only thing that works is closing out of LR all together then reopening.

6 Messages

 • 

124 Points

i didn't change anything - everything has stayed the same. i haven]t used collections until WELL after this has been a problem. no collections in lr2 but lr3 about 5 months after the develop mod stopped working after removing deleted images. P.S. nothing to do with publishing either. (not if that helps or not...)

19 Messages

 • 

250 Points

9 years ago

I experienced the same problem of right-click stopping working today and found this thread through a search on the topic. I run Windows 7 64-bit, LR 3.5. Right-click failed in all parts of LR that I tried, yet worked fine in the operating system and other programs running at the same time. Closing and restarting LR rectified the problem.

22 Messages

 • 

364 Points

9 years ago

lightroom 3.6 on windows 7 64 bit system. catalog has about 800 pictures. after deleting 25 to 50 images from the catalog, using "right click on the image" and "remove from catalog", the right click option freezes and doesn't work for any image along the scroll bar at the bottom. closing the programing and opening again it works. This repeated three times while I was removing pictures from this catalog. I have 4GB memory, and got no errors from LR or windows. i was in the slide show mode.

This reply was created from a merged topic originally titled
LR 3.6 does not respond to right click on image.

Employee

 • 

166 Messages

 • 

3K Points

Aha! I managed to get this to reproduce. I stubbornly removed over 200 images before it started failing, but I think I finally have a bead on this elusive bugger.

I can see an assertion failure message being emitted into the log in the Debugger. I thought sure this was some obscure issue of leaking Windows UI resources, but all my resource counts are right where they were when I started.

Here's hoping I can pick enough info out of the Release build in WinDbg about where that vague error message is originating.

Thanks! -- DT

Update: The former remark about the tracebacks switch providing more clues was incorrect. I don't know why, but though this error appears to be due to a pcall that throws an error, it's bypassing the traceback mechanism... very annoying. Hopefully, I can still break in at the crucial moment to see the error.

Employee

 • 

166 Messages

 • 

3K Points

Found it. I don't know exactly how to fix it yet, but I believe I know exactly what is causing it to happen (and I have a hypothesis as to why the amount of time it takes varies so much from person to person -- it's based on the number of items in the menu which is in turn related to the number of collections, presets, etc one has).

19 Messages

 • 

250 Points

If it helps, I had a second experience with right-click failure today. I'm working on a project with a large number of nested collections. The failure seems to come when I'm working in the Develop module, but I haven't noticed any apparent pattern. I also have a fairly large number of Develop presets on the menu.

4.5K Messages

 • 

76.3K Points

9 years ago

When right-click functionality has been lost, here is the error logged in the -tracebacks upon right-clicking:

[6072]
[6072] L:
[6072] ?:0: attempt to index a nil value
[6072] 0: [unnamed] - 498286368:1114+289
[6072] ---------------------------------
[6072]

Employee

 • 

166 Messages

 • 

3K Points

Weird. That error didn't come up in the locations where I was right clicking. It must be a context specific side effect. In any case, I definitely have this bug cornered so I can write it up for somebody who knows enough about the Windows menu code to fix it without breaking something else.

4.5K Messages

 • 

76.3K Points

I didn't test much: I was right-clicking a smart collection.

Sounds like y'all are hot on the trail...

Employee

 • 

166 Messages

 • 

3K Points

We did apply a fix for the right click problem, FWIW. However, the fix came in after we'd branched to lock down the beta, so it won't be fixed there.

It will, however, be fixed in 4.0 final.

6 Messages

 • 

124 Points

9 years ago

when deleting multiples of images in the develop module approximately deleting 60 plus images. The right click to delete more images no longer works unless you close out lightroom and reopening.

This reply was created from a merged topic originally titled
Right click on mouse in Develop module wont work after deleting many multiples of images.

4 Messages

 • 

124 Points

9 years ago

Hey ya'll - Just curious.

Any info on the delete issues in LR3 after deleting a gillion of them? -

Ironically enough. I downloaded the new LR4 beta. This release won't let me delete even a single image. Whether with delete key nor right clickie.

Even though I am running as admin. Could there be some extra special Mission Impossible Secret Squirrel box that needs to be selected that I don't know anything about?

Anyone, Anyone, Bueller, Bueller ..

Employee

 • 

166 Messages

 • 

3K Points

D'oh. Yeah, I am seeing an error when trying to delete photos from Develop. It worked a few times and then it didn't. It looks like a distinct bug, though.

Which is to say that the right click menu doesn't stop appearing, it's just the "Delete Photo..." operation itself is throwing an error that prevents it from completing. I have a stacktrace, so I just home in on this one and try to get it fixed for 4.0 final. Thanks for the report!

Adobe Administrator

 • 

15.9K Messages

 • 

295.3K Points

Might we need a new topic for that issue?

Sr. Product Manager, Adobe Digital Imaging

Employee

 • 

166 Messages

 • 

3K Points

It would have been better if it wasn't merged with this one, if that's what you mean. Is there a way to "unmerge" it?

Adobe Administrator

 • 

15.9K Messages

 • 

295.3K Points

Unfortunately no. But I can create new topic if the user doesn't want to and quote the problem.

Sr. Product Manager, Adobe Digital Imaging

11 Messages

 • 

382 Points

9 years ago

It's still a problem in LR 4 too :(

Win 7 x64
Microsoft Mouse drivers (default)
16 GB Memory