Skip to main content
Adobe Photoshop Family

20 Messages

 • 

330 Points

Mon, Oct 10, 2011 8:58 AM

Solved

Lightroom: inconsistent behavior when starting

Hi,
I've noted an inconsitent behavoir of LR when it is started in "non-standard" conditions. This is not critical, but upsetting as I get finally exactly the opposite of what I was expecting. (I've always encoutered this bug (since 2.6) on both vista & W7)

All my pictures and catalogs are on external disk:
for each "picture library" the files, the catalog & the technical data (preview, cache) are in a unique Windows directory on an eSata external drive with this approach:
- I can make full backup very easily
- I've a very safe confidentiality of the pictures (when the drive is off...)
- I can use my professional laptop for "personnal use"
And by the way the perf are very good with a 2Terabyte 7200RPM external disk (25 000 pictures of 19 & 50 MP).

The issue is that with this approach, I start from time to time LR without a library on-line and:
- LR asks me if I want start with the default lib or exit.
- I choose "exit"
- LR exits
- I connect my disk
- I relaunch LR
- and LR => starts automatically with the default lib (which is exactly the opposite of what I want).

I believe that:
- either LR should start in the default library at the first try
- or re-ask at the second
but not alone at the second start what I've refused at the first.

It is not a severe but, but it's irritating.

Responses

Official Solution

Adobe Administrator

 • 

15.1K Messages

 • 

287.7K Points

4 years ago

Fixed in Lightroom 3.6 and later.

Sr. Product Manager, Adobe Digital Imaging

130 Messages

 • 

2.1K Points

9 years ago

It sounds like you have your startup preferences set to "Always open a specified catalog", when you launch LR with the drive offline then logically LR can't open it so asks what you want to do. The second time, with the drive online, LR can and does start as specified.

If you want different actions, suggest changing your startup preferences to something like "Prompt me when starting Lightroom", which will give you a list of recently opened catalogs to choose from.

20 Messages

 • 

330 Points

9 years ago

Thanks Jim.
No my preference is on "go to last opened catalog" (or whatever the French translation is). I agree that I could force a prompt or open always in the same catalog. But that doesnt fit what I wish and despite this "detour" the behavior of LR is still strange: When I tell him not to start with the default catalog, it does that without asking the following time.

Any way, some troubles are worse.

130 Messages

 • 

2.1K Points

9 years ago

Even with that setting, LR is still acting logically in accordance with the preferences.

What you seem to be asking for is for the preferences to be ignored on next start after an aborted start up, though it's not entirely clear to me what you would then want LR to do instead?

20 Messages

 • 

330 Points

9 years ago

No, It seems to me that in this case LR isn't working according to the preferences I've set (or I'm confused by m poor english):

- My preference is: open the calatog that I used the last-time
- LR doesn't find it and asks for the default
- I EXIT (don't open the default)
- And the next time LR acts as if I had opened the default (which I don't)

It seems that LR updates the last opened catalog to default whatever my choice is, thus open the default witout prompt the next time.

What I'm asking for is "not change my last opened" if I've open nothing.

130 Messages

 • 

2.1K Points

9 years ago

My bad, not your poor english, my poor reading of it. I had interpreted 'default' to be the catalog on the external drive....in which case I agree with you that what you are experiencing seems illogical.

Apologies for the confusion.

503 Messages

 • 

10.6K Points

9 years ago

Benoit, I was able to reproduce this behavior, and I have logged a bug.