John_R_Ellis's profile
Champion

Champion

 • 

5.8K Messages

 • 

101.3K Points

Fri, May 17, 2019 10:39 PM

2

Lightroom: Imported develop presets copied to wrong folder with Store Presets With This Catalog

When the preference Store Presets With This Catalog is checked, an imported preset gets placed in the Camera Raw folder, whereas a created preset gets placed in the catalog folder. Not only is this confusing to users, but it defeats the purpose of Store Presets With This Catalog. 

Why would a user who has enabled Store Presets With This Catalog want imported presets stored somewhere other than the catalog folder? 

To demonstrate the undesired behavior:

1. Make sure Store Presets With This Catalog is unchecked.

2. In Develop, create two new presets P1 and P2.

3. In the Presets panel, right click P1, do Show In Finder, and move P1.xmp to the desktop. Do the same with P2.xmp.

4. Restart LR.

5. Do File > Import Develop Profiles And Presets, and import P1.xmp from the desktop.

6. In the Presets panel, right-click P1, do Show In Finder, and verify it's in ~/Library/.../ImportedSettings.

7. Check the option Preferences > Presets > Store Presets With This Catalog and restart LR.

8. In the Presets panel, right-click P1, do Show In Finder, and verify it's in ~/Library/.../ImportedSettings, rather than copied to the catalog folder, which is incorrect.

9. Do File > Import Develop Profiles And Presets, and import P2.xmp from the desktop.

10. In the Presets panel, right-click P2, do Show In Finder, and verify it's  in ~/Library/.../ImportedSettings, rather than copied to the catalog folder, which is incorrect.

Tested on LR 8.3.1 / Mac OS 10.14.5.

Responses

Champion

 • 

181 Messages

 • 

4K Points

2 y ago

John, this is not a bug - now that Develop presets sync, they are stored in the ACR folder, unlike other presets and templates. In Preferences you'll now see two buttons - one to get to all but Develop presets (controlled by what you select on Store with Catalog), and one to get to edit ones, in the ACR folder.

Champion

 • 

5.8K Messages

 • 

101.3K Points

2 y ago

When Preferences > Presets > Store Presets With This Catalog is checked, if I create a new develop preset, it gets placed in the catalog folder. But if I import a develop reset, it gets placed in the Camera Raw folder. Why the difference in behavior? 

The intent of that option is to allow develop presets to travel with the catalog on, say, an external drive. But the current behavior won't let a user take her imported develop presets with her catalog, just the presets she created.  That's intended behavior?

Champion

 • 

181 Messages

 • 

4K Points

2 y ago

Thanks, John - I see that I'm wrong ... now when I create a preset it is stored with the catalog if the option is checked... and I have no explanation for the discrepancy.

Champion

 • 

6.6K Messages

 • 

110.4K Points

2 y ago

I queried it at the time and Thomas Knoll stated that it is working as designed (import is different to creation/placing presets in the folder) but I completely it's bad behavior. 

Victoria Bampton a.k.a. The Lightroom Queen

www.lightroomqueen.com

Author of Adobe Lightroom Classic - The Missing FAQ and Adobe Lightroom - Edit Like a Pro books.

Champion

 • 

5.8K Messages

 • 

101.3K Points

2 y ago

I wonder what use case(s) he had in mind? I just spent a fair bit helping a user of my free Fix Presets plugin sort out confusion created by this.

Champion

 • 

6.6K Messages

 • 

110.4K Points

I believe it was Camera Raw compatibility. The whole point of the combined storage was cross-app compatibility. Store Presets with this Catalog was the outlier.

Victoria Bampton a.k.a. The Lightroom Queen

www.lightroomqueen.com

Author of Adobe Lightroom Classic - The Missing FAQ and Adobe Lightroom - Edit Like a Pro books.

Adobe Administrator

 • 

10.3K Messages

 • 

137.8K Points

2 y ago

Probably should rewrite this as an Idea as we are changing behavior that is as-designed...
Adobe Photography Products

Quality Engineering - Customer Advocacy

Champion

 • 

5.8K Messages

 • 

101.3K Points

2 y ago

I changed it to Idea and edited the top post accordingly.

1 Message

 • 

60 Points

7 m ago

Hello Adobe community and thanks in advance to any who might be able to help:

I’ve made several imports in the last couple of weeks. Unbeknownst to me, I left the import preset to my newly created “Portfolio Import” preset instead of my “Raw File Import” preset. So the files have been imported with the wrong preset as well as placed in the wrong folder. Anyone know how I might reconcile this?? I feel like it’s not just a matter of moving the files since I need to have them imported with the correct preset as well. Thanks again to any/all here. 

Champion

 • 

5.8K Messages

 • 

101.3K Points

Hi Funymocha,

 

Since your issue isn't related to this feature request nor is it product feedback, I suggest you start a new thread in the Lightroom community forum:

https://community.adobe.com/t5/lightroom-classic/bd-p/lightroom-classic?page=1&sort=latest_replies&filter=all 

 

You'll get lots of help there pretty quickly.

1 Message

 • 

60 Points

6 m ago

I just spent over an hour trying to figure out where my presets were going and why some presets I bought weren't working. 

The checkbox vs create/import behaviors in LR Classic 10 is very confusing and frustrating. 

I want my presets in the folder with my catalog whether I make the preset myself or whether I buy it.