Skip to main content
Adobe Photoshop Family

2 Messages

 • 

84 Points

Sat, Oct 29, 2011 8:12 AM

Closed

Answered

Lightroom: How do I prevent Lightroom from automatically opening when I mount a camera card?

Lightroom 3 with Windows 7 (and ealier versions) everytime I add a memory stick lightroom opens. This would be OK if it were just pictures but a mempry stick full of word documents? its crazy and has to be fixed, please.

This conversation has been merged. Please refer the main conversation:

Responses

130 Messages

 • 

2.1K Points

9 years ago

It's a user preference.

Edit>Preferences>General Tab. Uncheck the Import Option to "Show import dialog when a memory card is detected".

704 Messages

 • 

8.5K Points

9 years ago

You can also tell your OS what to do when a memory stick is mounted. Windows prefs somewhere.

130 Messages

 • 

2.1K Points

Of course you're right, as changing that preference in Lightroom IS telling the OS what to do (at least on Windows, can't say for Mac), as it causes the Autoplay settings for media types "Pictures" and "Mixed Content" to be changed from "Import using Lightroom" to "Ask me every time".

It also works in reverse....change either of those Autoplay settings manually and it will also change the Lightroom preference.

4.5K Messages

 • 

76.3K Points

9 years ago

It is possible to add logic to detect whether memory card has photos/video to import vs other stuff and act accordingly.

On the other hand, its not that bad to just turn the auto-import option off and just open Lightroom whenever you want to.

130 Messages

 • 

2.1K Points

In theory, again on Windows, it's possible to set the Autoplay setting for Pictures media to be 'Import using Lightroom', and keep the setting for 'Mixed Content' so something else, e.g. "Take no Action" or "Ask.....".

Unfortunately it would seem that those separate settings only 'stick' until the next time you have cause to look at the Lightroom Preferences (for whatever unrelated reason) and you'll find that as soon as you OK out of them the 'Mixed Content' autoplay setting gets reset back to 'Import using Lightroom'. That feels like a minor bug.