Skip to main content
Adobe Photoshop Family

6 Messages

 • 

144 Points

Thu, Mar 31, 2011 6:26 PM

Solved

Lightroom: Facebook Export in broken/errors

Facebook publishing doesn't work at all in LR 3.3. :-(
I get this error (see screenshot) every time. :-(

Here's a corresponding excerpt of my console.log -- obviously a bug that needs to be fixed...

27.03.11 22:31:01 Adobe Lightroom 3[48905] Warning failed to send request 0: -1
27.03.11 22:31:02 Adobe Lightroom 3[48905] Warning failed to send request 0: -1
27.03.11 22:31:03 Adobe Lightroom 3[48905] Warning failed to send request 0: -1
27.03.11 22:31:13 [0x0-0x1d08d07].com.adobe.Lightroom3[48905] Notice 2011-03-27 22:31:13.353 Adobe Help[51959:903] NSDocumentController Info.plist warning: The values of CFBundleTypeRole entries must be 'Editor', 'Viewer', 'None', or 'Shell'.
27.03.11 22:37:44 Adobe Lightroom 3[48905] Warning Oops! An untagged string (?:0: attempt to index field 'albumInfo' (a boolean value)) got thrown far enough that we display it to the user. This shouldn't happen.
27.03.11 22:38:01 Adobe Lightroom 3[48905] Warning AgNewCreationsDialog ERROR New creation dialog failure ?:0: attempt to index field 'albumInfo' (a boolean value)
27.03.11 23:23:25 Adobe Lightroom 3[52086] Warning Could not get album info from Facebook.
27.03.11 23:24:10 Adobe Lightroom 3[52086] Warning Oops! An untagged string (?:0: attempt to index field 'albumInfo' (a boolean value)) got thrown far enough that we display it to the user. This shouldn't happen.
27.03.11 23:24:35 Adobe Lightroom 3[52086] Warning AgNewCreationsDialog ERROR New creation dialog failure ?:0: attempt to index field 'albumInfo' (a boolean value)

Responses

Official Solution

Adobe Administrator

 • 

14.8K Messages

 • 

285.4K Points

9 years ago

These problems should be solved by the official release of Lightroom 3.4:

http://adobe.ly/fva6UM

Let us know if you're still experiencing issues after this release.

Sr. Product Manager, Adobe Digital Imaging

6 Messages

 • 

144 Points

10 years ago

Facebook publishing doesn't work at all in LR 3.3. :-(
I get this error (see screenshot) every time. :-(

Here's a corresponding excerpt of my console.log -- obviously a bug that needs to be fixed...

27.03.11 22:31:01 Adobe Lightroom 3[48905] Warning failed to send request 0: -1
27.03.11 22:31:02 Adobe Lightroom 3[48905] Warning failed to send request 0: -1
27.03.11 22:31:03 Adobe Lightroom 3[48905] Warning failed to send request 0: -1
27.03.11 22:31:13 [0x0-0x1d08d07].com.adobe.Lightroom3[48905] Notice 2011-03-27 22:31:13.353 Adobe Help[51959:903] NSDocumentController Info.plist warning: The values of CFBundleTypeRole entries must be 'Editor', 'Viewer', 'None', or 'Shell'.
27.03.11 22:37:44 Adobe Lightroom 3[48905] Warning Oops! An untagged string (?:0: attempt to index field 'albumInfo' (a boolean value)) got thrown far enough that we display it to the user. This shouldn't happen.
27.03.11 22:38:01 Adobe Lightroom 3[48905] Warning AgNewCreationsDialog ERROR New creation dialog failure ?:0: attempt to index field 'albumInfo' (a boolean value)
27.03.11 23:23:25 Adobe Lightroom 3[52086] Warning Could not get album info from Facebook.
27.03.11 23:24:10 Adobe Lightroom 3[52086] Warning Oops! An untagged string (?:0: attempt to index field 'albumInfo' (a boolean value)) got thrown far enough that we display it to the user. This shouldn't happen.
27.03.11 23:24:35 Adobe Lightroom 3[52086] Warning AgNewCreationsDialog ERROR New creation dialog failure ?:0: attempt to index field 'albumInfo' (a boolean value)

This reply was created from a merged topic originally titled
Facebook export broken.

117 Messages

 • 

2.9K Points

10 years ago

I think this is happening because you're not currently authorized on Facebook. Try this: right-click on your Facebook publish service, choose Edit Settings, and look at the "Facebook Account" section to make sure you're authorized.

We've added better error handling to the next dot release version to catch this.

6 Messages

 • 

144 Points

nope, I am authorized. I can send screenshots if you want.

20 Messages

 • 

686 Points

10 years ago

I think authorization also fails if you have a Facebook business account.

117 Messages

 • 

2.9K Points

10 years ago

You might try the 3.4 release candidate at http://labs.adobe.com/downloads/light..., although if it's not the authorization issue, I'm not confident we've hit your case. Does the album that you're trying to publish to still exist on Facebook?

20 Messages

 • 

686 Points

10 years ago

Julie, was your last post aimed at MetaWop? I mentioned Facebook business account because that's the only one I have made for testing. I know others have managed to authorize accounts so assumed they were using personal accounts. I am also UK-based and that may be an issue too (you never know!). However, I had no problems authorizing my Flickr account.

117 Messages

 • 

2.9K Points

10 years ago

Yes, sorry, that was a question for MetaWop. By the way, Shangara, the 3.4 RC now takes advantage of Facebook's new API for posting to business accounts.

20 Messages

 • 

686 Points

10 years ago

Thanks, Julie, that sounds good.

20 Messages

 • 

686 Points

10 years ago

Julie, tried the Lr 3.4 RC. I clicked on Authorize after logging into our business Facebook account but got same error as with Lr v3.3: Can't Save Changes: Authorizing...

Adobe Administrator

 • 

14.8K Messages

 • 

285.4K Points

I know that there are bug fixes that have been made to 3.4 since they posted the 3.4 release candidate (based on feedback from that build posting) - so she may be referencing that. I'll let Julie clarify.

Sr. Product Manager, Adobe Digital Imaging

6 Messages

 • 

144 Points

10 years ago

Just to let you know: I'm in the process of reproducing the problem. Currently, I'm getting other/new problems with publishing a collection to Facebook.
let me sort it out & I'll post details soon here.

117 Messages

 • 

2.9K Points

10 years ago

MetaWops, can I contact you offline?

6 Messages

 • 

144 Points

sure. how can we manage this? I'm on Twitter (@metawops) -- you too? We could DM us our eMail addresses. Or do you have my eMail address already? (From the registration here or on the Adobe forum?) Then go ahead and mail me. :-)

1 Message

 • 

62 Points

10 years ago

I am not familiar with the log files as posted above and have only seen this recurring error from both LR3.3 and LR3.4 both on Win7 Pro 64bit with 8GB RAM and more than enough scratch disk space:
"Failed to retrieve item info" in two separate pop up windows.

Every time I try to upload a batch to Facebook it sends the first file to the right gallery just fine but then throws that error and fails to proceed to the next file.

I am not keen on the notion of uploading most of a 2000+ image gallery set file by painful file before deadline.