Skip to main content
Adobe Photoshop Family

2 Messages

 • 

80 Points

Mon, Apr 8, 2013 12:35 AM

Lightroom: Display Driver Failure

I just updated to Lightroom 4.4, then tried to edit a .PSD version of an image in Adobe Photoshop Elements 9. When I made a selection and then attempted to my screen started to upchuck (technical term!), I got a message that the display driver had failed. It repeatedly flashed the screen and recovered ... until it gave up and automatically rebooted.

Is the problem due to the update to LR 4.4? Or is the problem in PSE 9? (I've not had this problem prior to the update.)

This was also posted under the produce "Photoshop Lightroom.

Thanks for your response.

Ron Williams
rrwms@insightbb.com

Responses

15.1K Messages

 • 

195.8K Points

7 years ago

Most likely it's just a bug in your display driver.
Have you checked the GPU maker's website for updates?

2 Messages

 • 

80 Points

7 years ago

Sounds like a good way, Chris, to just point the finger at someone/anyone else.

While it could be accidental that the problem arose immediately following an update to LR 4.4, the timing is suspicious to say the least.

It's also true that the change I was attempting was rather complex in that I selected numerous small portions of the image. The number of mini-selections could have challenged the display driver and/or the PC and/or the software (Elements 9).

Your response, however, comes across as a rather flip "It isn't my problem".

Anyone care to provide a more thoughtful response????

15.1K Messages

 • 

195.8K Points

Lightroom may have changed the way it calls the driver. But most likely the bug is in the video card driver (we see a LOT of driver bugs around here, usually fixed by updating the driver).