allankcrain's profile

5 Messages

 • 

124 Points

Thu, Apr 28, 2016 4:21 AM

LIGHTROOM - Deleting a virtual copy deletes the smart preview for both master and copy

Reproduction steps:
1. Create a Smart Preview for a photo (Libraries module, Library=>Previews=>Build Smart Previews)
2. Hide the original file from Lightroom (e.g., rename the original file, disconnect the drive it's on, etc) so you're working with the Smart Preview when doing your editing.
3. Make a virtual copy of the photo (Photo=>Create Virtual Copy)
4. Delete the virtual copy
5. The MASTER photo which was not deleted no longer has a smart preview.

Smart previews should only be removed when all copies of a photo that could potentially use that smart preview are removed. This bug has persisted across several version upgrades.

I keep my primary files on a big slow RAID and edit smart previews on my laptop a lot, and often use virtual copies to have one color and one black and white version of an image. Sometimes I decide I don't want the B&W, or just decide I want to go back and create the B&W after making a few more edits to the original, so I run up against this bug a lot in my workflow.

This conversation has been merged. Please refer the main conversation:

Lightroom: Smart previews disappear for modified pictures

Responses

Champion

 • 

6.5K Messages

 • 

109.4K Points

5 y ago

Can you please confirm your OS and Lightroom version (under Help menu > System Info)?  

Victoria Bampton a.k.a. The Lightroom Queen

www.lightroomqueen.com

Author of Adobe Lightroom Classic - The Missing FAQ and Adobe Lightroom - Edit Like a Pro books.

5 Messages

 • 

124 Points

Lightroom version: 6.5 [ 1067055 ]
License: Perpetual
Operating system: Mac OS 10
Version: 10.11 [4]
Application architecture: x64
Logical processor count: 4
Processor speed: 1.8 GHz
Built-in memory: 4,096.0 MB
Real memory available to Lightroom: 4,096.0 MB
Real memory used by Lightroom: 294.1 MB (7.1%)
Virtual memory used by Lightroom: 4,237.7 MB
Memory cache size: 792.3 MB
Maximum thread count used by Camera Raw: 4
Camera Raw SIMD optimization: SSE2,AVX
Displays: 1) 1440x900

Graphics Processor Info: 
Check OpenGL support: Failed
Vendor: Intel Inc.
Version: 4.1 INTEL-10.14.58
Renderer: Intel HD Graphics 4000 OpenGL Engine
LanguageVersion: 4.10

Adobe Administrator

 • 

538 Messages

 • 

9.9K Points

5 y ago

Thanks Allan for pointing this out.
I could reproduce this issue on Windows.

Thanks,
Sunil