Skip to main content
Adobe Photoshop Family
P

17 Messages

 • 

244 Points

Wed, Oct 21, 2020 7:54 PM

Acknowledged

Lightroom Classic: When trying to add files to Collections I get this error: ?:0: attempt to compare two nil values

I just installed LrC 10 and when I went to add images to a target collection, I get the following error: ?:0: attempt to compare two nil values.  This is really holding me up organizing my photo book.  Please help.

Responses

Accepted Solution

Official Solution

Champion

 • 

5.3K Messages

 • 

95.4K Points

a month ago

A workaround that's helped several so far: Select the problem collection and do View > Sort to change its sort order to something other than Custom Order.

57 Messages

 • 

860 Points

The entire reason for my collection is to have a custom order of photos from multiple folders. Hoping this gets resolved quickly.

10 Messages

 • 

248 Points

Your suggested workaround worked for me. Thanks very much John_R_Ellis

2 Messages

 • 

72 Points

thanks for the workaround!

1 Message

 • 

60 Points

Helped for me to...Thank you.

1 Message

 • 

60 Points

@John_R_Ellis Hi John...Trying to use your workaround...but not seeing View > Sort as an option. Clicking on the collection I want to add from, going up to the menu, clicking VIEW and what next? There is no option to Sort in the View menu. What am I doing wrong?

4 Messages

 • 

92 Points

Go to View Menu >> Grid View (G)

Then below the grid, change the Sort By Option to anything but Custom. 

(edited)

Champion

 • 

5.3K Messages

 • 

95.4K Points

"Trying to use your workaround...but not seeing View > Sort as an option."

Go to Library grid view (e.g. type "g"). Then you'll see the View > Sort menu (see the screenshot):

150 Messages

 • 

3K Points

a month ago

Serves you right for being a beta-tester! ;)

17 Messages

 • 

244 Points

Yes!  I thought it was simply an update.  Wondering if I can go back to my previous version.

17 Messages

 • 

244 Points

Yes. Ok, I just talked to Adobe LcR support and this is a known issue and they are working on a fix which should be available very soon.   If you updated your LRC and Master catalog, you will have to wait for the fix or install the last version of LRC and go back to your previous catalog.  Because I've been working in the new updated catalog for several days, I don't want my work spread over two catalogs so I'll wait for the fix.  If one hasn't updated LRC or your catalog, it's probably better to wait.  IMO.

2 Messages

 • 

70 Points

A work around. If you make a selection and then hover over the destination collection folder, right click and Add selected photo to this collection. It works for me after I get this error.

2 Messages

 • 

74 Points

This works for me too. Thanks!

Champion

 • 

783 Messages

 • 

13.6K Points

a month ago

Works for me on Lr10 and macOS 10.15.7 by using "B" shortcut, Using menu and drag and drop.  

17 Messages

 • 

244 Points

I think it may be related to the same image put into different collections under the same collection set. 

Champion

 • 

783 Messages

 • 

13.6K Points

I tried putting the same images in different collections under the same collection set by changing the "target collection"  to the different collections and it worked fine.  macOS 10.15.7.  I do see a couple of the users having issues are not using 10.15.7 but I can't imagine that would be the issue.  

Adobe Administrator

 • 

508 Messages

 • 

9.7K Points

a month ago

It works for me in Mac and Windows as well?
I am writing you an e-mail offlist to get the catalog.

Thanks,

Sunil

Employee

 • 

56 Messages

 • 

868 Points

a month ago

What is the sort type selected in the UI ?

5 Messages

 • 

102 Points

Where can I see this?

Adobe Administrator

 • 

508 Messages

 • 

9.7K Points

You could see it under the Grid view:

17 Messages

 • 

244 Points

Ok, I just talked to Adobe LcR support and this is a known issue and they are working on a fix which should be available very soon.   If you updated your LRC and Master catalog, you will have to wait for the fix or install the last version of LRC and go back to your previous catalog.  Because I've been working in the new updated catalog for several days, I don't want my work spread over two catalogs so I'll wait for the fix.  If one hasn't updated LRC or your catalog, it's probably better to wait.  IMO.

5 Messages

 • 

102 Points

a month ago

Same issue for me, only happened after the update. On a Mac.

(edited)

17 Messages

 • 

244 Points

Ok, I just talked to Adobe LcR support and this is a known issue and they are working on a fix which should be available very soon.   If you updated your LRC and Master catalog, you will have to wait for the fix or install the last version of LRC and go back to your previous catalog.  Because I've been working in the new updated catalog for several days, I don't want my work spread over two catalogs so I'll wait for the fix.  If one hasn't updated LRC or your catalog, it's probably better to wait.  IMO.

2 Messages

 • 

74 Points

Same problem here also on a MAC. It is 21 days later now. Clearly not fixed yet. Would be nice if they do not release new versions without proper testing first. 

154 Messages

 • 

1.9K Points

a month ago

Please post your System Information as Lightroom Classic (LrC) reports it. In LrC click on Help, then System Info, then Copy. Paste that information into a reply. Please present all information from first line down to and including Plug-in Info. Info after Plug-in info can be cut as that is just so much dead space to us non-Techs.

 

 

 

 

 

3 Messages

 • 

80 Points

@david_golding_1mvs2lwngpf9v 

Same problem for me, Here's mine: 

Lightroom Classic version: 10.0 [ 202010011851-ef6045e0 ]
License: Creative Cloud
Language setting: en-US
Operating system: Mac OS 10
Version: 10.15.5 [19F101]
Application architecture: x64
Logical processor count: 16
Processor speed: 3.6 GHz
SqLite Version: 3.30.1
Built-in memory: 65,536.0 MB
Real memory available to Lightroom: 65,536.0 MB
Real memory used by Lightroom: 2,403.5 MB (3.6%)
Virtual memory used by Lightroom: 11,152.5 MB
Memory cache size: 190.6MB
Internal Camera Raw version: 13.0 [ 610 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 168MB / 32767MB (0%)
Camera Raw real memory: 170MB / 65536MB (0%)
Displays: 1) 5120x2880

Graphics Processor Info: 
Metal: AMD Radeon Pro Vega 48

Application folder: /Applications/Adobe Lightroom Classic
Library Path: /Volumes/PHOTO 2TB/PHOTOGRAPHY/LR Cats/ART/Fine Art-2-2-v10.lrcat
Settings Folder: /Users/stevekeller/Library/Application Support/Adobe/Lightroom

Installed Plugins: 
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Facebook
4) Flickr
5) Format
6) Imagenomic Portraiture 3
7) Luminar 4
8) Nikon Tether Plugin

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: $$$/dvaaudiodevice/SystemDefaultAndEffectiveDeviceName=System Default (Built-in Output)#{comment}DVAAU-4201250: Open the audio hardware preferences page.
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: LR5x42
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon Pro Vega 48 OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-3.9.15
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod 

17 Messages

 • 

244 Points

Ok, I just talked to Adobe LcR support and this is a known issue and they are working on a fix which should be available very soon.   If you updated your LRC and Master catalog, you will have to wait for the fix or install the last version of LRC and go back to your previous catalog.  Because I've been working in the new updated catalog for several days, I don't want my work spread over two catalogs so I'll wait for the fix.  If one hasn't updated LRC or your catalog, it's probably better to wait.  IMO.

3 Messages

 • 

80 Points

a month ago

I'm having the same issue. Just started suddenly. I tried resetting the preferences, no change.

5 Messages

 • 

102 Points

a month ago

Here's mine:

Lightroom Classic version: 10.0 [ 202010011851-ef6045e0 ]
License: Creative Cloud
Language setting: en-GB
Operating system: Mac OS 10
Version: 10.15.6 [19G2021]
Application architecture: x64
Logical processor count: 4
Processor speed: 2.3 GHz
SqLite Version: 3.30.1
Built-in memory: 8,192.0 MB
Real memory available to Lightroom: 8,192.0 MB
Real memory used by Lightroom: 1,197.9 MB (14.6%)
Virtual memory used by Lightroom: 6,847.3 MB
Memory cache size: 63.7MB
Internal Camera Raw version: 13.0 [ 610 ]
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 133MB / 4095MB (3%)
Camera Raw real memory: 154MB / 8192MB (1%)
Displays: 1) 2880x1800

Graphics Processor Info: 
Metal: Intel(R) Iris(TM) Plus Graphics 640

Application folder: /Applications/Adobe Lightroom Classic
Library Path: /Volumes/Extreme SSD/Master Catalogue-2-2-3-2-v10.lrcat
Settings Folder: /Users/jonlewis/Library/Application Support/Adobe/Lightroom

Installed Plugins: 
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Facebook
4) Find Duplicates 2
5) Flickr
6) Nikon Tether Plugin

17 Messages

 • 

244 Points

Ok, I just talked to Adobe LcR support and this is a known issue and they are working on a fix which should be available very soon.   If you updated your LRC and Master catalog, you will have to wait for the fix or install the last version of LRC and go back to your previous catalog.  Because I've been working in the new updated catalog for several days, I don't want my work spread over two catalogs so I'll wait for the fix.  If one hasn't updated LRC or your catalog, it's probably better to wait.  IMO.

5 Messages

 • 

102 Points

a month ago

Hi, I recently upgraded my Lightroom Classic and I've lost the ability to add photos to the quick collection (B). It comes up with the following message: 

Any help would be must appreciated, thanks.
Note: This comment was created from a merged conversation originally titled Unable to add photos to quick collection

1 Message

 • 

60 Points

a month ago

Having the same issue. Here's mine:

Lightroom Classic-Version: 10.0 [ 202010011851-ef6045e0 ]
Lizenz: Creative Cloud
Spracheinstellung: de-DE
Betriebssystem: Mac OS 10
Version: 10.14.6 [18G6032]
Anwendungsarchitektur: x64
Anzahl logischer Prozessoren: 8
Prozessorgeschwindigkeit: 2,5 GHz
SQLite-Version: 3.30.1
Integrierter Speicher: 16.384,0 MB
Für Lightroom verfügbarer phys. Speicher: 16.384,0 MB
Von Lightroom verwendeter phys. Speicher: 2.698,3 MB (16,4%)
Von Lightroom verwendeter virtueller Speicher: 10.831,6 MB
Cache-Speichergröße: 540,5MB
Interne Camera Raw-Version: 13.0 [ 610 ]
Maximale Anzahl Threads, die Camera Raw verwendet: 5
Camera Raw SIMD-Optimierung: SSE2,AVX,AVX2
Virtueller Speicher in Camera Raw: 688MB / 8191MB (8%)
Physischer Speicher in Camera Raw: 690MB / 16384MB (4%)
Monitore/Anzeigegeräte: 1) 2880x1800

Informationen zum Grafikprozessor: 
Metal: NVIDIA GeForce GT 750M

Anwendungsordner: /Applications/Adobe Lightroom Classic
Bibliothekspfad: /Users/carstenkrebs/Pictures/Lightroom/Lightroom Catalog-2-2-v10.lrcat
Einstellungen-Ordner: /Users/carstenkrebs/Library/Application Support/Adobe/Lightroom

Installierte Zusatzmodule: 
1) AdobeStock
2) Aperture/iPhoto-Import-Zusatzmodul
3) Aurora HDR 2019
4) DxO PhotoLab 3
5) DxO PhotoLab 3 Importer
6) Facebook
7) Flickr
8) HDR Efex Pro 2
9) Luminar 3
10) Luminar 4
11) Nikon Tether-Zusatzmodul

Config.lua-Flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: $$$/dvaaudiodevice/SystemDefaultAndEffectiveDeviceName=System Default (Ausgang (integriert))#{comment}DVAAU-4201250: Open the audio hardware preferences page.
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: LR5x42
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 2048
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: NVIDIA GeForce GT 750M OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: NVIDIA Corporation
GL_VERSION: 2.1 NVIDIA-12.0.24 355.11.10.50.10.103
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_point_sprite GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod 

17 Messages

 • 

244 Points

Ok, I just talked to Adobe LcR support and this is a known issue and they are working on a fix which should be available very soon.   If you updated your LRC and Master catalog, you will have to wait for the fix or install the last version of LRC and go back to your previous catalog.  Because I've been working in the new updated catalog for several days, I don't want my work spread over two catalogs so I'll wait for the fix.  If one hasn't updated LRC or your catalog, it's probably better to wait.  IMO.

17 Messages

 • 

244 Points

a month ago

My system info:

Lightroom Classic version: 10.0 [ 202010011851-ef6045e0 ]
License: Creative Cloud
Language setting: en-US
Operating system: Mac OS 10
Version: 10.15.7 [19H2]
Application architecture: x64
Logical processor count: 6
Processor speed: 3.7 GHz
SqLite Version: 3.30.1
Built-in memory: 24,576.0 MB
Real memory available to Lightroom: 24,576.0 MB
Real memory used by Lightroom: 2,554.9 MB (10.3%)
Virtual memory used by Lightroom: 9,235.4 MB
Memory cache size: 308.3MB
Internal Camera Raw version: 13.0 [ 610 ]
Maximum thread count used by Camera Raw: 4
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 1151MB / 12287MB (9%)
Camera Raw real memory: 1154MB / 24576MB (4%)
Displays: 1) 5120x2880

Graphics Processor Info: 
Metal: AMD Radeon Pro 580X

Application folder: /Applications/Adobe Lightroom Classic
Library Path: /Volumes/Thunderbolt LaCie 2big Dock Thunderbolt 3 Raid 1/LR CC Master Catalog/Christopher Priebe Pictures-2-2-2-v10.lrcat
Settings Folder: /Users/christopherpriebe/Library/Application Support/Adobe/Lightroom

Installed Plugins: 
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) ColorChecker Passport
4) DxO PhotoLab 2
5) DxO PhotoLab 2 Importer
6) Export to Autopano Giga
7) Export to Autopano Giga 3
8) Export to Autopano Giga 4.2
9) Export to Autopano Giga 4.4
10) Export to Photomatix Pro
11) Facebook
12) Flickr
13) HDR Efex Pro
14) HDR Efex Pro 2
15) LR/Instagram
16) Nikon Tether Plugin
17) ON1 Effects Standalone 2020
18) ON1 HDR Standalone 2020
19) ON1 Resize Standalone 2020

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: $$$/dvaaudiodevice/SystemDefaultAndEffectiveDeviceName=System Default (Built-in Output)#{comment}DVAAU-4201250: Open the audio hardware preferences page.
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: LR5x42
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon Pro 580X OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-3.10.18
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod 

17 Messages

 • 

244 Points

Ok, I just talked to Adobe LcR support and this is a known issue and they are working on a fix which should be available very soon.   If you updated your LRC and Master catalog, you will have to wait for the fix or install the last version of LRC and go back to your previous catalog.  Because I've been working in the new updated catalog for several days, I don't want my work spread over two catalogs so I'll wait for the fix.  If one hasn't updated LRC or your catalog, it's probably better to wait.  IMO.

Champion

 • 

5.3K Messages

 • 

95.4K Points

a month ago

If this bug is happening to you, please also report the current sort order for the collection.  To see the current sort order, select the collection in the Collections panel. Then look in the toolbar at the bottom of grid view or do the menu command View > Sort.

LR 10 made a significant change internally to how the images in a collection are ordered, so more details will help.

17 Messages

 • 

244 Points

Ok, I just talked to Adobe LcR support and this is a known issue and they are working on a fix which should be available very soon.   If you updated your LRC and Master catalog, you will have to wait for the fix or install the last version of LRC and go back to your previous catalog.  Because I've been working in the new updated catalog for several days, I don't want my work spread over two catalogs so I'll wait for the fix.  If one hasn't updated LRC or your catalog, it's probably better to wait.  IMO.

17 Messages

 • 

244 Points

a month ago

Ok, I just talked to Adobe LcR support and this is a known issue and they are working on a fix which should be available very soon.   If you updated your LRC and Master catalog, you will have to wait for the fix or install the last version of LRC and go back to your previous catalog.  Because I've been working in the new updated catalog for several days, I don't want my work spread over two catalogs so I'll wait for the fix.  If one hasn't updated LRC or your catalog, it's probably better to wait.  IMO.

1 Message

 • 

60 Points

a month ago

I am also having the same issue with slightly different wording.

"?:0: attempt to compare string with nil"

I can add photos to other collections but not to the one for the book I am working on.

 

Sort is by "Capture Time"

My system info:

Lightroom Classic version: 10.0 [ 202010011851-ef6045e0 ]
License: Creative Cloud
Language setting: en-CA
Operating system: Mac OS 10
Version: 10.15.7 [19H2]
Application architecture: x64
Logical processor count: 4
Processor speed: 3.4 GHz
SqLite Version: 3.30.1
Built-in memory: 24,576.0 MB
Real memory available to Lightroom: 24,576.0 MB
Real memory used by Lightroom: 2,362.6 MB (9.6%)
Virtual memory used by Lightroom: 10,898.3 MB
Memory cache size: 1,373.5MB
Internal Camera Raw version: 13.0 [ 610 ]
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 481MB / 12287MB (3%)
Camera Raw real memory: 484MB / 24576MB (1%)
Displays: 1) 2560x1440

Graphics Processor Info: 
Metal: NVIDIA GeForce GTX 775M

Application folder: /Applications/Adobe Lightroom Classic
Library Path: /Users/Gary/Pictures/Lightroom Photos/Lightroom Catalog/Lightroom Catalog-2-2-2-v10.lrcat
Settings Folder: /Users/Gary/Library/Application Support/Adobe/Lightroom

Installed Plugins: 
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Facebook
4) Flickr
5) HDR Efex Pro 2
6) Nikon Tether Plugin

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: $$$/dvaaudiodevice/SystemDefaultAndEffectiveDeviceName=System Default (Built-in Output)#{comment}DVAAU-4201250: Open the audio hardware preferences page.
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: LR5x42
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 2048
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: NVIDIA GeForce GTX 775M OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: NVIDIA Corporation
GL_VERSION: 2.1 NVIDIA-14.0.32 355.11.11.10.10.143
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_point_sprite GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod 

(edited)

17 Messages

 • 

244 Points

Ok, I just talked to Adobe LcR support and this is a known issue and they are working on a fix which should be available very soon.   If you updated your LRC and Master catalog, you will have to wait for the fix or install the last version of LRC and go back to your previous catalog.  Because I've been working in the new updated catalog for several days, I don't want my work spread over two catalogs so I'll wait for the fix.  If one hasn't updated LRC or your catalog, it's probably better to wait.  IMO. 

(edited)

Champion

 • 

783 Messages

 • 

13.6K Points

You only need to do the SAME post once.

17 Messages

 • 

244 Points

Obviously my first post.  Thanks

3 Messages

 • 

80 Points

This happened to me when trying to move some images into a specific folder that's linked to an online gallery (format.com). I made a new folder on format, transferred the existing images to it, and now I can add the new images as well. I have dozens of other folders on the same server, for some reason one got corrupted. Hope that helps for others.