Skip to main content
Adobe Photoshop Family

56 Messages

 • 

878 Points

Wed, Nov 25, 2020 11:48 AM

Solved

Lightroom Classic: v10 slow on start up

Gang, my LRC10 on windows 10 is slow at startup. When launched the screens are slow to populate. 

But over the last two weeks, When launched the Cursor turns to a circle and spins for minutes.  I have tried a system reset.

I have also performed a windows 10 check disak and found a issue with the files on the SSD.

Guess my question can I totally deinstall LRC the reinstall LR10?  Will the system remember my files?

Responses

3 Messages

 • 

82 Points

2 months ago

I'm experiencing the same. Extremely slow navigating the images on the grid. Selecting an image might take upto 5 seconds. 

My laptop is 4 months old and was working great before the upgrade. 

PC, I5, 16Gb ram, dual monitor (mirrored), SSD, etc. 

Any suggestions? 

56 Messages

 • 

878 Points

2 months ago

I now have a error with Catalog and cant start LR10. guess I need to restore?

Adobe Administrator

 • 

9.1K Messages

 • 

126.8K Points

2 months ago

I would recommend a two step process, Ronald. 

1. Reinstall Lightroom 

2. Reset preferences

Clean Lightroom Install Procedure

Close Lightroom

Restart the computer

Use the Adobe Creative Cloud App to uninstall Lightroom

Restart the computer

Install Lightroom via the Creative Cloud App without launching any other programs.

Restart the computer

Launch Lightroom

Wait 5 minutes

then

A Preference File will survive a Lightroom uninstall/reinstall. Sometimes weird behavior is corrected/cured by resetting the preferences.

Reset Procedure:

1. Close Lightroom.

2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom.

3. Overwrite the Preferences when prompted by the dialog.

4. Close Lightroom.

5. Restart Lightroom.

Does the behavior continue after resetting the preferences?

Adobe Photography Products

Quality Engineering - Customer Advocacy

3 Messages

 • 

82 Points

Thanks Rikk, let me give it a go. At the moment its close to unusable. 

3 Messages

 • 

82 Points

@Rikk Wow. Looks like problem solved. Thanks!