Skip to main content
Adobe Photoshop Family

5 Messages

 • 

120 Points

Mon, Jan 15, 2018 1:01 AM

Lightroom Classic: Unable to get copy of edited PS image to appear in LR

I have recently upgraded to Lightroom Classic CC. In Lightroon 6, when I wanted to edit in PS, a small window appears giving me options to edit a copy with the LR adjustments, etc. Now, I don't get that little window and instead after clicking on edit with PS, I get sent directly to PS. After editing in PS, and saving the file, the newly edited TIFF file does not appear in lightroom. And there is no edited copy beside the original as I had in LR6. I can't understand why. My setting are the same as when I had LR6 for external editing. Could someone help me with this please?

Responses

Champion

 • 

3.2K Messages

 • 

56.7K Points

3 years ago

What type of file do you send to Photoshop? The small window with the options only appears when you send an RGB-file to Photoshop, not when you send a RAW-file. When you hit 'Save', the TIFF does go back to Lightroom, but there are situations where this seems not to work. One situation is if the sort order of the grid is set to 'Added Order'. In that case the new TIFF is added all the way to the end of the grid, and that is easy to miss. Sort by file name and check if you do see it now. The other situation is when you are in a smart collection, and the TIFF does not fit the criteria of that smart collection. Imagine a smart collection that searches for five star RAW-files. Because the TIFF is not a RAW-file, it won't show in this smart collection when you hit 'Save'. Check in the 'All Photographs' (sorted by file name).

Johan W. Elzenga,

http://www.johanfoto.com

5 Messages

 • 

120 Points

3 years ago

Hi Johan.  Thank you for your response.  I have somehow managed to resolve the latter problem.  For some reason, it was saving the TIFF  in a different folder.  Not sure why.  I still have a problem with the former issue.  I have set my preferences to Prophoto RGB in external editing.  Is that not correct?  Thank you again for any advice.

33 Messages

 • 

604 Points

3 years ago

Johan,

I have lost a number of files edited in Photoshop after directly exporting from LR. This seems to happen randomly. I have to go back to Photoshop, see where it has placed the edited file, then go to LR and find it in the Navigator section above Collections. I will say that files pretty consistently do appear in the same folders with the original files imported to LR. I have also found PS edits to disappear when a PS file imports back to LR when LR is in Develop mode. I have fixed this by going to Library mode and the PS edits appear correctly.

5 Messages

 • 

120 Points

3 years ago

Btw, I realised my problem with the file not appearing back in LR was because I was using Automate with a Save action that I had set up.  It was going to a preset file folder.  Really strange because when I set up the Save action previously in CS5 PS, I had no problems.  It just saved the file.  Now every time I try to set up a Save Action, it saves to a preset file and doesn't do the simple task of just saving.  Any ideas why this happens?  Thanks.

Champion

 • 

3.2K Messages

 • 

56.7K Points

3 years ago

You can set in the action step whether or not the file should be saved to a specific folder. Apparently that is what you did.

Johan W. Elzenga,

http://www.johanfoto.com

Champion

 • 

3.2K Messages

 • 

56.7K Points

You probably recorded the action, and so you recorded the destination folder as well. The easiest way to avoid this and always save to the current folder is not to record the save step, but to add it via 'Add Menu Item'. That allows you to just add a 'Save' step, without a destinstion path.

Johan W. Elzenga,

http://www.johanfoto.com

5 Messages

 • 

120 Points

Sorry to seem so dense.  But I am finding it a bit difficult with this new version of PS.  Before when I would click Save, it gave me options how I wanted to save the file.  Now, when I click save, it just automatically does it.  Only when I click Save As will I see the destination folder.  So I am unable to set in the action step whether or not the file should be saved to a specific folder.  But as I seem to be getting nowhere there, I am interested in the other solution you gave me.  

Where would I find the 'Add Menu Item'?  I can't seem to find it.  Thank you again.

Champion

 • 

3.2K Messages

 • 

56.7K Points

You have to use 'Save' if the image was sent from Lightroom to Photoshop. The reason why you don't get a destination dialog is because Lightroom already knows the destination: the original folder. And that is crucial for this new image to be automatically added to the catalog. If you change the destination by using 'Save as', how is Lightroom going to know where you saved it?

Sorry, it is 'Insert Menu Item', not 'Add Menu Item' (I used my iPad when I typed it, so I could not check). It is in the Actions Panel. Select the last step of your recorded action, then use this to add the 'Save' step instead of recording that step.

Johan W. Elzenga,

http://www.johanfoto.com

5 Messages

 • 

120 Points

Thanks for the response.  I have tried what you suggested, but when I play the Action, the save screen shows up and it is set up to save it as a PSD copy.  I thought it was to be automatic so it will save into the original folder?  I am sorry, I don't know why I am having such a hard time with this.  When I save each file individually, I have no problem.  But I process a lot of photos so I just want to automate it.  Thanks.

Champion

 • 

3.2K Messages

 • 

56.7K Points

Yes, it should work automatically, because simply hitting Cmd-S on a Mac or Ctrl-S on a PC works too (and is actually the way to fo it). No idea why the action won't do the same.

Johan W. Elzenga,

http://www.johanfoto.com